Project root key is not changeable anymore

project root key is not changeable anymore

i.e. i can`t change from E to - (no root key)
I´m afraid this effects my recordings from scratch
what can i do to be able to change this or turn it off!?
or is this a bug in c11 ?

Hi,

What happens, if you try to change the Root Key, please?

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

hi martin,

when i try to change the key to „no key“ (-) nothing happens, it will be ignored

Could you try in the Cubase Safe Start Mode[Disable preferences], please?

hi martin,

tried safe start as well as trash preferences!
still not able to turn off the root key!

Hi,

If you click to the Root Key afterwards, does it show the - symbol in the drop down menu to? Or does it show the wanted Root Key note?

yes, but all files don’t! even in the pool
it’s not changeable!

Hi,

Then it seems to by a GUI but only.

Are you sure the whole project should transpose when changing this?

i just wanna turn it off, to no key at all!

@Martin.Jirsak I don’t think this is a GUI bug, but instead a real coding issue.
However this isn’t with the Project Root Key in the Project Toolbar (this one can be disabled), but with the Root Key for Audio Clips and MIDI Parts, either from the Info Line or in the Pool.

Since the [ - ] is displayed in the list, and we are able to highlight it and click it, we are expecting the Root Key to change to “none”, but it does not. This is a serious problem because once we set the Root Key for an Audio Clip or a MIDI Part, we can no longer exclude them from the Project Root Key transposition, and the root key information will now be included in the audio files no matter what.
This completely breaks basic premise of the Root Key feature.

Furthermore, when we first set the Root Key, the action is listed in the History, but cannot be undone from here either. Note that every time we click the [ - ] value, a new entry is added to the History, while when Root Key is already set to a key, C for example, selecting C multiple times do not add any action, since it is already selected.

So this experiment proves the underlying code is failing to select and apply [ - ] properly, this isn’t just a GUI bug.

Root key cannot disable history