Quantize Pitches function doesn't work reliably

Quantize Pitches function in Key Editor → Scale Assistant is not reliable. Sometimes it moves even those notes that are already part of the chosen scale, other times it moves a note further than to the nearest pitch. Moreover, in “Editor Scale” mode you will often obtain different results than in “Chord Track” mode (even if the Chord Track contains the same scale). Please, see the repro-steps below.

Let’s have the following initial note sequence:

image

From the picture it can be seen that we have selected “Use Editor Scale” option and particular scale: “E Diminished”. After clicking on “Quantize Pitches” we will obtain the following result:

image

Here, note “a” is transposed to “b”, despite the fact that “a” is already a part of “E Diminished” scale. Which is incorrect behavior, I suppose.

Now, let’s undo this operation, then choose “Use Chord Track” option and notice that the corresponding scale event is also set to “E Diminished”. After clicking on “Quantize Pitches” in this setting, we will obtain the following result:

image

Now, the context was the same, so we should get the same result, I assume. However, as you can see, the result is completely different: note “a” remains in place (which is good) but note “h” has been trasposed to “a” (why not “b”?) and note “f” has been transposed to “e” (why not “fis”, as in the previous setting?).

Interestingly enough, when using “Transpose to Scale” function within MIDI Logical Editor, we will obtain the result I would actually expect:

From this observation I conclude that Quantize Pitches function in Scale Assistant is not reliable yet. Can you confirm this issue, please?

1 Like

Hi, all,

I would like to bump this issue. Do you use Quantize Pitches function? If so, can you confirm my findings?

Thank you in advance!

Hi,

Reported to Steinberg. Thank you.

1 Like