quantize sliced audio

When I want to quantize sliced audio, the audio does not snap to the nearest point in the grid, but to a seamingly random place bars away (still off the grid and always to the left, ie sooner)… It is a mistery to me why this happens.( I use a fixed tempo…) I have to move slices manually for them to snap correctly…What’s going on?

Check and see if you have the iQ (Iterative quantize) option checked. I was seeing the same behavior and have yet to figure it out (I’m thinking it may be a bug). With iQ unchecked the tracks quantize as expected (though it is a hard quantize only). What is odd is that the iQ appears to work OK when I use it to quantize multitrack drums in an edit group folder, but I couldn’t get it to work properly with a single audio track. I do need to do some more experimentation, though.

yes, I did have the iQ option checked, and if I uncheck it quantizing will work. So thanks for that. But (big but!) it will only work if I slice directly from the sample-editor! I’m used to edit audio in the audio-editor. If I double-click the audio in the audio-editor I open the sample-editor, and if I create slices via this route, the whole sliced sample will offset to the wrong spot (might be in any direction, not just back as I said earlier…) even before I’ve done any quantizing at all! The mistery remains but we’re making some headway…


Ok…now that I’ve had some time to investigate this further it definitely appears to be a bug.

I’ve found that audio events may not quantize properly with the iQ option (iterative quantize) until you change the quantize preset from the quantize panel. For example - slice up an audio event somewhat near the grid and try to quantize just one of the events to 1/16 using the panel with the iQ option checked - you will see the event moved around to random positions that are not correct. Use the undo button to the left of the quantize button to start over again. Now change the quantize preset to 1/8 or 1/4 and then switch it back to 1/16. Now click the quantize button and the event will quantize to the nearest 1/16 by the percentage entered in the iQ box as it should. It appears that you need to do this every time.

Wow, that explains a lot when I was trying to use it last week. It seems to me that there are so many new bugs that I’m having a hard time using Cubase 6… I’m going to hang in Logic Land a little until a patch is out :frowning:

Well done for fault finding this one fishtank…Hopefully Steinberg will note the bug soon.

Interesting - I’ve yet to examine this; will get to it over the weekend…

reported (28212)

I’m somewhat relieved to find this in here as it proves I’m not crazy or doing something completely stupid. But, seriously, how on earth could something like this slip through beta testing? I’m not trying to bash on you, because I am overall pretty impressed with Cubase 6 and the new direction you’re going. But Iterative Quantizing on audio parts is, as a matter of fact, completely unusable. I found this within the first 30 minutes when I used the new Version for the first time ever!!! Somebody must catch this during testing?

I made a post about this a while back. glad to see them do something about it.


we have tested this function and had a close look to the reports here. It looks that this feature is perhaps misunderstood.

Perhaps some of you could post here a screenshot of the quantize pannel together with a short description of what you want to archieve, and what you would expect to happen.




I have quantized multitrack drums in an edit group on about four songs using the new iterative quantize feature and so far it seems to have worked as expected, it is when I try to quantize an audio event by itself that the iQ feature appears to not function properly. Many others have also experienced this as well (which is evident in this thread).

Audio events have always quantized from the beginning of the event to the nearest grid setting. The new iQ (iterative) feature should move the event a percentage there instead of all the way allowing the “feel” of the track to stay in tact. When you try to quantize an audio event on an individual track that is cut up (not processed with hitpoints, but that does not work properly either, I believe) it will work as expected with the iQ option NOT selected - but places the events seemingly at random points instead of a percentage of the distance to the grid when you try to quantize using with the iQ enabled. My previous post describes the behavior as well as the inconsistencies in what it does when you change the grid settings back and forth on the quantize panel.

I am quite confused by your post as this SURELY has to be a bug. Can you explain to me what we are misunderstanding about it?

Any information Steinberg? :frowning:

Yep, I’ve seen something very unexpected with some MIDI Notes, using iQ :
Some notes are moved in the wrong direction.
( So it does not seem to be an Audio-Only issue )

Answering Chris’ question :
Example ( V5 project ):
A note, that is a bit early, should be moved back in time so that it’s only a tiny bit early.
That’s what anyone would expect, when using iQ with 80%, nonQ off and magnetism off …
But iQ ‘thinks’ it should be ‘attached’ to the preceding quantize value
and moves the note forward by an extreme amount, so that it ends up
a bit behind the preceding quantize value and thus at a completely wrong position.

Maybe an incompatibility of the new quantize engine and V5.x projects ??

bye, Jan

It’s been reported & given an official bug number, so it is being looked at…Chris’ post 5 up from yours covers this.

And then Chris said, everything is working as expected, when they tested it.

So if we want this fixed, we need to help them out.

I may post a cpr showing the MIDI iQ error, if I can find some time …

bye, Jan

quite plain and simple this is definitely a bug. i just quantized a whole record and it was a nightmare because of this bug. it’s simple. make an audio slice, 90% of the time pressing Q will work correctly but other times it will go to the wrong beat(like i’ll be 2ms from the next 16th note but instead it will go to the one 100ms away). Happens about 1/10th of the time. I certainly hope they aren’t having trouble reproducing this but i can make a video or something if i have to.

I should point out i am NOT using the iQ button and just trying to do a straight quantize. I just want this and the awful inability to make a shortcut to the quantize panel style “crossfade” bugs to be fixed asap because they’re making my job almost impossible when it comes to attempting to hand quantize parts like i used to be able to in C1-5.5


Hi zack,
was this project started in V6 or in V5 ?

it seems to work only if you move the “S” start event vertical line in the sample editor
For example :
-take an easy rythmic audio like 1/4 hihat

  • double clik on it to open the Sample editor
    -Create the slices as usual: now you have all the slice portion of the audio with each time a vertical line at the begining (“S”)
  • Now if you move this “s” to right and come back at the same point now you can I-quantize and it works
    -BUT as you I don’t want to this for each portion;-)
    so hope for quick solution from the creator
    Best regards

yea that’s the thing, I have ZERO desire to open the sample editor when i’m working this way. I’ve never had to before and shouldn’t have to start now. I do like using the new automated quantizing methods using hitpoints on the rare occasion i’m dealing with drums simple enough to use it on, but more than 1/2 the time. This bug needs fixing pronto or i’m going to have to give up on Cubase 6. Or just start my projects in 5.5 which would be sad.

My other peevs about C6 might just take me getting used to them, but this is a bug and needs to be dealt with in the next update. There’s no reasonable reason the Q button should stop working correctly in Cubase.

To answer previous question, projects were started entirely in C6.