Question about Fonts on Mac OS 10.15.5 (Catalina)

OK,

I open a document and I get this warning:


However, you can see from Font Book, I have this font installed on my system:

However, under my “user” Petaluma does not appear. Only under “Computer”. Where does Dorico draw its fonts from? I have not touched Petaluma and some how it was installed in the computer and not under my user. I am not sure what is going on, but some clarification about where Dorico is looking for fonts will help me immensely.

Robby

Petaluma is installed by Dorico, so it’s a “Computer” font, not a “User” font. As has previously been discussed at length, here, for instance, Petaluma only has a Regular variant. Dorico is warning you that it can’t find an Italic variant - because none exists - and so it is doing its best to automagically show an italicised version on screen. You may have problems when you try to e.g. export files with italicised Petaluma, given an italicised variant of Petaluma can’t be embedded in the PDF.

The Problem is that Petaluma Script does not have an Italic. However, somewhere in Dorico’s Font Styles, something is set to use Petaluma Script in an Italic style.

(This is likely because it was originally set to Academico Italic, and you’ve changed the default text font to Petaluma Script.)

OK… I think Ben is onto something here. I don’t remember changing anything to italic, so probably it was Academico Italic that was later changed.

@Leo, I understand the reasoning that it is a computer font. But as of yesterday, Bravura was not a computer font for me. I was a User font, which is why I was very confused. But I think things are sorting themselves out now with font location.

Robby

It doesn’t matter whether you changed anything to italic or not - Dorico does this by default.

Here, for instance, are the settings for the Bar numbers (parts) Paragraph Style.

Where it says “Parent: Default Text” in the top right corner, that means use whatever the settings are for the Default Text paragraph style.
Where the switches to the left of “Style” and “Size” are turned on, they mean override whatever was set for the Default Text paragraph style and use these settings instead.

By default, bar numbers are italic, chorus lyrics are italic, dynamics are italic, etc.

Ahhhhh… OK. This hasn’t happened before… but now it all is making more sense.

Thanks for the insight.


Robby