Quick Control & TouchOSC Hell: Please help!

Hi there,

I am currently setting up my first TouchOSC app with Cubase 11 Pro using MIDI CC via Generic Remote Control. All working fine so far with all the standard commands.

I also wanted to set up 8 rotaries in order to control the Track and VST Quick Controls. This got pretty fast really messy! At first it worked, then not and no I have more than strange behavior with the setup. I tried different MIDI channels, CCs etc., read the manual, searched threads but I could not find anything helpful to my problem.

The current behavior looks like this. I can control parameters of a loaded VSTi with the track controls via the inspector. When I try to control the parameter via the TouchOSC app it does move the respective Quick Control slot BUT from another NOT selected channel? WHY?!!! Driving me crazy! :sob:

Here is my setup:

Here is a video that shows this weird phenomenon: (sorry for the bad quality)

Video:

Quick Controls Touch OSC Cubase Problem - YouTube

Assigning TouchOSC MIDI CC via MIDI Learn from the VSTi works just fine, BUT as long s TouchOSC is in the “ALL MIDI” the Retrospective Recording does not work anymore while playback. That is why I need the Quick Controls as an interface.

Please Help!!! :pray:

Hi,

Could you try with an Audio tracks first, please?

1 Like

You’re mapped to the wrong quick controls, there are two types (Which is confusing, i know):-

and

Make sure your controller is only mapping to the one you want (i.e. Track controls), and not to the VST Quick Controls. I’d imagine you have both setup right now? Also, what is your other “Generic Remote” for? Is that mapping fromTouchOSC too?

Personally I’d create a single Generic Remote entry and map what you want in there, I don’t use the standard pre-sets.

2 Likes

Hi,

thanks for your answer and the links. But as I wrote I actually read the manual and I am well aware about the two types of Quick Controls. I even watched some videos on the topics from the Steinberg channels. Seems like the quick conrols haven’t been updated since more than 7 years. :man_facepalming:

In the video above TouchOSC is only routed to the Track Quick Controls, not the VST Quick Controls or the Generic Remote. I want to use the Track Controls because I want to be able to individually set up the parameters for all 8 Quick Controls for third party VSTi. With the VST Quick Controls you can somehow edit the parameters with the stone age “Remote Control Editor” but I only get the first 4 working, not all 8. It is really messy and clunky.

I also tried setting everything up via a single Generic Remote. Unfortunately I was not able to find the “Track Quick Controls” there, only the “VST Quick Controls” manager. Am I missing somthing?

Hi Martin,

I am close to giving up. I tried with an empty project:

  1. Setup TouchOSC only with Track Quick Controls with an Audio Track:


    → MIDI Learn in the Track Quick Control Editor picks up the correct MIDI CC.
    → The Track Quick Controls of the Audio Track are NOT responding to TouchOSC
    → Checking with MIDI Monitor on a MIDI Track, the correct CC are received from TouchOSC

  2. Setup Touch OSC only with VST Quick Controls with an Instrument Track:


    → MIDI Learn in the Track Quick Control Editor picks up the correct MIDI CC.
    → VST Quick Controls DO respond to TouchOSC

I can’t figure out what the problem is here really. And actually the Track Quick Controls worked before with the very same setup.

Is it important to have a specifi MIDI channel?

Do I have to change some preferences anywhere?

Hi,

If you want to use the Track Quick Controls, make sure the TouchOSC MIDI Port is not in use for the VST Quick Controls, please.

Wait what? I have both on the same port with different CCs on the same channel. I’m not having any issues. In fact I have the same port with both of those AND two different Generic Remotes. If this isn’t suppose to work, then I must have MIDI faeries.

1 Like

Hi Martin,

as described in my previous post, I had TouchOSC MIDI Ports only in use for either the Track or the VST Quick Controls, not at the same time. But as oqion mentioned, this should be possible anyway.

I tested further and recognized the following behavior:

Remote controlling via TouchOSC is stuck to the first track it was controlling the Quick Controls, regardless track selection. I created an audio track in an empty project, assigned quick controls and then controlled them via TouchOSC, all good. Then I created an instrument track, assigned quick controls but TouchOSC was still controlling the Quick Controls of the audio track, even if the instrument track was selected. When I deleted the audio track and again reassigned the Quick controls at the Instrument I could control them with TouchOSC. I repeated this with different track types and order, always the same result.

Is there a preference that locks the remote control of quick controls somehow to a specific track or the first controlled track or something like that? I expected that the hardware controller should control the Quick Controls of the current selected track right?

This also only applies to Track Quick Controls not the VST Quick Controls.

Maybe someone has an idea. Much appreciated! :slight_smile: Thank you

A Video that shows what I decribed:

so it actually controls only the first added track (regardless if audio or instrument track). If you delete the first added, it will control the second added track and so on. It completely ignors track selection.

To me this looks like a Cubase isse. I also tried with other hardware controllers, and the behavior was the same. So it has certainly nothing to do with TouchOSC.

Ok, that’s supper weird. At first I thought it might have something to do with assigning a “Rack” Quick Control to a “Track” Quick Control, because I have never done that… I mean, why would I? But then I tried it and it worked just fine. Confusing, but it works.

Then I thought maybe you just were never moving the “knob” past the pickup point, but then, I don’t know if you have the pickup box checked in the TQC setting. I haven’t ever not checked that checkbox. I honestly don’t know why it isn’t the default because the only time you wouldn’t want it is if you have motors. But I turned that off, and it still worked. Jumps around, but it works.

So it has to be something about the TouchOSC. Have you opened Protokol to see what is actually being sent? Is there something in the TouchOSC script that is locking it to a particular track somehow. It’s really strange.

“A few minutes later”
So then I noticed that you selected “get default QCs from plugin”, which I have also never done, because those are the Rack QCs, and I have sliders for those, so why would I? And then I selected another track and moved the slider and thought oh, that’s not moving the value. But no, I was moving the Rack QC slider, not the Track QC knob, so I moved the knob and it worked.

So maybe… maybe it is something like that somehow.
By the way, the RQCs and TQCs will work at the same time as this test shows. If you select an audio track and move a RQC, it is still focused on what is selected in the Rack, not the track, but that changes when you select a track That has something in the Rack. It’s all very confusing, but useful too. If you are sending CCs via “learn” from a MIDI track and you are playing two things at once in a performance, then you can control two different instruments that way, and as you have shown me, you can control a third separately by moving the RQCs over to TQCs on one of the instruments. Very Cool.

You can also control more than one with the same “Learned” Controller by setting them to the same controller coming from two different tracks. This only works if you are using MIDI Sends though. If you are direct routing the midi track to the Instrument, the instrument has to be in “monitor” mode. And if you are using MIDI tracks, this isn’t what you want.

Ok, more info than you asked for, but not a solution to your problem.

I wish I knew why yours isn’t working though.

1 Like

Hi oqion, yes indeed very weird. Thank you very much for checking on your end!

I don’t think that it has something to do with TouchOSC. I tried with other MIDI hardware controllers today and got the same results. I checked all preferences I might have missed but could not figure it out.

It happened before that I accidentally activated some hidden Cubase preferences but from my research I could not find anything that is triggering this behavior.

I am working with a template, where nearly all VSTis are loaded as deactivated Tracks. So as a workaround I will set up TouchOSC directly with the MIDI setups/MIDI learn of the instruments itself.

Nevertheless it would be great to get solution to this somehow.

Thanks everyone!

There is a setting for having the Rack QC focus not follow the track selection, it’s in the gear at the top right of the rack.

My complaint there, is that when it doesn’t follow track selection I have found no way to change it. So if you want the RQCs to map to a particular instrument, you have to select that track, and then change the setting before you select another track. So, I just leave it, and always select that track and control everything through a MIDI track.

1 Like

Very strange. The only time I’d expect so see cross-track control like that would be with something like an MCU remote mapping whereby you can access tracks that aren’t necessarily selected on-screen.

But you have nothing like that setup(!?)… So even if TouchOSC was sending out MCU commands there’s not a matching remote to deal with those commands - so very mysterious…

Have you tried changing the ports on each of those generic remotes to be be ‘TouchOSC Bridge’, and then back to ‘Not Connected’ again and saving? i.e. just to ensure that they are saved with nothing selected.

It may be that you need to run Cubase in safe mode disabling prefs and see if it does the same.

Also, try not running the standard presets and mapping the quick controls in your own generic remote, they are:-

VSTi Quick Controls:-
image
VST Quick Controls Manager > Device > Quick Control 1…8

Track Quick Controls:-
image
VST Mixer > Selected > QuickControl1…8

Note: You need a track in your project for those options to appear.

2 Likes

Oh, that sounds promising - good spot!

1 Like

Thanks, but that’s RQCs not TQCs. so… probably not, but worth a try.

Hi,

thank you very much for your answer! :slight_smile: I have tried changing the ports with saving and everything but this hasn’t solved it. As I said I also tried with different hardware controllers and I also checked with MIDI monitor. The routing of the MIDI CC data seems not to be the problem.

Ahhhh I haven’t expected to find the Track Quick Controls in the “VST Mixer” device in the Generic Remote Control. I will try that right now and let you know if hat one works. Thanks for that :pray:

oh my god. I just wanted to try your Generic Remote suggestion but there are no Quick Controls for “VST Mixer > Selected > Quick Controls” :sob:


I did say you need at least one track in the project, just add a Retrologue track or something, then it will show up. :slight_smile:

1 Like

Oh maaan :man_facepalming: Thank you! I have to say it is not really intiuitive.

I got it to work. Unfortunately it doesn’t solve my problem. The hardware controller only controls the Quick Controls of the first selected track. If I delete that one, it controls the second created track etc. Doesn’t matter if its audio or instrument tracks.

And now, in the Generic Remote setup it says explicitly “selected Track”. So more than weird! :unamused: