Random Spikes With Cubase 8.5.30

Copied over from ‘General’ forum as it probably will have a better chance of answering here:

ASIO Performance Spikes in Artist 8.5.20 - Help
Postby Seeker_UK » Tue Mar 07, 2017 10:41 pm

The title says it all really.

Running a Dell Optiplex 780 (latest bios - A18), 4GB RAM, i7 (2600) 3.4GHz processor, Sapphire AMD Radeon HD 5450 1GB, Focusrite Saffire 2i4 2nd Gen.

I had 8.5.20 (32-Bit) working perfectly until recently. Now at some random time, typically 2-3 minutes the CPU average hits 100% and causes a dropout, even if it’s running at 20-30%. DPC Latency Mon and Latency Check shows no issues for processors but occasional page file faults but nothing to suggest any issues.

Having read many threads on this, I have:
Switched off power saving in BIOS.
Disabled c-states in BIOS
Changed power settings to highest performance (ie no hibernation / sleeping) but have not used Steinberg Power Scheme.
Changed the NVidia video card for the Radeon and installed latest driver - only driver was installed, no other software.
Changed an Alesis io|2 for the Focusrite with latest drivers (4.15) installed.
Ensured the USB mouse and Focusrite are on difference USB hubs.
Updated the NIC driver to latest from Intel site (cured the spike every 4s observed on DPC Monitor)
Updated the USB drivers to latest Intel drivers.
Tried Cubase with ASIO guard on and off.
Tried ASIO4ALL, Generic ASIO and Focusrite ASIO Drivers.


Nothing seems to make any difference and I can’t see a link between a particular activity or plugin(s) used and causing the spike - it happens regardless of the amount of tracks / plugins used.

The only things I can think of that are left to try are a complete reinstall (I’d rather not), install a USB 3.0 adaptor card for the Focusrite, roll back to Windows 7, buy a new PC or finish with Cubase.


UPDATE
This was reported to Steinberg tech support on 8th March - no response yet, not even an acknowledgement. :imp:

I installed the 64 bit version but kept it at 8.5. Exactly the same symptoms.

I’ve updated to 32 bit 8.5.30 and that hasn’t sorted it.

I’ve kept the mouse and Focusrite on separate USB ports.

Run Latencymon and everything is OK.


Please, can anyone advise what else to try; I can’t make music anymore.

My recommendation would be a complete reinstall.
I also suggest watching the following third party video on CPU performance:

https://www.youtube.com/watch?v=GUsLLEkswzE&feature=player_embedded

Joshua,

thank you for the reply - it’s nice to know someone in Steinberg cares about customer support.

Thanks also for the link to the vid - I had watched it as part of the Google searching to sort out this annoying issue. As a user of Cubase for the last 15 years, it helped confirm some of the considerations around performance if not actually giving me any pointers to what is causing the random spike.

When you say you recommend a complete reinstall, are you referring to a reinstall of Cubase or Windows 10?

Thanks.

Is anyone going to bother actually trying to help me out here?

I’m afraid so. Realtime audio performance is heavily hardware/drivers/OS depending. Every change on one of them could potentially be devastating for your DAW. Each set of hardware can react differently. Steinberg can’t test all hardware combinations, neither can’t the community. Steinberg could sell Cubase appliances or certified workstations, but they don’t. Next best thing is buying a workstation from a recognized DAW builder. Most of the time you could also buy support for this kind of issues from them. For a (imho) relative small premium you get carefully selected hardware and in some degree support. If you are serious about Cubase I’m afraid you have to use optimal hardware.

You could also make regular snapshots (backups) so you could return to an earlier state. But that takes dedication or in some degree automation/scripting. Not very practical either.

Hope something works out for you. Not making music is a bitch :wink:

da10us - thanks for taking time to contribute. Much of what you say, I very much suspected anyway from my 10+ years of Cubase ownership and, for that I don’t expect Steinberg to be in a position to fix everything. Like you say, a proven DAW PC (or Mac) might be the answer.

However, what I do take issue with is the pretty poor customer service they should provide. Not even an acknowledgement of receipt of my technical issue and no apparent means to contact them when that seems to be failing. A quick “hi, we’ve got your report, sorry you have a problem and we’ll get back to you in X days” should be the accpetable minimum.

This is now one month on from raising an issue with Steiberg and NOTHING. Not even a courtesy response.

Frankly, this level of customer support is appalling.

You said that your CPU usage in your OS spikes to 100% when this happens, so there is no problem with Cubase, but its in your OS (something is causing CPU spike, and its not weird that real time audio chuckles at that moment). Check in Process Explorer from SysInternals what proces is taking this cpu power when spike occurs is it system or cubase or some AV or something else.

Morak,

Thank you for replying - it is certainly been more useful than Steinberg have been. I have used Process Explorer and nothing was out of the ordinary. I wonder when I stated ‘CPU Spike’, I used the wrong term - I meant a VST performance spike (as opposed to the ‘disk’ performance on the meter in Cubase).

I have done some more digging and it seems that Intel drivers can be an issue. I have removed all the Intel drivers on the PC and let Windows install its latest and best (following an upgrade of Windows 10 to the latest build). Running dpclat shows an almost constant, 50us latency (occasionally rising to 500us) which should be good enough to run Cubase with no issues. However occasionally, and even when running only one VST instrument or 2 or 3 tracks of audio, it still spikes for no apparent reason.

Seeing the number of questions about performance related to Cubase 8 / 8.5, there is obviously something up with Cubase for it to be too sensitive to PC issues. Let’s face it - if Reaper can get it right, so should a well established company like Steinberg.

Wow. At this point if I were in your position I would do a Windows 10 reinstall, if only to be certain that you have really isolated the stuff running to the OS and Cubase.

The fact that that it’s periodic points to some kind if software doing something, who knows what though… The most harmless-seeming drivers can do big damage.

Have you tried ASIO4ALL with your computer’s internal “sound card”? :question: If “dpclat” is “DPC Latency Checker” http://www.thesycon.de/eng/latency_check.shtml, how are getting around its 1ms offset in Windows 8/10? :question: Did you ensure that Windows isn’t allowed to shut off your USB devices “to save power” (see picture) and that you are plugged directly into one the computer’s USB2 or USB3 ports? :question: What sample rate and buffer size are you using with the Scarlett (not Saffire - right?) :wink: Increase your Cubase “Auto Save” time preference? Are you using a “green” system HD (that wants to go to sleep)?
USB Power Management.jpg

Do you use AudioWarp with elastique Pro algo? I get the same with 8.5.30, 8.5.20 is ok. 9.0.10 also had this Warp crackle bug, 9.0.20 fixed that. So the final update for 8.5 is useless because it breaks a core functionality.

See here:
https://www.steinberg.net/forums/viewtopic.php?f=250&t=108006

No, that’s not caused any problem. This is just spikes in VST performance whether I play back audio or use VSTis.

Thanks for all that info - I have checked all power settings were set to ‘performance’ (only one device needed to be changed) but it’s still doing it.

Just an update. Steinberg tech support finally got back to me.

Their suggestion was to upgrade my RAM to 8Gb and run the 64 bit version.

As my PC is due a memory upgrade, I will do that but having run 8.5.30 in 64bit already and it exhibits the same problem, I’m not totally convinced it’ll fix things.

A final update on this issue.

I upgraded my memory to 8Gb or RAM which now means I can run at the maximum FSB of 1333MHz. Cubase still exhibits the random spikes in VST performance in both 32 and 64 bit versions.

HOWEVER.

After weeks of s**ding about, I think I have found the culprit (or the main one anyway) - the onboard Intel 82579lm Gigabit network adaptor. Deleting the Intel drivers and using the Microsoft drivers that came with the latest full upgrade of Windows 10 reduced the number of spikes. Disabling the network adaptor reduced the spikes so that Cubase now approached usable.

So what I need is a PC with a motherboard with non-intel network adaptors.

I’m getting them with Cubase 9. Started a couple of months ago. I’ve noticed that it seems to happen every hour. Whenever it happens, I check the time on my computer and it’s always 33minutes past the hour - 12:33, 1:33, 2:33. Event viewer doesn’t show anything happening hourly. I wonder if there"s another way to check what"s causing it…

I was just about to buy your Radeon card to see if this changes my issues. Same issues.

Something I’ve noticed recently is that I get these spikes when nothing is playing and Cubase is sat idle. Most of the time I don’t see them happen but having reset the red in the VST Performance meters it has jumped again… Sometimes I happen to be looking at the screen when the spike happens and I’ve noticed that a box pops up on the screen. Its almost subliminal and it only seems to happen at a standstill. The box is related to Asio and I think its offering two radio buttons to choose between drivers - my Audient Asio driver or the bog standard 500ms Steinberg driver. There is also a title at the top separated by a line. I’ve never had chance to read it properly, but it looks like an old Asio option box that used to be in Cubase in an older version, maybe as far back as SX. It looks like code that has been left in after an upgrade.

If you are getting these issues with Radeon then NVidia can’t be the culprit and Cubase is pretty much abandonware if they have upgraded from selling 8 to 8.5 and 9.0 without making it usable.

I agree that there must be some recommendations of cards that actually work with Cubase. Surely Steinberg must be testing that it works fine on their own computers, or maybe they just test for a few minutes and never get these issues.

I contacted Steinberg and got a reply that they don’t have a fix. All of the fixes that you have suggested sound like nonsense to me, just to fob you off with an answer. This is an issue that many people are having. Maybe everybody gets it but they just don’t notice or don’t care enough to raise it.

Try to keep an eye out for that popup box when nothing is playing and see what it says.

Return to windows 7 64bit