(really old) BUG: Record Arm randomly enables on previously selected tracks

This here:

This happens ALL THE TIME. During a normal working day, 100s of times.

When deleting an event after recording, or sometimes stopping and starting recording, randomly tracks that have been “touched” before is record armed. The next time Record is pressed, it will record on all the record armed tracks.

I sometimes end up not noticing that Cubase (or Nuendo in my case, exactly same issue there) has automatically record armed tracks.

There is no notice of any version fixing this for the past years. I reported the bug 7 years ago at the same time as posting on VI-Control.

Workaround has been to create a logical preset that disables record arm on all deselected tracks, and incorporating that into a macro with Record “kind of” solves the issue. Besides the fact that now I don’t have any option of recording to several tracks if I want to.

Before anyone asks: No, this has nothing to do with Midi Controller, Midi Control surface, system specific, or anything else external. This is a bug. I’ve had it on 3 different systems, different midi controllers, different project files, etc, and other people have the same bug. This needs to be fixed.

I don’t use the function, so I’ve never noticed that.
Since it doesn’t seem to happen every time, have you noticed any work steps or circumstances that make the bug more likely to occur?

If I were being sarcastic, I would now say: better than the other way around. :wink:

But since memory space is finite, I’ll refrain from sarcasm at this point. (Sarcasm would really be appropriate after 7 years.)

Unfortunately this might require a clearer repro than “this happens to me”. The replies to that topic do make it sound like you might be Record Enabling tracks by accident. One thing that could be related is that if you Right Click a track on the MixConsole and press R, that track will be Record Enabled even though it doesn’t appear to be selected.

I’ve heard that argument before as well. I’m not.

This is what I commonly do:

  • I record.
  • I press stop.
  • I press either Cmd + Z or Delete the last recording. But sometimes it record enables it on stop. I have not been able to pin-point if the record or if the stop triggers this, as this usually occurs when I’m working, and I’m fast on using the shortcuts.
  • I press record again. Now random tracks that I’ve been working on earlier is record enabled for no reason, so it starts recording content on to those tracks.

Not a single time do I press R or do anything else that would trigger those tracks. Or record enable by misstake in any other way, it’s simply not possible using the combination above.

And multiple other people have it, according to the VI Control post.

The current workaround of a macro removing record arm, then re-enabling record arm “kind of works”. But still, sometimes when I’ve just recorded, I need to manually disable record arm if I’m not going to record more contents.

Back when I first wrote about this bug, I was on Cubase using a completely different template, setup and computer. Then for a long time I was using Logic, before transitioning into Nuendo 1,5 years ago. Discovering that the bug was still present.

It’s a bug, and it has to do with enabling record on track selection. I work in game development myself doing a lot of QA, and I understand that this is not much to go on, as I can’t reliably reproduce it. But it still needs some kind of investigation.

Weird… I’ve been building a new song demo template to include all my real World setup, and have not encountered this bug. Once I start recording things and deleting them as you do, I’ll see if this happens here, and report back.

I do not recall this happening, and I often use the “command + Z” to undo recordings. Usually I have the recording track selected all the time, and do not select other tracks while recording.

This is in Nuendo though, not Cubase…

Screenshot 2023-01-13 at 18.53.45

Most of the times it hard to replicate this, as “just happens” when working fast with various stuff.

Here’s an example though. The reproduction here was:
1.Cmd + D for Duplicating the track CSS Str.Ens - Sustain.
2. Observe that Record is armed on the old track + CSS V1 – Legato – the latter that I had been working on earlier, but quite a long time since I last selected it.
3. Removing the duplicated tracks, disabling the Record Arm, and re-doing the exact same thing a second time will not give the same result.

This happens all the time. Someone has suggested this might be a bug related to folders, but I’m not sure. I can’t really test it since 49/50 times (guess) it works as expected, but the 1/50 it randomly record arm tracks.

Does this happen with all track types or only with certain ones? (For example, only with instrument tracks.)

I’ve only seen it on Instrument and MIDI-tracks so far, but I can’t confirm that definetely unfortunately.

Okay, I mostly do post. I don’t use midi and instrument tracks. That might explain why I have never experienced this behaviour.
But I am programming Blu-rays. So I know that sometimes a tiny bug can build up to a (big) problem. A hundred times it works fine and then it happens. Such bugs are often difficult to reproduce. And fixing them is sometimes difficult too. This is especially true for complex software like Nuendo. (Compared to that, programming a Blu-ray is child’s play. :wink:)

Since you are obviously not the only one with this problem, I would definitely report it to Steinberg. (Though I’m not sure if Steinberg gives this issue a high priority.)

I’ve found a workaround with a macro that disabled the record arm on all tracks, record arms the current track and starts recording. It actually works better than just recording as it will give you the opporunity to record on multiple tracks at once without manually having to click the record arm button on each track with the mouse.

1 Like

I’m bumping this again since this is still the single most slow-downing bug on my workflow, that I have absolutely NO CLUE whatsoever why it is happening, and I’m becoming increasinly desperate as deadlines pile up.

So I’m trying now to describe as clearly as possible using two screen captures, showcasing what happens.

Case 1

What I do in Case 1, is the following:

  • Playback is running
  • I select some parts
  • I press Backspace (= delete).
  • This record arms all the tracks displayed in the capture.

Case 2

What I do in Case 2, is the following:

The only common factor I’ve found so far is:

  • It seems to be affected by removing (either cutting or deleting) an event.
  • The tracks that are record armed have in common that the – at some earlier point – has been used for recording.

As this is happening randomly, I can’t reliably reproduce it, but I’ve pin-pointed it to a combination of having “Record in Editor” enabled in a separate Key Editor window, and deleting a part. This randomly record arms tracks.

Can someone PLEASE help me with this, it’s becoming unbearable.

Nuendo 12.0.40 (nothing in the change log suggesting any changes to this from what I can see).
macOS Monterey 12.6.2

1 Like

I don’t suppose this will solve your problem… But today version 12.0.60 has been released.

Unfortunately not fixed according to the latest change log.

I’ve successfully been able to reproduce the issue. I created a new thread, so this one can be closed:

see "Record in Editor" Record Enables previously selected tracks (successfully reproduced)