Rearranging Systems

Hello Doricans,

In a project I am working on making the parts as compact as possible.
I messed around with the number of bars per system.
(stubbornly tried to be smarter than Dorico :woozy_face:)
The result is that the systems are now not evenly distributed over the page.

I have 2 questions:

  • How can I distribute the systems evenly on a page?
    ( how can I adjust the spacing between staves individually?)

  • How can I force a system to move to a previous or next page?

Groet, Marien

Hi Marien,

  • Take a look at your vertical spacing settings - I suspect page 3 is calculated as overfull based on the ideal/minimum gaps set there and therefore spacing is uneven between systems with inter-system content (stuff that sticks out, like the rehearsal marks) and those without it. Reduce your ideal and minimum gaps to the smallest value you’d like, and let Dorico add any extra space available using vertical justification.

  • You can force systems to the next page using frame breaks. You can pull them back onto a previous page by making frames from the current selection.

  • The Solo text in bar 115 - have you moved that graphically? It looks like it collides with the staff a bit. If you want to move text around, I’d recommend deactivating collision avoidance first, so its impact on vertical spacing is removed. (Ditto the rehearsal marks - have you moved each one manually, or changed the minimum gap between rehearsal marks and the staff in Engrave > Engraving Options > Rehearsal Marks?)

  • Your Default master page - you’ve copied changes from left to right, but that’s left your odd-numbered pages with the page number token in the top left but the paragraph style is still outside edge-aligned. That’s why the page number 3 isn’t flush with the left edge of the systems. Either change the paragraph style to be left-aligned and show page numbers in the top left of all pages, or edit the Default master page and move the page number text frame only on the right page to the top right corner.

For a video tutorial into topics relating to page formatting, see here –

– and here –

Hi Lillie,
Thanks for the extensive answer.
It is much and quite complicated, but I’m going to work with it.
(Probably only after the New Year :grinning:)
Groet, Marien

At first glance, it looks like you need a smaller inter-system gap. But on closer inspection, it’s just above the rehearsal marks that there’s extra space. (I assume there is one on each line of page 2, and that you haven’t adjusted the vertical positions of any staves.) So instead maybe try reducing the value in Layout Options > Vertical Spacing > Minimum gaps > Minimum inter-system gap with content.

I wouldn’t use System Breaks on every system unless you absolutely have to. Dorico will generally do a good job of spacing out the music, according to the Note Spacing value in Layout Options. You might need a couple of Breaks to even out the last two systems, and maybe one to set good page turns on each double page.

I wouldn’t give a small number of bars rest a whole line.

Use a Note Spacing value that suits the music and fits to a good number of systems. You can apply changes to the Note Spacing value at any point to tighten things up or loosen them off.

Also, if you made the rectangles around your Rehearsal Marks smaller, you might get some more space. It looks like they are almost touching the staves.

(There’s also fixed casting off for bars per system, which you can set per-layout. If you generally want 4 bars per system, even if you want to override that for a small number of systems, that can make things easier too.)

But this appears to be the style where every rehearsal letter starts a new system. Obviously not good for even spacing, but it’s a style.

Hi Mark,

The extra space is created because there is a rehearsal mark and text in the same measure in the same system. The rehearsal mark is automatically placed above the text. Dorico adjusts the distance between the systems and then moves them further apart.
I manually placed the rehearsal mark and the text side by side. Unfortunately, the space between the systems remains.
Groet, Marien

Hi Ben,

I’m not a good reader (I started out as a bassist :slight_smile:
For me it’s nice when the beginning of a phrase or a solo starts at the beginning of system. Moreover, I like it when the quadrature of the music is reflected in the sheet music. That often means 4 bars per line.
In addition, I play music with a lot of improvised parts. Contact with fellow musicians is then necessary and you look much less at the sheet music. If you then have to start reading again, it is very handy and clear if you can go straight to the beginning of the system.
Furthermore, a solo section with 4 bars on a line is generous in size, but may last much longer in time than the written pieces of music. To indicate that, I reserve a whole line for that. Moreover, there is also more space for notes.
Sometimes I even make a separate flow for the solo (with only measures of rest). This way I create more space around an improvised part of the music. (No doubt there are more ways to do that :slight_smile:
So I like to see the structure of a piece of music reflected in the sheet music, even if it takes more pages and therefore more pages to turn.
Groet, Marien

If you disable collision avoidance for the text and then move them around, the space will be recalculated as if the text wasn’t there. There’s a link for how to do that in my previous reply.

Hi Lillie,

It did take me some time to understand how the Avoid collisions button works.
You must enable Avoid collisions to disable the feature.
This completely misleads me.
Disable Avoid collisions would be better text near the button. But the words disable and avoid together in a text also creates confusion because it suggests a kind of double negation. I think it would be better if the button would work the other way around.

But… I now know how it works. (-:
Thank you

One more little thing:
I find it strange that if you turn off the Avoid collisions function in the entire project (at Engraving Options - Text), you don’t see this reflected in the individual text. (Engraving Toolbox - Graphic Editing - text) You would expect that the function (Disable) Avoid collisions would also be enabled here.
I still find it confusing that Avoid collisions must be on in one case and off in the other to achieve the same thing.


It works that way because there’s a default setting in Engraving Options: activating the property lets you override the Engraving Option, whatever it’s set to, and then the checkbox lets you determine whether or not the property is active for the selected items.

So if the Engraving Option is set to “text items never avoid collisions”, you could allow only a few text items to avoid collisions by activating the property, and activating the checkbox.

Hi Lillie,

Now I don’t understand anymore. Are we talking about the same function? In Engraving Options - text - Position of text relative to other items?

Here I have turned off the Avoid collisions function. (for all text)
However, for the individual text in the Engraving toolbox (Disable) Avoid collisions is not enabled. In the Engraving toolbox, it looks like Avoid collisions is turned on, but it’s off.
If I would like to enable Avoid collisions for a text item, that is not possible. I can’t turn off something that’s already off.
So hence my confusion, I hope I’m not going too far (-:

Groet, Marien

Yes, that’s what I’m talking about. An activated property slider indicates that a setting has been set/overridden for a particular item. Meaning it’s been overridden from its default setting – whether that comes from an Engraving Option or something else.

The property can be in the following states –

  1. Deactivated: not overridden. The item follows whatever the Engraving Option is set to.

  2. Activated, with the checkbox deactivated: The item no longer follows the Engraving Option because the property is activated. Because the checkbox is not activated, the item does not avoid collisions.

  3. Activated, with the checkbox also activated: The item no longer follows the Engraving Option because the property is activated. Because the checkbox is activated, the item avoids collisions.

To summarise: the activation status of the property does not tell you whether or not it avoids collisions. It tells you whether or not it’s following your Engraving Option. The checkbox tells you whether or not it’s avoiding collisions.

1 Like

I will add to the excellent explanation from Lillie that this behavior is not easily understandable because, from a user point of view, we would expect that when we override a setting (toggle on) the option value (figure or boolean value) matches the value that was set in Layout options or Engraving options. But this communication is impossible (for boring technical reasons IIRC)
This had been discussed at length in the early years of Dorico…


Hi Lillie,

Thank you for the extensive explanation.
You do need that to understand how Dorico works in this area.
I now understand how it works, but can’t find it very intuitive and clear.

Regards, Marien