Record Error: Too many tracks recording

Cubase 11 Artist
I spent all day and late into the night looking at other people’ fixes and none of them have worked for me.
*I stripped out my NVIDIA GeForce driver and reinstalled with only basic operations
*Loaded the session onto a different drive
*Rendered all midi and deleted the midi files, then backed up the session without unused files
*Changed buffer size
*Made performance adjustments
It’s not a problem when I go straight to audio recording in a fresh session, I can multitrack. I just spent a week carving out midi tracks, now I want to add audio and Cubase won’t let me. I can see it hanging while trying to draw the waveform (I also tried running with no waveforms, didn’t help).
I upgraded to an expensive new PC because Cubase was getting buggy in my old laptop and reinstalls were not fixing it, but this is a problem I never had. 32 gigs ram, AMD Ryzen 7 3700X, should be plenty of processing power.
If I have to buy a new video card, I’ll do it, but I don’t want to spend the money and find I still have the bug.
Suggestions? Video card recommendations?

since you don’t list how many tracks you are trying to record I would assume not so many.

anyways since you seem very hung up on video card I think you have checked out this page:
Error message: “Recording Error: Too many tracks recording” – Steinberg Support

I once had a friend with this error, he just restarted Cubase as admin and it worked - it was a simple access/rights issue

Also, make sure your disc drives aren’t sleeping

just some suggestions if you haven’t already tried it

Hi, glennloopez. I have visited the link you provided and tried everything mentioned. Thanks for your suggestion re: admin startup. Unfortunately, no luck. I have disabled sleep for my drives. I’m trying to record 1-2 tracks at a time right now and have no trouble multitracking with a clean session w/o MIDI, so I’m wondering if I was hit by a bug via MIDI. Hate to throw away more than a week of work.

I’m wondering if scrapping my Cubase install and redoing the setup with fewer plugins will help.

have you checked your latency? it could be you have a driver that makes problems for your soundcard

I have tried latency and buffer adjustments to no avail. I disabled my Realtek audio driver, didn’t help. Just installed a new minimal graphics card, still having the same problem but I suspect it is possible there could still be some residual software issues with the old graphics card. I went to the computer store where I purchased the factory built computer, turns out the graphics card is so new that it only came available for sale a couple days ago, so no way to know about bug history and fixes (NVIDIA GeForce RTX 3060 Ti). I’m now running a full install on my limping old laptop to see if the session will run. I was using it for earlier versions of Cubase but not Cubase Artist 11. If the problem persists, then the Session is probably corrupted. If it runs, I may try purging Cubase entirely and reinstalling everything.

I have loaded earlier versions of the session and had more stability. Not perfect but able to record with some risk of glitching. Fortunately, this is a solo project and live band performances are not on the line. I think for future sessions I will start with only stark MIDI when MIDI is called for, lay down live tracks, then go in and fully buff the MIDI. Hopefully Steinberg will come up with a solution before too long, I submitted a ticket. I’m running out of ideas.

I tried to run the session on my laptop and it is still running the error. It looks like the Cubase session is corrupted. I note that the waveform stops drawing before the Record Error comes up. In addition, there was another error message for my first attempt at running in record mode, “audio dropout”.

so if you start a new project and start recording no problems? but if you load any old project it gives you problems?
you mentioned dropout again - to me, it screams latency issues. have you tried the program Latency Mon? Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks
you should have values from 20-80 with your current computer setup, depending on which soundcard you are using.

with such a new computer you should have no problems. there are many things to try and check. anything from Bios updates to AMD chipset drivers
if you are afraid of leftovers from your Nvidia check out this tool Display Driver Uninstaller Download version (

Thanks! I have noticed I’m getting disk cache overload when the problem hits. I’ve been searching the forum and found other people have had similar problems but I don’t see any solutions yet. My drive is SSD, I am thinking about installing another SSD drive and splitting the work load.

Also, it could be a plugin in your Cubase project causing problems, you never know.

I would be curious to see the results from you running Latency Mon. I had a constant latency on my AMD machine of over 500 (which is horrible) and all I had to do was to downgrade my LAN network driver from latest to a 2015 version. Now my latency is 20-30 and just so more responsive (anything less than 100 is very acceptable). Sometimes it is just small things that fix everything. Your computer should be plenty for recording a bunch of tracks, no need to add extra discs to even out the load.

The problem has been resolved. I bought two Samsung EVO 1TB SSD drives, both have larger onboard cache than the Lexar SSD chip that is built into the computer. I downloaded Samsung Magician and configured the drives for maximum performance. I found that audio on the Lexar had been corrupted but was able to open a backup and transfer to one of the new drives. It purrs like a kitten, not a hint of cache spike.

Thank you very much for taking the time to provide suggestions. I hope my fix is helpful to anyone else who has this problem.