Recording Audio from a VST Instrument

I’m new to Cubase, using Cubase 9.5 Pro. I viewed the Greg Ondo video on How to Record Audio and MIDI for VST Instruments in Cubase.

In the video, he creates both a dummy output and a Group Track. He then creates an audio track, and selects the Group track output as the input for the audio track. In the video, when he clicks on the audio track input block, he gets a drop down menu that shows the available inputs, and includes the dummy output bus and the group track as possible selections for input. However, when I follow the steps to create the dummy output and the group track, and then click on the audio track input block, the only choices I am given are the inputs. I am not given a choice of using the dummy output or the group track as an input.

What do I need to do so that I can use the dummy output or the group track as an input to the audio track, as Greg does in the video? Is there a preference I need to select to make the outputs visible for selection in the audio track input block?

Hi,

First of all, in most cases you don’t need to do this. If you want to Mixdown, you don’t have to record it as an Audio. You can Mixdown from the Instrument track directly.

If you need an Audio, you can use Render In Place.

But if you want to record it this way, there is no special need. Just make sure the Instruments tracks’ output is routed to the Group and the Audio tracks’ output is NOT routed to the Group.

Cubase makes it impossible to make a feedback loop, if a output is not showing up as an input choice, it is because you have something routed in a way that could cause a feedback loop.

1 Like

I’ve had a think about this and i agree “Render in Place”
I’m rendering all Instrumental tracks to audio tracks because when Cubase updates in the future those vst instruments may not be available
I’ve already been unable to use 32 bit plug ins to version 9.5 and this is the same as vst instruments being updated and discontinued

Thanks for the comments. As peakae stated, I must have had something routed incorrectly. I deleted the audio track that would not give me the input options, created a new audio track, and was able to accomplish the recording.

Here’s how I do this, if RIP or full Audio Mixdown isn’t needed.
This is for Cubase Pro.

  1. Create VST Instrument Track (or midi track if using Rack Instrument)
  2. From Mixer (lower 3rd), select track, right click and select “Add Group Track to Selected Track or Tracks”
  3. For this group, Choose “Stereo,” “Outside Folder”
    Group Track created with Group Track Fader right next to the Instrument Track. Name the Group VST Patch, or anything else.
  4. From Group Track Inspector, set Group Track Output to “No Bus”
  5. Create Stereo Audio Track
  6. Go to the Audio Track’s Inspector and assign its input to the VST Patch Group Track.
  7. Enable Monitor/Record Ready on the Audio Track.
  8. Record live audio from VSTi output.
1 Like

Hey stephen, I’m trying to follow you instruction (Artist v10) and step 6 is not working for me for some reason.
I don’t have the option of assigning The Audio track input to the group track.
What am I doing wrong?

Hi,

To record from output bus to another track is Cubase Pro only feature.

Aha! Good to know and thanks.
So what do I need to do to record the audio from a VST track on Artist 10?

Hi,

The only one way is to Solo the track, Export it and Import it back to the project.

1 Like

Got it.
So the only version enabling the recording of a midi track’s audio is studio?

Hi,

MIDI tracks send just a MIDI data. You probably mean Instrument track (Audio Return from the Instrument).

The only one version which allows to record from out bus is Cubase Pro.

Yup’ that’s what I meant.
Got it
Thanks :slight_smile:

Hi, I’m a relative newbie to newer versions of Cubase (I used to use it in its pre-VST days on an Atari ST) an wondered if I can have some advice on the best way of recording the Audio Output from a VST instrument of I’m using Cubase Elements 9.5?

Hi,

In Cubase Elements, there is no Render in Place, if I’m right.

So the only way is to Solo the track, Export Audio Mixdown and in the dialog enable to import the exported file back to the project, once the export is don’t.

Unless you own an Audio interface that allows to loopback a channel.

Hi there, my interface doesn’t allow for a loopback, so a solo audio export back into the Project it is!
(or an upgrade to Cubase pro!)
Cheers!

Here’s a weird thing that’s happening to me and it’s probably because of some basic misunderstanding on my part: I’m able to record the vsti in the manner described above, but no playback comes out of that same track. I can see the wave and can actually scrub the track, but no “normal” playback. So I take the wave, move it to another audio track and this works… what’s my blind spot here?

Hi,

make sure the Monitor button is not enabled on the Audio track, please. And double-check the output of the Audio track, please.

Hey. Thanks :blush:
Checked these 1st thing. Not the issue it seems :slightly_frowning_face: