Releasing Audio Driver automatically and manually <---- Does Dorico prevent macOS to sleep?

Dear users and developers,

Can Dorico prevent macOS to sleep?

I set up my MacBook Pro to sleep when it is not used more than 15 min.
It works usually well, but the machine does no go automatically to sleep while Dorico is running.

I can manually Ley the machine sleep when Dorico is running, but the machine does not automatically go to sleep.

Is it intended?

Yes, the audio engine prevents the computer from sleeping if you leave it unattended but open and running. However, it will obviously sleep if you close the computer’s lid. This is as intended.

I must turn off the computer if I do not use it for a while, of course.

Could the audio engine be switched off when Dorico does not use the audio engine for 1 or 2 minutes?
Users do not use always the audio engine of Dorico.
In Engrave and Print modes, the audio engine may automatically be turned off.
In Setup, Write and Play modes, the audio engine may automatically be turned off if there are

  • no change (adding or removing instruments) in Setup mode for a while,
  • no input notes in Write mode for a while,
  • no selected single note or a chord in a single staff in Write mode for a while,
  • no MIDI event editing in PLay mode for a while.

If what I have described above are possible, Dorico would not prevent the computer from sleep, wouldn’t it? If my thoughts are wrong, please ignore me!

We have no plans to shut down the audio engine after a period of inactivity.

Dorico shouldn’t prevent the laptop from sleeping. Just my opinion. I find it a bit odd…

The answer should be simple: exit the program.

Thanks, Derek. :slight_smile: Just providing feedback as I just returned to my Macbook Pro after leaving it with Dorico open for 3 hours and… it was not asleep. AND… it was hot! Not sure why, but leaving Dorico open and not using your computer, makes it hot. Anyone can confirm this?

That’s Dorico users must sacrifice at this moment.

All ASIO-dependent applications on macOS have to do audio-related matters in this way. All Steinberg applications on macOS at this moment are obliged to use and only use ASIO for direct audio processing, regardless that it is bridged to macOS native CoreAudio (which is directly used by non-Steinberg pro audio apps like Logic Pro X, Studio One, Ableton Live, etc.). // I guess this policy reduces the workload of developing cross-platform softwares, AND it can let Steinberg softwares take advantages from some ASIO-accelerated audio hardwares.

For all people who encountered audio-engine-related system-resource-busy or sleeping issues (like what addressed in posts above), please do the same test with the latest available public build of Cubase Elements (free for 30 days trial or 60 days during this stay-home period). If your issue persists, then the issue may need to be troubleshooted by audio engine team in Steinberg headquarters, not the team at Her Majesty’s doorstep. However, if your issue only happens with Dorico, then you can continue reporting your encounters here.

P.S.: Sorry for my survivorship bias, but Dorico 3.1.x sleeps well on my MacBook Pro 2017 running Catalina. I suggest turning off the Adobe Creative Cloud app.

Yes, but this kills the creative process. I use an imac and just keep it open for as long as possible. The only time I ever have to close it is because Dorico loses the dongle connection which requires a reboot. This has been happening less with the last update though. I wish Dorico (and Cubase) could open as quickly as Logic.

Dorico 3 boots up pretty fast on Windows 10 with modern desktop CPU (e.g. 8th generation intel) and 4k-gaming-capable graphics (at least GTX 1060). The mixer responds at 60fps (while on mac it is really sluggish). However, score content scrolling looks slower than doing on macOS. Also, Windows is notorious regarding its UI font rendering quality (especially for East-Asian languages).

My audio interface is Zoom UAC-2. I use macOS Catalina on my macs.

What’s your macOS version and audio interface? (plus telling your exact iMac model, please.)

P.S.: If I were you, I will buy another Dorico license and activate it using soft-eLicenser. Soft-eLicenser shouldn’t have the USB disconnection issue, and its “.sel” file is Time-Machine backcupable (better register that to your MySteinberg account, just in case).

I’ve got a late 2015 iMac 3.3 GHz i7 with 16G Ram running Mojave. My audio interface is RME Babyface Pro.

Hopefully Steinberg will change their licensing technology in the future so that the dongle users can change to a soft solution.

Overall, I don’t have a problem with performance.

The behaviour is identical on Windows. (I seem to recall that used to be worse, as earlier versions prevented other audio programs from running simultaneously.) Once I start Dorico, even if it is just the hub, my computer screens stay on. It is the only program I have that exhibits this effect, and the only program that I have to terminate to blank the screens. In fact I now make positive use of this otherwise unwanted feature by deliberately running Dorico, even when I am not using it, just to keep the screens from blanking, as doing so is simpler than opening the Control Panel and changing the setting temorarily!

David

You can explicitly set your computer to sleep by issuing the sleep or hibernate command, but if the audio engine is running, then the computer will not go to sleep on its own. The same is true of Cubase. The audio engine is a real-time process that keeps the system awake so that it can process audio at any moment.

Try Option–Command–Power button (or Option–Command–Media Eject) all at once to get Mac to sleep instantly.

After reading Daniel’s response above, I feel that this complaint can be passed to the audio engine team now.
It maybe an issue specifically happen with Steinberg audio engine (ASIO technology), or it may be a deliberate design.

Till now I hadn’t heard any similar stories with CoreAudio-only pro-audio apps (Studio One, Logic Pro, etc.) on macOS.

Thanks. This one helps.

Daniel wrote:

The audio engine is a real-time process that keeps the system awake so that it can process audio at any moment.

But I dont need “audio processing at any moment” when I am not actually using Dorico! At the same time, I prefer to leave the program open so I can return to it when I want to use it. This is what I do with all the other programs on my computer (Word, Thunderbird, Notepad, Samplitude, DigiCheck, Photoshop, Firefox, VLC, Cool Edit Pro, etc) – I just click on the icon on the taskbar when I want one of them to spring into action – it’s what is jokingly called multi-tasking! Apart from Photoshop, which is a different issue (!), they dont hog resources when they are not the active window, and I only kill the processes when necessary. My habit is to leave my desktop running 24/7 and to reboot it only when essential. I certainly dont want to have to visit the Windows Power Settings every time I leave the machine on. The amusing part is that I dont actually listen to the synthesized sounds very often in Dorico, preferring to work in silence…

David

You can choose whether or not it is a greater inconvenience to quit and restart Dorico so that your machine can sleep, or manually put your machine to sleep when you’re finished with Dorico. But the behaviour of the audio engine in this department isn’t likely to change.

I’ve set the top left corner of the screen as a hot corner for putting the screen to sleep. When leaving the desk for a while, I shoot the mouse pointer up there as I get up from the chair, and off with the lights.

Dear developers,


Please forgive me that I invoke this theme again.

Due to a problem of battery charging, I firmly ask to implement that audio engine release feature of Dorico.

Since the last week, I have experienced that Dorico does not correctly work when the battery charged under 7%.
I always use MBP plugged with power, but the battery might not be charged due to overheating under some conditions. In that case, the battery is run out in a few hours even if the power source is connected. The battery is charged while MBP is sleeping or shut down.

The leading cause of overheating is OneDrive and Microsoft Edge but not Dorico. However, I am sure releasing an audio driver, for example, in 5 seconds after Dorico does not produce sound would help this issue because Dorico does not correctly work to await the response of the audio driver.

Could the audio driver be on only in the following situations?

  • while Doeico plays back music


  • while the mouse touches virtual keyboard on VST plugin


  • while ‘Listening Mode’ (see the next sentence to know what it is) is activated.
    ‘Listening Mode’ is the mode user can listen to the sound while inputting notes by using caret, mouse click or external MIDI devices. If it is activated, Dorico behaves as usual. If it is not enabled, Dorico does not produce sound (i.e. it does not wait for the response of the audio driver) when inputting notes by using caret, mouse click or external MIDI devices.