Remove all chords from all players at the same time

For whatever reason the orchestra template I just started a project for has chord symbols showing for all players. I know I can individually remove the chord symbols from each player, one at a (very slow) time. Is there away to remove all chord symbols from all players at once? (Then if I want to I can go back into setup and show chord symbols on the players I want them on). It isn’t obvious in the menus, right clicking, jump bar or documentation and I couldn’t find this question in the forum.

Select All, Edit / Filter / Chord Symbols, Delete.

EDIT: Oh, you want to keep the chord symbols, but just not have them show? I think you have to do that for each player unfortunately.

@JAMES_GILBERT It is much quicker if you record a script that hide the chord symbols for all instruments (of the player).
So an script is attached, In windows just put it in:
C:\Users[your user name here]\AppData\Roaming\Steinberg\Dorico 4\Script Plug-ins

There is a shortcut to run last script (or create one if that is not a default)
then you just need to select the player, use your shortcut (obviously you have to use the script before so it will be consider as the last), move down (or up) with the arrow keys, use the shortcut again and so on. even with many players it won’t take so long.
hide chord symbols for all (314 Bytes)

I hadn’t thought about recording a script. I usually don’t use chord symbols in an orchestra piece but a client wanted a piano part added that had chords. This will teach me to make sure my templates are properly created in the future. Thanks.

It turns out that the problem of all players having chords wasn’t my template. When I highlighted everything in the score and applied “generate chord symbols from selection”, chords were added to all instruments throughout the piece even if the setup said only the piano should have chords. Bug or feature? I’d like to use that function to generate chord symbols for just the piano part (or whatever player has chords) but I can’t find a way to do that.

I can confirm. Seems like a bug to me too. There are settings to control “Notes from Chord Symbols” in Note Input Options, but I’m not finding any for Generate Chord Symbols. There’s definitely nothing in the “Generate Chord Symbols from Selection” dialog box either.

This is working as expected. When you use Generate Chord Symbols from Selection, Dorico makes sure that every instrument in the selection ends up showing chord symbols (by adjusting the per-player settings you can access in Setup mode). You can of course select each player in turn after having created the chord symbols and set them not to show chord symbols again.

1 Like

Is that desirable behavior? I would think that most people will be selecting all the available players that are playing so all the notes will be included in the calculation, but certainly won’t want chord symbols on all staves. I’ve never really used this feature, but I would imagine most people, like James here, would expect the chord symbol locations to remain unchanged, unless this routine is being run on a selection of instruments that don’t have chords set to show. In that case, maybe an option to show on the top staff or something. It’s certainly a lot of staves to turn off in a large ensemble work.


I agree with @FredGUnn . I considered using this as an analysis tool, but quickly got frustrated by the mass of chord symbols appearing. Fortunately Undo is just a click away.


So how do I, or is it possible to analyze an entire orchestra score and apply chords to just one player (a player that is completely blank - no notes)?

Would using the layout option to show chord symbols only above the top staff suit for your needs until a better solution is offered?

1 Like

One possible approach would be to create a new piano instrument in your layout, then use Edit > Paste Special > Reduce to reduce the whole texture down onto the piano instrument, and select that instrument before running Generate Chord Symbols From Selection. This will show the chord symbols on the piano, of course, and you can then delete the piano instrument from the project: the chord symbols will remain, and you can then specify in Setup mode which players you want those chord symbols to appear on in the usual way.


I have used that approach and can confirm it works.

Why ?
It contradicts the decisions that have been made reg. which instruments should show chords.
And even if I untick everything (like hide in all instruments) they are NOT hidden, but still show. This can’t be the expected behaviour!