Remove extender lines

I wish there was an option to remove extender lines. I am a Chinese user. In Chineses we don’t need extender lines. This option is available in sibelius. I think this is a easy feature. I can shorter every extender lines one by one. That was very painful. I can also adjust the width of the extender line. But sometimes I need to export xml to other daw users, they still show extender lines.
I also hope that dorico can customize Multi-bar rests. I can freely decide which bars are merged and which are displayed separately. That is easy function in Sibelius.
I really love using Dorico. But many people around me use sibelius. I used to use sibelius too. I switch dorico when version 3.0 came out. I wish I could recommend dorico to people around me, but the current version is missing some simple options.
Please forgive my english writing level.

1 Like

I suspect the large setting will not prevent extenders from being encoded in XML.

If you want no line, you can hit the right-arrow key instead of Space. Alternatively, you can press Enter to close the lyric popover, navigate to the next note with a lyric, and Shift-L again.

Do Chinese music scores typically show nothing for melismas? (I know Japanese scores write a long mark ー under each continuing note.)

1 Like

This was going to be my suggestion as well. Don’t hit space multiple times, so dorico only associated the text with the first note. Then, if necessary, you can multi-select any lyrics that you want left aligned (if this is done in Chinese music; I don’t know) and adjust them from the properties panel all in one go. Simple.

Thanks reply!
Right-arrow key and Space do the same things to creat extenders line in Chinese when note has line. A Chinese character has two syllables. No extender line required.

Right – The right-arrow method is while entering the lyrics. To get rid of an existing line you can select the syllable, hit Enter to edit, Space once, and then Enter to close the popover.

Thanks reply!

The second picture is what I want. Now i set minmum length vary large to achieve that. But in XML file it still exist.

Ah, I forgot about ties, for which Dorico makes extenders automatically! This is a little trickier. You may have to un-tie first before adding the lyrics, and then re-tie afterward. There was some more exploration of this issue related to Korean last year in this thread.

1 Like

Thanks for such a quick reply.
Your method is very good. This method can temporarily solve my problem. But it will increase my workload slightly
I often need to do a lot of lyric work. I often import midi files as melodies, and then copy a section of “1 1 1” under each note. Finally I use the edit line lyrics function. This process, if it goes well, will be much faster than I can do in Sibelius.
Actually all I need is a switch on/off the extender.

If my memory serves, you can shorten lyrics using the standard key commands for shortening items rhythmically; just keep pressing Shift-Alt/Opt-Left arrow with the offendingly-extender-lined lyric selected until it no longer shows and extender.

1 Like

I can confirm that works for a ‘real’ melisma under changing notes. But it doesn’t work with tied notes (perhaps not surprisingly).

1 Like

I can confirm that works for a ‘real’ melisma under changing notes. But it doesn’t work with tied notes (perhaps not surprisingly).

Have you tried it in Engrave mode?

This should work:

In Engraving Options > Lyrics > Extender Lines, set the Minimum length for extender line to a value which just a little less than the shortest extender line you would like to see, or might need on other syllables (probably under 2 spaces). Then in Engrave mode, you can select the end of the extender line and move it to the left. The slow way is to keep pressing Shift-Alt/Opt-Left arrow. A much quicker way is to grab it with the mouse pointer and drag it closer to the syllable until it disappears. If you need to reset it, select the syllable (while still in Engrave mode), open Properties and disable Line end X (in the Lyrics section).

Thanks reply.
I know this method but extender lines still shows in XML files.

Yes, you are correct.

Try this.

Select the syllable which has the extender line.
In Properties > Syllable type, change End to Middle.
Export to XML.
Import the XML file.
Does that make any difference?


I have just tried that suggestion I made.
Unfortunately, it changes the extender line to a series of hyphens extending to the next word (which it now thinks is the next syllable).

When I first tried it, I did not have any notes or lyrics following the tied note.

For XML files you can manually edit the xml file to get rid of lyric extensions. Search for “extend/” within brackets (which for some reason I can’t enter here) and remove all references. (The search and replace function in a text editor works great for this). I do this quite regularly as I need to import to musescore and my final product can’t have any lyric extensions.


“You may have to un-tie first before adding the lyrics, and then re-tie afterward.”

“For XML files you can manually edit the xml file to get rid of lyric extensions.”

These two methods look like the only reliable ones at the moment.

= = = = = = = = = = = = = = = = = =

I even tried changing the thickness of extender lines (to as little as 1/100 space and as much as 4 spaces), then exporting the project to XML. When the XML file was imported into Dorico, the extender line thickness was at default thickness. So it looks like either the extender line thickness is not included in the exported XML file or it is not recognised when imported into Dorico.

One other thing that I noticed after exporting to XML and then importing the XML file into Dorico is that the extender line (at least on tied notes) reverts to default length, even if it has been lengthened or shortened in the original Dorico project.

For situations such as this, it would be handy to have a Property or Engraving Option of None for lyric extender lines, as well as the Syllable types of Whole word, Start, Middle and End.

1 Like

Thanks for everyone’s reply.
What I want to do is to tell Dorico that it is necessary to add the option to not display extender lines. Some languages do not require extender lines.
I hope dorico can do better and better