Running SX3 on Windows 10

Does anyone run Cubase SX3 on Windows 10? Or think that it should be possible? When I try to install it I get the message:

“There are other activated processes which disturb the installation process. Please restart the computer and repeat the installation.”

I’m hoping that there are other options besides trying to do a dual boot with Windows XP, which is what I last used SX3 with. Thanks for any tips!

I’ve got an issue that most of you will call it old. But it’s essential for me. Till now I worked on the good old Windows XP Pro with Cubase SX3 without any problem. But with the stopping XP support I decided to get a new machine and I did. CPU AMD FX8 Core 4GHz 18MB Cahce, with 8GB RAM - runnning Windows 7 64bit. Oddly enough I can’t even install Cubase SX3 on that machine. It stops right in the beginning
on a “font__.ttf” file installation! I skip installing Syncrosoft License Control in the beginning but it seems anyway that it installs it. And then after asking for Serial Number etc., it starts the Cubase installation, but soon stops on that “font__.ttf” file and “Not responding”…
Drives me mad. I spent money and effort to get that new machine and… I CAN’T use it !!
Thanks in advance Harry Bellen.

I love SX3 too, but was using it last year on my very old laptop with Windows XP. I think maybe you can try to install something like VirtualHost on your new station and install there a new virtual host with Windows XP. Maybe there will be some mismatches between virtual meaning of hardware and a real one, but you will not know it while not try. It’s a way like some are using Hackintosh on PC. IMHO.

I’ve done some compositions on SX3 and now thinking about migrate them to Cubase 9.5. Only one thing is bad. Retrologue 2 doesn’t replace Monologue :frowning: Maybe somehow we can program Retrologue to sound similar to Monologue. But it will take too much time. Not possible for now.

Hallo there, I’m working with Cubase 10 PRO with windows 10 andI have the same problem as Harrybellen has:
When I try to install SX3 or SE3 (co convert all-files to cpr-files) I got the same message:
it starts the Cubase installation, but soon stops on that “font__.ttf” file and “Not responding”… And then CUbase is not responding

Does anyone know what to do or another way to install to solve this problem?
Thanks in advance!

Hi mate, did you ever get this sorted? What did you do please?

Kind regards, Paul

Hi there mate.

Did you ever get this sorted? What did you do please??

Regards, Paul (Codsworth)

+1000

same problem here

Kind regards, Rudy

I just solved it by simply installing Cubase SX3 on Windows 10 in Safe Mode

I occasionally need SX3 to convert very old projects, but that’s all I use it for, so I just zipped up the program folder from an XP installation and copied it across to Windows 10 (i.e. don’t run the SX3 installer on the Windows 10 machine at all). I then just run the exe directly and it’s fine for project conversion.

Cubase SX3 for Windows 10 can be downloaded at a link which was kindly sent to me by Steinberg Technical Support. (can’t put it in this message, this forum does not allow links, but you can find it in a page titled “Converting Cubase VST songs (ALL/ARR) into CPR format” in the Steinberg Support)
I need a USB dongle to use it.
Beforehand, I had tried to install Cubase SX3 on Windows 10 with the original CD in safe mode (as suggested by ZingarMusicLab) but could not do it because my keyboard and mouse don’t work in that mode.
A demo version of Cubase Elements (works for 1 month) can also open old .cpr files but the settings of your projects (delay, reverb…) are lost while they are kept when you reinstall SX3. Also the design of Elements is much different, so, in the end, in 2020 I still far prefer using SX3 the same way I did in 2004.