Second apostrophe bug on Dorico 4

Hi. I’ve just noticed that there is an apparent bug on the second apostrophe when you type something on Project Info. How can I make it normal?


1 Like

Hmm, it seems the period after has an effect with this. You can always just use the shortcut for the curly quotes. On the PC it’s Alt+0148 and then it works fine with or without the period.


As a matter of fact, these symbols shouldn’t look like apostrophes or quotes. In high-level typography you should use so-called primes instead. They mostly look straighter than curly quotes, but are also slightly more slanted than the common straight typewriter (ASCII) quotes (which, of course, no-one should ever use in serious work).
Single prime ′ is U+2032, double prime ″ is U+2033. Also used for feet and inches when you’re feeling imperial.
So it’s not 4’33” but 4′33″(hard to see in the forum font, but the difference is there).


Quite right, and this was mentioned and discussed last August.

…and tokens to provide the flow duration written with primes rather than curly quotes were duly added in the subsequent update.


In any case, the period should not be affecting the apostrophe.
For the U+2032 and U+2033, what does that mean? I tried pressing shift+u2032 but that’s not it. I also tried holding u an pressing 2032 but that’s not it.
So. how do I insert that on Project Info?

Where do I find the field for project duration with the prime tokens?

Right-click in the text frame, and from the context menu, choose Flow Info > Flow Duration (Primes). It will show the calculated duration of the flow.

I might be doing something wrong. I don’t see it.


Double-click to invoke the text editor dialog first.

I usually put the info in Project in Project Info, not on flows.
Is there a project duration?

Also, the flow duration automatically showed 0’14’', and I don’t see where to edit it in Project Info.
Additionally, they are not the so-called prime, but the apostrophe.


It’s {@flowdurationprimes@} if you want primes.
There isn’t an equivalent token for the entire project.

No, it does not appear in the Project Info. You have to enter it in a separate text box. Double click inside the text box and right-click as Daniel described.

I don’t see that option with primes on my list (I have Dorico 4 Pro version
Also, @pianoleo , that would give me the primes, but how would I change manually the duration (I don’t want 0’14’', I want Duration: approx. 4’15’')?

Then type “Duration: approx. 4’15”!

These are tokens, automatically populated from (in this case) the playback duration of the flow.

As we discussed before, Dorico apparently has a bug when you write a period after the apostrophe.
And even if I don’t write the period, writing it manually would make it have apostrophes, not primes.
It’s not that bad, but we are trying to find a solution to have the duration I want to put with the primes.

You can just insert the primes as individual characters. They’re just regular Unicode characters. You can copy and paste them.

Single prime: ′

Double prime: ″

Holding Alt and pressing 0146 and 0148, on the numeric keyboard (not on the numbers above the letters) on Project Info makes the apostrophe and double apostrophes respectively, and it allows it to have a period! Thanks.
Now we just need to find a way to have the prime instead of apostrophes.


I don’t understand the “U+”, what should I do?
As for inserting, I tried, but it brought a huge space that could not be deleted unless you deleted the prime itself. For some reason now I was able to copy and paste it.
Anyways, this solves the issue, thanks. But I would still like to understand the “U+” thing (the spacing issue may happen in another time again).


If you update to 4.3.20 you will find it in the list!