Shift + Numpad on Windows 10

As per manual, pressing “Shift+ Num 1-9” issues the VERY useful commands “Recall Cycle Marker 1-9”.

Now, Windows, when pressing shift, disables the Num Lock status and it’s impossible for Cubase to listen to this key combination. Instead, shift is ignored, and only the Num 1-9 gets through, resulting to a “To Marker 1-9” command being given instead. One cannot even use these key combinations in the assignment field of the key commands window.

Is there anything the team can do about this, or should an asterisk be placed in the manual (for Windows users?)

Just for completeness’ sake: It works as expected with Num Lock toggled to off.

1 Like

It does? I thought I tried everything, but I will check again!

I confirm what both of you said, actually (Windows 10 Pro user, here) :

  • The <Shift+NumX> combinations don’t work as one could expect when the <NumLock> key is activated,
  • They do work when the latter is not.

I have tested this both with actual markers, cycle markers and the Type in Key area of the Key commands window. A precision that indeed should be mentioned in the manual, at least for Windows users (I don’t know if it’s the same thing on an OSX based system).


Thanks, @cubic13 !

Ah, this sucks. I don’t want to remember that I need to deactivate numlock before giving a key-command and then to activate it again. Is there a way (excluding AHK) to disable this window feature? I searched a bit but I didn’t find a satisfactory answer.

Not that I know of, sadly : I have also tried with either <ctrl> or <alt> as an added key and each time, the <shift> part of the key combination disappear, when the <NumLock> is activated… :slightly_frowning_face:

An alternative is to run Cubase with the Num Lock disabled.

On my machine it’s a BIOS setting that allows me to start my computer with Num Lock on or off. There may also be a Registry setting for it.

Ah, I know, I know but I’m so used to using the NumPad for its numeric function. I foresee a #persistent AHK script in my future… :crystal_ball: :mage:t3:

Edit: Actually, it wasn’t as simple a script as I thought with AHK, so I just made 9 buttons in Touch Portal that press numlock, Shift+x, numlock and all’s well.

1 Like