Shortcuts suddenly don't work any more..?

Did any of you have this problem:
I definde user key shortcuts, but suddenly randomly some of them don’t work any more…?
For example I definded alt + “-” to reduce the dynamic intensity. From one day to another it doesn’t do anything any more, although it is still written in the list of shortcuts.
I tried to delete it, refresh, enter it again, refresh, nothing helped,it seems as if this key command is suddenly blocked forever (although I didn’t do any update or something it just appeared suddenly)

anybody experienced a similar problem and has an solution?

1 Like

Oh and one more key command problem:

Usually Dorico recommends to use ; in order to start a tuplet and then should just create automatically a triplet, but on the german keyboard this is different. So I linked another key (in my case “ö” to create a triplet, but the problem is that dorico then enters always the popup box and i have to enter 3:2) isnt there a way to say just with one button “create a triplet” which appears so often, that it would safe a lot of time if I don’t have to enter always the ratio in the popup box.

I don’t recall having experienced such behavior, no. Only when I was messing up with my json file while building up the feench Notation Express version, but that is history now.

I never used javascritp, so this cannot be the problem here

Are you on mac or PC? I ask because I am reading some threads about the exact same problem. It might be interesting to track whether there’s a pattern…

Yesterday suddenly R stopped working for me, and soon I discovered that it was because I had forgotten to switch my keyboard layout back to U.S. from Korean!! Of course Dorico won’t repeat anything when I type ㄱ.


I am using a german apple wirless keyboard on mac.
I guess it maybe has to do with the German keyboard having the signs differently routed than the english one…?
But the very strange thing is: it worked before and suddenly not any more, no matter how often I deleted it and reprogrammed it. It is as if this keycommand is from now on blocked forever.
and I just tried it out: Its still the same problem on Dorico 4.0.

now I made it two commands:
ALT + numblock -
ALT + -
the numblock version works, the other version not (the second one is the one that suddenly crashed).

Did you manage to solve your problem?
Mine is with Ctrl+V and V.
Curiously these shortcuts work when the preference window is opened, at any page. The voices change on the staff by pressing V. But as soon as I close the preference window the shortcut stops working.

Edit: all the keys on the keyboard stopped working in Dorico. Closing and reopening the project did not help. Quitting and restarting Dorico got the keys working again. Even now the voices shortcut V works. A classic case of restartitis.

Welcome to the forum, Brice. I’m sorry you had this problem. If you encounter this again, take a look in the Edit menu: do the Cut, Copy and Paste items appear correctly there? I suspect that one or more of these menu items might not appear: this happens from time to time on some Mac computers. We’re looking into it at the moment and hope to have a fix for it in the near future.

1 Like

Thank you for your welcome.
I have not encountered this problem since restarting. I am using Windows 11.

I’m on a Mac, Monterey OS, and find the problem persists despite restarts. I’ve assigned option-E to Export File. When I try it, nothing happens.

I created a thread 3 years ago about a similar problem : Dorico 3.1 : Instrument names in French + Shortcut issues with MacOS - #19 by francisb

To me it happens several times a day. The only fast solution I found is to switch from the French Canadian Keyboard (the one I’m using normallY) to the English one and switch back to the French Canadian. Then it works fine. I have to this about 5 times per hour (sometimes even more, like at each minute). I hope someday it could be fix but it seems I’m the only one having this issue :frowning:

On several keyboards (don’t know about French Canadian) option-e is dead key, used to add diacritics. It will be captured by the OS before an app can ‘see’ it.

Welcome to the forum, @sjgeltman. Has this shortcut ever worked for you as expected? If not, I would suggest you try using a different assignment.

Thanks, Daniel, for your response. I’ve tried multiple custom shortcuts for this, and nothing works. Glad to try any you’d suggest.

Ah, of course, I know why: the reason is that “Export File” is a command that requires further parameters to specify the format in which the file is to be exported. What format are you trying to export, specifically?

Apologies, Daniel, for my delayed response. (I expected responses to arrive in my email inbox, but nothing did.) I’d like to export to .WAV format, please. I appreciate your help with this.

If you’re willing and able to hand-edit your keycommands_en.json file (you’ll find some advice on how to do this if you search on the forum), you can add a custom entry in there that will show the Export Audio dialog – it won’t export directly in WAV format, as you’ll need to choose some parameters in the dialog. You can add a shortcut for the command:


Thanks for the suggestion, Daniel. Not sure what I’m missing here…

… as there’s no response from Dorico when I try Ctrl-Shift-E to export.

Are you adding your new shortcut in the kGlobal context?