Show/hide automation inverted on multi-out vst's

Hi all!

I love the show/hide automation function for normal track operations but on my vst using multi-outputs…
Clicking hide all automation actually reveals the output lanes
Clicking show all automation actually hides them.

How is this helpful and what am I doing wrong?

Thanks in advance!

Anyone? I can’t be the only one who has noticed this.

Just tested it and seems to more or less work as expected, here. I say ‘more or less’ because it’s actually rather confusing…

Using an instrument track with HSE3 configured as having two different outputs :

  • Show automation (header track icon) shows both outputs
  • Hide automation (header track icon) hide them.
  • Show/Hide automation (Right-click menu) : same behaviors.

BUT… Using Hide all automation actually shows the outputs (or keep them displayed). I guess that this is because the output lanes, even if displayed like automation ones are actually more than that : they are linked to an audio stream (a given output of the multitimbral synth - there is an Edit channel button appearing with the default track control settings).

So, what could seems strange at first can’t be truely considered as a bug, IMO. The whole thing is consistent, as pure automation lanes are actually hidden when needed : this is checkable, adding in example an automation lane to one of the multi instrument outputs . The Show all used automation command behavior can also be explained in the same way, I think.

Overall, yes, there is a rather confusing implementation of the commands related to automation lanes vs outputs ones, but it is consistent, somehow, as true automation lanes behave as expected. Usually, I never use the Hide all/Show all commands, from which I never noticed it until now, I admit… :thinking:

Thanks for the reply. I don’t think clicking on ‘close all automation’ should be opening something else. That’s just not what I’m going for when I click on that.

It’s definitely a confusing implementation and one I’ll have to work around. I’ll train myself not to rely on that feature I guess.