Sluggish GUI performance...


I’ve made a lot of search regarding the GUI performance issues (lagginess, sluggishness when doing editing etc) and some of them seem to be in relation to Nvidia drivers, but I haven’t found a solution regardless of any further tweaking including uninstalling Nvidia drivers and doing a clean reinstall (complete driver wipe with Driverfusion), rolling back to previous ones (trying out the suggested ones for possible fixes) and whatever that comes into my mind.

This “lagginess” seems to occur only GUI-wise, I currently have no problems related to audio at all, but it always seems to happen whenever I do slicing and quantization on multitracked drum events. I guess things get out of hand when such an amount of multiple events and waveforms get chopped up, but I think that my current configuration is not really supposed to have such an issue at least graphics wise.

I have to conduct slip editing on multitracked drums by hand, but the lagginess results in the loss of considerable amount of time.

System specs below;
-Cubase Pro 8 running on Win7 64bit (up to date) (the unnecessary background services are disabled, and it was tweaked in the manner of a DAW PC, without going overkill)
-2 x Nvidia GTX 560 Ti’s on SLI configuration running on driver version 353.06
-Intel Core i5 760 @2.80 stock speeds (all the throttle settings in BIOS, including core parking are disabled)
-16GB of memory
-2TB WD Caviar Green HDD (mind that the project/audio files and the Cubase 8 installation, the OS, plugins, sample libraries are NOT on different drives, but on seperate partitions, I’m not sure if this could be related to GUI sluggishness)
-2TB WD My Book 1140 External HDD

Any help is really appreciated, thanks in advance.

EDIT: One thing I’ve noticed, (as obviously) the problem seems to go away when I untick “Show Waveforms” via Preferences > Event Display > Audio submenu. I wonder if Cubase (or due to anything not proper on my rig, the computer itself or the GPU) is not able to utilize the graphics card successfully in order to render the waveforms?

Just wondering what the graphics section of the Windows Experience Index score is? Maybe that will show if your card(s) are not setup correctly.

Lots of thoughts/suggestions on this thread about a bunch of stuff. Maybe a quick read through will assist you.

Regards :sunglasses:

Hey! Thanks a lot for your fast response :slight_smile:

The score is at 7,9 as I’ve been expecting, I do not seem to have any issues when playing contemporary games with eyecandy graphics when I tweak them a little bit, I’m sure that something else fishy is going on here, since the issue persists as long as waveforms are visible. Very strange. It slows down the slip editing process A LOT, I can’t even drag the chunks with precision sometimes.

I’ve noticed those two registry tweaks, I’m going to give them a shot and see what happens.

EDIT: Does not seem to make any difference at all. It’s again extremely sluggish.

One thing that I’d like to pinpoint, I do not seem to have this problem whenever I untick the “Show Waveforms” option, I even get rid of the occasional “audio performance spikes” when I do this.

I wonder if it’s related to the Nvidia drivers or how Cubase actually processes the drawing of waveforms and utilizes the GPU/CPU/whatever for that purpose?

It’s obviously related to graphics, but none of the suggested tweaks seem to have an impact, except the “Show Waveforms” box, and of course I cannot do that since I need to see the waveforms & hitpoints in order to conduct slip editing properly.

Apologies for the double post.

7.9 so your graphics are top notch… and you tried the registry suggestions in the linked topic (I thought that would help). Everything set to run as admin? Hopefully a few others will chime in here.

Regards. :sunglasses:

Exactly. I’ve tried the registry tweaks, and everything is also set to run as administrator, including Cubase 8 itself.

Anything related to power saving or throttling (from USB settings, HDD settings, hardware to BIOS) is off, the computer is always performing in full performance, I’ve also tried numerous OS tweaks regarding DAW optimization, still no difference.

The only thing I didn’t try out is the NVIDIA 337.88 WHQL drivers (from March 2014 I suppose) which some people mentioned as a remedy, but I also doubt that it’ll make a difference.

I’d also like to take note that some individuals are having the same problem on other DAW’s aswell, I came across topics with the same issue regarding Pro Tools and PreSonus Studio One. Here’s one of them, the OP also supplied a GIF that demonstrates the lag issue;

I wonder if this is related to an optimization/processing problem on the GPU manufacturers side, whether be it ATI or NVIDIA? If that’s the case, maybe Steinberg, PreSonus, Avid, Logic, etc all could mention this issue to them and work out a unified fix?

Since you’ve done all the tweaks and other stuff you got to give that Nvidia driver change a shot. I would. :wink:

If you do, please report your results. Thanks

Regards :sunglasses:


Driver rollback to 337.88 made no difference at all.

I’m out of solutions, really, and it’s really taking away from my workflow, and slowing down my speed by at least half.
It’s almost like POW camp torture to slip edit. I’m out of ideas :frowning:

I really hope that Steinberg digs in to this issue as soon as possible.

You may want to submit a support request ticket if seeking Steinberg assist.

Regards. :sunglasses: