Snare drum rolls

I cannot seem to find a way to get a tight continuous roll in the snare drum, triangle etc. There seems to be no difference at all between the three-stroke and four-stroke articulation. I have tried the buzz roll also…any suggestions…

What sound are you getting now? And is the buzz roll the sound you want?

Robby

All I get separate notes of various values. If you look at the attachment you will see 1/8. 1/16. 1/32, 1/64 and a buzz roll symbol but what I am getting are 1/8th and 1/16th and the rest of the symbols give the same value with no difference, all 1/32nd notes.

What sounds are you using? I imagine that Halion probably has this sorted out by default, but if you’re using, for instance, Kontakt, like I do, you’ll need to set up your percussion playing techniques. You’ll want to tell it that those symbols are not played “natural” but rather as a “roll,” and then in your percussion map, you’ll need to make sure the correct midi note from whatever vst instrument you’re using is set to “roll.” Percussion maps are in the play menu. I’m not in front of Dorico right now, so I can’t remember exactly where the percussion techniques menu is, but my gut is telling me somewhere in the setup tab. Perhaps someone else can chime in with that.

Also, I’m not certain, but I’m pretty sure that one or two of the videos on the YouTube channel deal with this and/or closely related issues. You might give them a looksee.

Ok, assuming you are using Halion and the snare sample there, here is what you need to do…

There are 3 main areas that need to be covered, and setup correctly.

The first 2 are the percussion map and playing technique:
Go to Play mode, and in the right hand side panel, is a little cog next to the instrument rack. Click on that. Make sure the General MIDI drum map is chosen in the percussion map section.


Next go to the percussion map menu in the play menu.

Make sure you see the “Playing technique” for the roll.

to be continued…

Thanks for the detailed reply. I shall have a look at this tomorrow…

Next go to the snare drum in setup mode, and click on the chevron to display the menu. You will need to edit the percussion techniques.


Now, in the percussion techniques, you will need to add what you need.
I choose the Z as it makes the most sense to me.

Make sure you have the “natural” technique at the top selected. Then follow the numbers in the graphic…

1.) Click the + to add a new technique
2.) Select the Z
3.) In the playing technique box select the same thing as it was written in the percussion map… in this case ‘roll’.
4.) Click the replace button. The add button, will add the ‘roll’ technique to the already ‘natural’ technique. However, as you saw in the percussion map, there was only 1 technique assigned to the roll.



Now add the Z where you need it… and playback plays the buzz roll.

Robby

I’m curious if you were able to get the Snare drum rolls working?

Robby

I have not had a chance to try it yet! I will be trying it later today and will post the results then. Thanks.
Michael

Hi Robby, this worked like a dream. Question: do I have to do this for every project or can I save as a present? I really appreciate the trouble you took to explain how to achieve this “magic trick”. Thanks. Michael

You can export the percussion kit containing your edited instrument and then import it into other projects, but you can’t currently set it up as a default.

Thanks Daniel.

I am glad to hear you got it to work.

Robby

When I tried to follow this, in setup mode trying to get a tam tam roll, the option to edit percussion playing techniques is greyed out.

Perhaps you’ve got your tam-tam as part of a kit? If so, choose Edit Percussion Kit, then in the dialog, select the tam-tam instrument and click the Edit Percussion Playing Techniques button.

Thanks (2 years belated) for the nice write up, Robby. Worked great. The roll is a bit quiet, which will be my next challenge, but much better than the “measured strokes” I had before.

I am glad I could be of help.

Robby