solid state drive a solution for disk overloads?

The problem seems to come and go; sometimes it happens even on fairly minimal projects. Setting the Disk preload (in VST Audio system advanced options) to 6 seconds seems to help.

Anyone else have this problem? Anyone used solid state drives? the problem with them (last time I checked) was that you have to pay quite a bit for a relatively small amount of storage.

If i look at your specs something is wrong with the system:
a) security issues (hacked)
b) you are online with the DAW all the time, and have granted full access to some type of other software with direct access to your resources, in this case your harddrive.
c) harddrive is going to die, but that seems unlikely since this is not an old system

If you disconnect from the net, is the drive still going berzerk ?

Because with your type of system, you should not even see the diskmeter go up at all…

kind regards,
R.

Aloha s,

1-Sounds to me like me a hard drive packing it’s bags to head south.

2-Others than price and capacity, I find SSD’s superior in all aspects to spindle drives.

Do some checking again. lately prices have really fallen.

To give you an idea on pricing the following link is a ‘Mac’ place yes
but they also sell PC SSD’s and I am sure other PC users on this board
can also help you locate PC sources in this regard.

http://eshop.macsales.com/search/pc+ssd
YMMV.

Good Luck!
{’-’}

Once you go SSDs, CPU will probably become the significant limiting factor from then on.

If very heavily using samples, split them over multiple drives.

Are your HDDs making any odd noises?

My audio computer is not online, and the hard drives actually are actually older than the motherboard/cpu.

Problem is, those solid state drives are fairly expensive.

Those drives look fairly appealing, but, for logistical reasons (the records I mix, due to 88.2 KHz/32 bit files, often get quite large) I’d probably want to get a lot of space. It looks like the 6G 240 gb drive is the best option to me.

thanks!

Have a look at this post the OP was having a similar issue and it turned out to be the SSD he had to replace it:

http://www.steinberg.net/forums/viewtopic.php?f=181&t=58034

Watch the video.

Usually no samples; I as well as my clients tend to keep it real.

I see you’re using SSDs; does that help allow you to work at 192 KHz?

I don’t think my situation resembles his that much; usually I am not using vstis, and when I look at the performance meter, the issue is causing sudden spikes to 100% on the disk meter, not the cpu. Often when i stop start playback, I’ll see a spike on the disk meter.

Then again, it is interesting that replacing the drive fixed his problem…

I don’t think our track count would be pushing the performance limits of a 7,200rpm HDD, let alone an SSD.

We went all SSD a few years ago. I couldn’t play any instruments then, so we had got a few sample libraries, a Strat and an Axon MIDI guitar adapter with a hope that my wife might have been able to do something with them. We got the SSDs for the samples to avoid the 40W and aircraft takeoff noise we used to get with the four WD Raptors we had for them.

All changed a couple of years back when I suddenly could play, so we are now mainly doing fairly sparse acoustic stuff, which doesn’t push the Cubase disk meter off the minimum.

Nice!

I work with bands, plus I am working on my own record, and I tend to record a LOT of tracks. I was curious because 88.2 tends to push my computer resources to the limit :slight_smile:

I went ahead and bought a SSD, and it doesn’t appear to be having any impact on the problems. Those problems being disk overload errors and periodic computer freezes that (have gotten MUCH worse in 7.5 and) appear to correspond with the autosave feature.

The specs are:
sequential read 550 mbps
sequential write 320 mbps
random read 85,000 IOPS 4K
random write 77,000 IOPS 4K

I installed it, formatted it, moved a project onto it and started mixing. The freezing is happening just as often and just as long, and when I tried to export the mixdown disk I still got an overload error.

Next I tried some mild overclocking exporting the same project from the SSD and the normal drive; they both worked with no overload, and while looking at the vst performance meter I could see no difference.

It would seem that the SSD is not really giving me anything worth the $100 I spent - considering it only holds 240 Gb? (I can still return it to microcenter)

I guess another experiment would be to install Windows and all the programs on the SSD, but that is a serious investment of time (at least a day if not more) , and if the main benefit will be faster boot times, I’d rather retrieve the $100 and not spend the time.

what do you guys think?

SSD’ drives changed my life forever.

I run 3 with great success. Can’t imagine my life without. I was unable to work with large projects in higher sample rates. They did improve stability with recording, editing and sample streaming.

Yes and they limit disk overloads also. I have projects on HDD drives and compare them on SSD’s with big difference in overall performance

Prices is coming down daily also :sunglasses:

I wonder why I am not seeing this sort of result. Any ideas?

Appears that whatever is using your disk might now have enough CPU attention to get its job done without blocking disk accesses. Make sure you have no disk utilities that are supposed to improve your disk throughput.

For example, the Samsung RAPID technology improves average SSD transfer rates significantly, but it does that at the expense of latencies up to 30ms, which would create hiccups (disk spikes) on all DAWs.

DAWs rely upon having the smallest maximum latency possible (I call it ‘best worst case’). Turn off all stuff that is designed for optimising non-real-time scenarios.


An SSD for the OS/progams drive will not give any performance benefits, other than speed up startup and program load times, unless the cause of your issue is some driver/service activity that is interfering with disk operations.

Make sure all unnecessary motherboard utilities/services are uninstalled, as they are typically designed to make their products look good, rather than your program performance.


In general:

a) SSDs will take storage off the critical path for DAW performance. If you still have problems, it is NOT the technology per se, but elsewhere, like drivers, firmware, services (non-OS), plugins and software.

b) Don’t be impressed by tests that indicate fantastic transfer rates, because they can only get those figures by keeping the channels saturated, thereby forcing ALL data to experience the maximum latencies/delays. A channel needs to run at well below its maximum capacity to guarantee low latencies, as it allows incidental OS and program ops without impact.

The VST Presets folder is on the C: (User Documents) drive, and so are some sample directories (e.g. Padshop Pro user samples). VST instruments and their programs are often installed on the C: by default, and some plugins don’t even provide a choice of location for installation.

IF these types of plugins are streaming off disk, they could benefit. E.g. HALion, Groove Agent, HSO, and Padshop (Pro). HALion can stream, but I don’t know whether they all can or do, or just load into memory. But if so, this could be true (or not).

Also, a typical service that you can disable, is “Windows Search”. Depending on what is going on, it could slow things down. When files are created and modified, the service catalog and index those files (as well as cleaning up from deleted files).

Specifically, the indexing of the contents of files. Generally, one doesn’t need this trawling through DAW-related files, and probably not for anything unless one has a lot of text files. If one has SSDs, searching is generally pretty fast without it.

To turn them off, for each drive:

  1. Right-click on the drive in Windows Explorer.
  2. Select the Properties option to open the Properties dialog.
  3. Unckeck the Allow files on this drive to have contents indexed in addition to file properties option.
  4. Click the Apply button, which will open the Confirm Attribute Changes dialog.
  5. If not already, select the Apply changes to drive x:, subfolders and files option.
  6. Click the OK button.
  7. If the Access Denied message box appear, click the Continue button.
    The Applying attributes… message box will show until done.