Solution for missing "kits", "presets" in Groove Agent, Padshop

In Groove Agent I could not see all Kits (only 3 instead of 8),
Padshop did not give any sound, because could not find presets
Media Bay showed less entries, for example Drum&Perc only 5000 (on other PC it showes 12000)

I tried:
Library Manager: A ll double click on *.vstsound did not work because “already registered”
Media Bay: Full scan over harddisk in Media Bay did not help, Media Bay cannot see more
Software: All software are up to date, Cubase 12 Pro

SOLUTION:

“Library Manager” is the problem.

  1. “remove” the things in “Library Manager”
    … you need the download file again…
    2.a Double Click the *.vstsound file in Downloads folder, for the removed stuff,
    2.b Or, click install in “Download Manager”, this does the same as 2.a
    this will open the Library Manager and will register the thing again (even more files at the same time)

Then it works again, in the standalone Groove Agent, or standalone HAlion, or Cubase, does not matter.
If you open “Media Bay” now, it will automatically update, and then you see more content.
At “Drum&Perc” I see now 8000 instead of 5000, so there are more things I have to 1.) remove, 2.) install / double click (register) again.

I hope this helps a lot !

1 Like

Hi.

I had issues that some bought extensions didn’t show up inside the “right zone media bay folder” inside Cubase. Asked Greg Ondo for this in the “Hangouts” on Youtube.
The solution he told me did fix the issue:
I closed Cubase, removed the files mediabay3.db and MediaDefaults.xml that are located inside C:<User>\AppData\Roaming\Steinberg (on Windows 10).
When you start Cubase, it rebuilts the media bay database and the missing items re-appeared.

Perhaps this is an alternative to the solution you provided here.

1 Like

Hi !

I tested your suggestion.
I moved these two files

from C:\Users\myUser\AppData\Roaming\Steinberg\Cubase 12_64
to C:\Users\myUser\AppData\Roaming\Steinberg\Cubase 12_64\newFolder

from C:\Users\myUser\AppData\Roaming\Steinberg\Groove Agent SE_64
to C:\Users\myUser\AppData\Roaming\Steinberg\Groove Agent SE_64\newFolder

from C:\Users\myUser\AppData\Roaming\Steinberg\Retrologue_64
to C:\Users\myUser\AppData\Roaming\Steinberg\Retrologue_64\newFolder

from C:\Users\myUser\AppData\Roaming\Steinberg\HALion Sonic SE_64
to C:\Users\myUser\AppData\Roaming\Steinberg\HALion Sonic SE_64\newFolder

and the files were regenerated,

the file size can differ, in case of mediabay3.db of the folder Cubase 12_64 , was before this action about 33 MB, now its 23 MB, but I was playing around with the plugin manager program, I think the file size was bigger because I did a full scan over the harddisk, so a lot of unnecssary content was inside the database file.

Unfortunately I cannot see now a difference, it worked before this action and it works now too.

Well, if all is fine and running, a re-creation of the database like I described will not break anything I hope and after the re-creation, all is still fine and running. What kind of difference did you expect?

I wrote my answer for people who might run into the same issue as you (missing kits etc. in Groove Agent) - perhaps they can just remove the two files and do not need to download all the stuff again etc.