[SOLVED] Cubase 6.5 - Multi-track editing problem (MIDI)

Hi Cubase-wizards,

Got a quick question for you. Lately I’ve been experiencing some strange behavior in Cubase 6.5.4.

Whenever I double-click on a MIDI clip to go into the key editor it either
a) Opens the currently selected track which is often not the track I double clicked on (especially if I click on a track during playback to perform some “real time” editing).
b) Opens the correct MIDI clip and lets me edit, but as soon as I hit play button it switches to the currently selected track.

This behavior, apart from being an annoyance, makes it impossible to perform multi-track editing, since no matter how many tracks I’ve selected Cubase always seems to “mark” one track as “selected more than the others” and as soon as I press play I only see this track in the key editor.

I am convinced that it’s something I’ve switched on or off, but I can’t seem to find it. I’ve got the “Edit Active Part Only” switched OFF. I’ve obviously tried having it ON, but it makes no difference.

Hope some of you can help me find the issue here.



A rather crude but effective method is to go to Preferences en find any parameter that has Midi written on it.
Then randomly change something in every parameter and click on Default Settings every time you’ve done that. That puts every Preference back to default setting. It might be good thing to backup your preferences first.
Again I admit it is a bit radical to do, but it worked for me one time when I encountered a very strange midi editing problem and it was solved this way although I never knew what the real problem was.
Like you I must have clicked something but could not recall what it was.

Hi ThePresent,

Good tip! I’m a bit reluctant to try it out at the moment. I can’t afford to lose the stuff that’s working in my current setup, so I think I’ll wait and see if someone else comes along who knows the exact cause/solution.

Thanks for your help though. Much appreciated!


Got a couple of suggestions but since you don’t want to troubleshoot the issue by trying different things, listing them is moot.

Or you could just give me what you got and let me be the judge of whether or not I want to try 'em out. :wink:

EDIT: To further elaborate on my lack of excitement for doing what ThePresent suggested comes directly from words like “Radical” and “Crude” which are no-go’s for my current setup which actually seems to be stable (mostly).


Anyway, I conquered my fears and did what ThePresent suggested on the MIDI-editing pane in the Preferences - and what do you know - it actually worked! :mrgreen:

Thanks a bunch for your help! You’re a lifesaver (although hitting that defaults-button was scary).


I will be a bit more reluctant using scary words, in the future :mrgreen:
Anyway it’s great it made a difference. It helped me out back then and also another person on this forum with a slightly different midi problem, so it seems like a nice general way of solving midi-editing problems.