[SOLVED] How to record guitar directly into Cubasis?

I would like to know how to record a guitar directly into Cubasis. I have Cubasis on an iPad Pro. I’m using a Presonus AudioBox iTwo as an interface (plugged into the iPad with lightening cable). Cubasis lists the AudioBox under audio device under settings. I have an audio track armed to record. I have the little speaker on and I can hear the guitar in my headphones. I chose the mono audio input 1, which matches the audio input 1 from the Presonus AudioBox. Stereo is on 1/2. When I start recording with the red button and play the guitar, nothing gets recorded.

Now when I use Audiobus with an app like Bias Amp, I can record the guitar into Cubasis. But I can’t record directly into Cubasis. Also, when I recorded using Audiobus, I armed two tracks trying to get one clean track along with the track with the effects from Bias amp. But the other track didn’t record anything.

I would like to know how to record directly into Cubasis without using other apps.

Thanks,
Dan

Hi Dan,

Thanks for your message.

Please have a look at one of our available tutorials
https://www.youtube.com/watch?v=j8t48FZSX60

While originally produced for Cubasis LE, please find the audio routing process explained at about 1:48 minutes, which works similar for Cubasis and Cubasis LE.

Please let me know if it helps to record your guitar into Cubasis directly via your Presonus audio interface.

Best,
Lars

I think I resolved my problem. I can record a guitar directly into Cubasis (using the Presonus audio interface and the lightning connector) after I give Cubasis the iPad’s microphone. I went into settings, selected Cubasis, and set the switch there to give Cubasis the microphone. I don’t know why Cubasis needs the iPad’s microphone to record through the lightning connector, but I guess it’s needed.

Cubasis certainly doesn’t need the microphone to record through Bias Amp with Audiobus.

I was doing everything else in the video you sent. The video doesn’t mention that you have to give the iPad the microphone.

Thanks
Dan

Hi Dan,

To record your guitar, the steps should be exactly similar to what’s shown in the tutorial.

Please try again following these steps:

  • Launch Cubasis and connect the audio interface
  • Create a new project with one audio track
  • Tap the “Routing” tab in the inspector
  • Tap “Mono input” to open the “Audio Inputs” popup
  • In the “Audio Inputs” popup choose the channel where your guitar is connected to
  • Start recording

It should not be required to chose the iPad microphone, instead I’d think this leads to wrong results!

In doubt, I’d suggest to get in touch with Presonus to ask them for Cubasis compatibility.
If required, I’m at hand to provide them with a Cubasis promo code for testing.


Best,
Lars

Dan

That pop up “allow (app) to access microphone” is an iOS thing, not a Cubasis thing. Even though it says microphone, what it really means is the iOS audio subsystem (keep in mind musicians are a very small percentage of the user base of iPads). It’s basically a security feature.
But you found the answer, happy recording!

Interesting. Just to be clear, I wasn’t referring to that Apple iPad pop-up about giving the app access to the microphone. I was referring to the fact that you can switch that feature (access to the microphone) off and on by going to the Cubasis app listed under the iPad’s Settings. Also, I was saying that you can turn off Cubasis’ access to the microphone (there under Settings) and still record a guitar into Cubasis using Audiobus and an app like Bias Amp. That seems odd to me. Further, it records the guitar with the Bias Amp effects, but it won’t record (if you set it up to do this simultaneously) a clean guitar track. It’s possible with Cubasis to record both tracks when recording a guitar using Audiobus. To get both tracks or to record directly into Cubasis on an iPad, you need to go into Settings and give Cubasis access to the iPad’s microphone.

Lars,

I followed your directions. To record a guitar directly into Cubasis on my iPad pro, I have to give Cubasis access to the microphone, which I do by going to the Cubasis app under Settings. If I turn access off, nothing gets recorded. Perhaps it is the Presonus interface. I also tried recording with a simple Griffin interface that I have. I can record using the Griffin interface only if I give Cubasis the iPad’s microphone. So using either interface, I can’t record if Cubasis does not have access to the iPad’s microphone.

Thanks for the help.
Dan

I wish I could remember where in the forum I had read that or possibly a beta testing email… but in a reply about two Or more years ago with Frieder Loch, it was mentioned that the microphone access must be enabled.

Lars… I know you know better so I’m only using a very used up brain to recall this one

Lars and knuckle47,

I was thinking that you couldn’t give Cubasis the microphone, because that would allow outside noises to come in through the microphone. But that doesn’t happen. I notice some significant noise on the Channel I’m recording into, and that’s cause for concern, but it isn’t because noise is coming through the microphone from the room. Cubasis isn’t picking up any noise from the microphone.

Now my concern is that giving Cubasis the microphone interferes somehow with the quality of the recording. In my judgment, that also doesn’t seem to be happening, but I can’t be sure. Lars said (above) that giving Cubasis the microphone “leads to wrong results!” But from what knuckle47 has said, and from my own experience so far, I’m not sure that Lars is correct.

Before I do anything, like contacting the manufacturer of my current iOS interface, I’d like to know whether giving Cubasis access to the iPad Pro’s microphone is necessary if you want to record guitars directly into the app properly with no “wrong results!”

Thanks,
Dan

Hi Dan,

You did not mention, that you were talking about giving Cubasis access to the microphone in the iOS settings, which is mandatory.
I was assuming, you have to assign the internal mic somewhere in Cubasis instead of your audio device in use.

Be assured, the iOS mic setting will not cause any problems when using external hardware for recordings.

Best,
Lars

It’s here, and a mandatory setting…
https://www.steinberg.net/forums/viewtopic.php?f=183&t=56030

Best,
Lars

That mic access pop up is a front end to the settings and usually appears on the first run.
Every audio app I have uses that setting, including audiobus. Again, even though it says microphone, what it means is the sound card built into the iPad.

Bias is working without it, because it sounds like you are using it as an IAA input to Cubasis. Bias has access to the mic, and IAA is an os level application passing Bias to Cubasis
Not sure why you can’t select the clean input directly in Cubasis with Bias as an IAA, but I would guess that it may be Bias thinking it owns the input. (I don’t own Bias so I can’t test). That would explain why audiobus does work, as it is splitting the input prior to getting to Bias.

Hope that helps

I did mention doing that, but perhaps not clear enough for you. Sorry about that. But it all makes sense now. Thanks for your time and expertise!

Dan

Ok, thanks wigglelights. Something like that must be going on. But from now on Cubasis will have the microphone!

Dan

Thanks for the update, glad to hear the issue is solved.

Best,
Lars