[Solved] Quantize not woking correctly(C6.5.2)

If I create a groove from a MIDI clip the position percentage in the quantize pannel does nothing!..

This is important for me and was working before I upgraded to 6.5. If I say import a groove from FXpasion Guru at 100% I was able to create a groove from MIDI and then adjust the position percentage in real time to get the groove I want, as I would in Guru. Now, it does absolutley zip!!!

I hope Cubase get this sorted as I waited ages for this feature having used Abletons and Gurus groove functions, got the feature I wanted and now its gone again… :unamused:

The only workaround is to create a groove template per percent, so thats 100 templates for just 1 type of groove, not very practicle.

Fingers crossed this is a bug that will be ironed out with the next update.


This is not a bug…maybe a local issue on your PC and/ or the VST Plug-In.

  • Enter the Swing you want and use the Quantize Button----> Works without any issue…

Hi Marcus…

Thanks for issuing me with a board warning!!

This is not a feature request, it’s a bug!

I’ve been using cubase since SX and had this working in version 6 (and possibly 5, can’t quite remember) and since updating to 6.5 it doesn’t.

This has nothing to do with swing. I know that swing works fine! I’m talking about when you import a groove from a midi part and then adjust the position percentage. When you import your own groove the “swing” disappears on the quantize panel and is replaced by “position”. But, like I said, now position doesn’t work.

How can this be a feature request if it already exists and let’s just say I have gone completely mad and imagined a feature that I used frequently, then what is position and why doesn’t it do anything?!

Furthermore, how can I report a bug without putting bug in the headline, ridiculous!

I suggest a bug and you confirm it or not, surely? Not issue me with a warning!..

Maybe I’ve gone about things the wrong way? Care to explain the correct procedure for reporting bugs?

That’s already in one of the stickies:

Ah, thanks… Wasn’t aware of that before I went on my rant, was just a bit wound up from getting a warning. :blush:

Right then…

Open cubase - empty project

Insert Giest

Draw 16th notes in Giest

Drag midi to cubase page

Right click midi part

Advanced quantize - create groove quantize preset

Go into midi part

Select new groove preset

Select auto apply

Adjust position…


Can someone else confirm this for me please?

I’ll give it a whirl. But I have no idea what “Giest” is.

Thanks… :slight_smile:

Sorry Giest is a vsti by fxpansion… It doesn’t have to be giest though, just an extracted groove from a midi clip.

It’s actually Geist, not Giest :wink:
Got me confused as well for a bit. I haven’t got it though :frowning:

Ha ha, oh yeah… :slight_smile:

Has anyone tried the position slider yet? It will only appear once you have created your own groove preset.

Everything is working fine here on 6.5.2.

Once you created your groove you need to select another quantize preset and then auto quantize. Otherwise the the position slider will not effect the position …

Hi, thanks for trying it…

What do you mean, select another preset? do you mean select another one (not the on you’ve created) and then select the one you created? Deselect then Reselect. :sunglasses:

Also, can you confirm that when you set the position slider to 0% it sets your midi to standard 16ths?


Yes, select another preset that is different to your created preset. I know this sounds obvious but the only logical reason why you are seeing no effect must be that you are quantizing with the the same created preset.

Also bear in mind that the position slider only works with user created presets not the standard factory grid presets (the position slider should not appear in these presets…)

I think I might be seeing a the problem that you might be referring to.

If for example if I create a midi pattern of 1/4 notes then select another user preset and select 0% on the position slider I would expect the notes not to move at all (0%) but after quantizing they do move from they 1/4 positioning .

OK I think I’ve worked out what is going on here. The position slider at 0% effect the midi pattern according to it’s original pattern. I.e if you create from scratch a 1/4 note pattern and alter the pattern to e.g 1/16ths the position slider will still only effect the quantize according to the original 1/4th pattern. So 0% will start from the first created 1/4 note positions.This seems to be what is happening here…

Hmmmm, I’ll have a little play around when I’m at my computer.
I’ve only ever done a user preset with 16ths. In theory if I use a heavily swung user created groove with auto apply, 0% should move the midi back to standard 16ths (no swing) and 100% should move the midi to full swing. This is how it used to work.


Write a 16th pattern with the standard 16th preset (not user created)

Now select a user created preset

Set the position slider to 0%

Select auto apply

Gradually move the slider to 100%

The midi will move to full swing

Gradually move the slider to 0%

The midi will move to its original position (no swing)


That’s how it should work, but it doesn’t seem to be working like that for me now.
Thanks for looking into this for me, I’ll run a few more tests and report my findings.

Okay, I’ve got to the bottom of it…

It seems there was a couple of issues sending it mental.

The first one was that it appears that “Groove to preset” doesn’t deal well with overlaps, so functions-delete overlaps dealt with that issue.

The second fix was setting the pre-Q to 16th in the quantize pannel, this allows the midi to snap back to 16ths and then to the position on the slider.

So, all is calm again in the land of Cubase and it appears I jumped the gun a bit declaring a bug (Sorry for all the exclamation marks Marcus :blush: )

Right, I’m off to the naughty step where I shall be reading the stickies…