[SOLVED] Trouble with IAA midi

Simple scenario:

  • I start Arturia iSem as InterAppAudio
  • I select my external synth keyboard (via camera connection kit, recognized via USB) as midi in sending on channel 1 and send it to iSem via channel 2 output. Fine so far: I can play ISem with my keyboard.
  • I start Arturia iMini
  • I select my external keyboard as midi in on channel 1 again and send it on midi out channel 3 to the iMini

Now if I want to record one of the two IAA connected synths by playing my midi keyboard, the other one is sounding at the same time. I found no setting to get seprated input, unless muting one midi track: but that’s not what I want, since I want to hear one track while recording the next.

Any idea to get that working?

Dear jimknopf,

Please check the midi output settings on the IAA track and assign them to "No MIDI output " when using IAA.

Thank you!
RG

That’s how I started before checking other routing options.

But when I have two (or more) IAA instruments running I always have all of them sounding whenever I hit a key on my external keyboard, no matter which track is the active one.

How do I get only the chosen track responding (with my external synth sending on midi channel 1)?
Does IAA not allow separate channels for different IAA synths, independent from the midi control input channel???

Can someone please clarify?

It’s probably more to do with Arturia’s sucky midi implementation. Their apps receive on all channels, no option to select specific channels.

No, I checked that as well.

It doesn’t work with other IAA synths either (Sunrizer, Waldorf Nave etc.): they all receive the same midi signal all the time, no matter how you route.

And Arturias iSEM does offer midi channel choice as well, by the way, while iMini still sucks concerning midi channel implementation.

Bump?

Anyone from Steinberg confirming the issue or offering a solution would be fair IMHO.

At the moment my complete effort to record into an iPad Air with Cubasis being on vacation, and then to work with the result in Cubase 7.5, is hanging due to this unsolved issue.

This is elementary functionality stuff and no small subcategory problem.

Hi all,

Workflow with multiple iAA instances and external keyboard in cubasis.

Disconnect inside the iAA standalone App the external midi interface inputs, except the cubasis midi input !

My Testsetup : Motif ES8 and "Midimate II " as external Midi interface

  1. create new project and midi track 1 and activate in > setup > arranger > “Arm Selected Track”
  2. assign iSEM as iAA instance to midi track 1 and open the iSEM midi settings
  3. disconnect the iSEM external midi inputs , set in “off” mode ( see attached picture)
  4. go back to cubasis and select midi track 1 and play on keyboard
    Result : midi track 1 iSEM is soundable
  5. create midi track 2 and assign Microsonic Piano
  6. select midi track 2 and play on keyboard
    Result : only midi track 2 Microsonic Piano is soundable
  7. create midi track 3 and assign iMini as iAA instance and open the iMini midi settings
  8. disconnect the iMini external midi inputs , set in “off” mode ( see attached picture)
  9. go back to cubasis and select midi track 3 and play on keyboard
    Result : only midi track 3 iMini is soundable
    10: select midi track 1 and play on Keyboard
    Result : only midi track 1 iSEM is soundable

So, iAA midi with cubasis works as expected.

Please check my description and give me an info if your " iAA midi trouble " is gone !

best
jan

Just tried the workaround with three of the synths and can confirm it works so far!

Thank you very much, Jan, this gets me/us going again!
Greetings to Hamburg from a German at Cote d’Azur :sunglasses:


P.S.
Seems the workaround does not work with the Bismark bs16 sampler.

Next problem: hanging midi notes all over the place while using an external midi controller (synth).

I was so happy about the midi routing workaround (see above) and thought I finally could record.
But I get hanging midi notes playing the external keyboard all the time.

This happens regardless of track configurations: even a simple Microsonic track with Piano can’t be played wihout hanging notes from my external keyboard.

Anything I as user could check or change?
So far still not able to do any reasonable recording.

Hi Jimknopf,

hanging notes is an different issue, see here :

http://www.steinberg.net/forums/viewtopic.php?f=183&t=61768

For better support please, make an new entree for one issue or bugs.

best
jan