Some key commands quit working in Dorico 4.3

A few of my key commands no longer work after I updated today. They are still listed as key commands page and in the jump editor. Two I use frequently [1] call up the graphic slices editor (ctrl shift g) and [2] return to the general graphic editor from the frame/system/note spacing editor (g). I can’t remember if these were custom or standard key commands.
Ideas?

If you begin recording a script and then press the shortcuts, what is listed in the usermacro file? ie are the shortcuts displaying the correct function?

Thanks for responding!
I’m sorry to say, but I don’t know what you mean. I tried recording a new macro (I don’t have an option to record a script in Dorico) and then ran that macro by using the “user macro” option at the top of the Script menu. It worked. I then went to the key commands window and did not see the macro I just recorded. But I have never been able to assign a key command to a macro I create.
This is the closest I could come to following your instructions. Probably missing something.

Sorry - I think I’ve used the wrong term. I meant try recording a macro. But, instead of clicking on the graphic editor etc, try using the key commands you’ve set and then stop the recording.

Now, open the usermacro file…

If your key command is to return to the graphic editor, is that action referred to in the usermacro file some way?

This is probably a really stupid way to identify what is going on :joy:

I’m on Windows 10. Since you seem to be unsure of whether the macros are the same as simple key commands, maybe I’ll wait to see what others say? Like I said at the beginning, some of my key commands don’t work. (Macros never worked for me.)

That would be a good way to verify the wording of commands … but I think the likelihood that any of them have changed wording since 4.2 is about nil.

But if you go into Preferences > Key Commands, pick a random one, and try assigning it a shortcut that isn’t working for you, you can see whether there’s another command already using that shortcut.

I selected “Application > About Dorico” and put in ⌘⇧G (equivalent of Ctrl+Shift+G in Windows) and the dialog warns me that shortcut is in use for the (new) Window > Key Editor Zoom in Vertical. I don’t know what might be going on for you with the bare letter G but of course it is important for note entry.

In the case of duplicate shortcuts, I think the menu item that comes first takes precedence. (But I don’t know exactly what constitutes coming first.) You can remove Ctrl+Shift+G from the above command if you’re sure you don’t want it.

So I did what you said and got the same results for the key command Ctrl+Shift+G while selecting the “Application” window. However, when I select my “Edit” window and check the key commands, I get the shortcut I set way back when. If I try to delete my shortcut, I am unable to reset another shortcut. (The button to save remains dull.)
I’ve attached a graphic to show what I mean in case the explanation fails.

Update 2: It wasn’t the keyboard layout. CTRL-SHIFT-H has been assigned to the new Key Editor zooming features. So, everyone who is having trouble with key commands, the new update may have taken over what we chose.
Update: I discovered that I had my keyboard set to US international. When I returned it to regular US keyboard, my keyboard shortctut worked.
Original post
I use to be able to type CTRL-SHIFT-H to hide time signatures. (My key command shortcut for the item ‘hide/show item).’ I can’t do that in 4.3 and if it was in the Jump menu - I think it was - it is not there. I can still hide a time signature by opening the properties panel and selecting the the couple of buttons required - far too many keystrokes compared to my shortcut.

The shortcuts Ctrl+Shift+G and G are new factory default shortcuts in 4.3, so they will be clashing with the ones in your custom set. You can delete the default ones if you don’t want to use them (related to Key Editor zoom) or you can change your own custom ones.

Not sure this is correct, Daniel? I haven’t been able to delete the existing key commands. If you’ll check my screenshot above, you’ll see that the “remove key command” option is greyed out. I thought I’d tell you this because it doesn’t align with your assumption about the default key command flexibility. (And I’d like to have the option to keep these and other key commands I’ve changed over time.)
Thanks!

Your first screenshot - the one with that key combination set - shows the Remove Key Command option white, e.g. available.
Your second screenshot - the one in which you had typed that key combination - shows the Remove Key Command option as greyed out because you’ve not yet set the key command so there’s nothing to remove.

1 Like

I think it could be useful to add a little paragraph somewhere in the version history where new official shortcuts are listed so that users can easily check whether they need to change their users’ keycommands settings. My 2 c :wink:

3 Likes

Yes, I am able to remove my key command, but that is not the issue. I want to remove the new default key command and replace it with one I prefer. Dorico used to be able to do this.

You can still do it. Go to the Window category in the Key Commands editor and find the various Key Editor Zoom… commands, and remove their key commands.

Perfect! Thank you!