Some pages have collisions between systems

I originally scored a song for flute, contralto, piano, and violin. I chose a viola sound for the singer output. Then I added a viola part for easy readability, and moved the slider in the mixer for the singer (viola sound) to zero. My goal was to have the visual score match the audio output.

But this created a bunch of collisions between systems. I worked through the Dorico information for “Laying out and formatting pages”. I was happily buzzing along when I encountered the recommendation “For inter-system gap, enter 8”. That option didn’t appear in Layout. Finally discovered that the example given was for Dorico 3.5.12. So now what do I do? I don’t want to scrap this idea. And I don’t want to force just one system to a page.

I will be very grateful for any help given.

:violin: Working-Viola—I’m Comin’ Home|attachment (1.2 MB)

Reduce your space size a notch, in Layout Options (ctrl-shift-L)? Might be a simpler approach.

Thank you @Janus for taking the time to help out. That was one of the suggestions in the list that Dorico provided. It said “ 1. In the Space Size section, select Size 4 (6.5mm) from the Rastral size menu.”. I did that. I can try to reduce it some more and hope that it is still readable. I’ll let you know. :pray:t2:

Remember, you do not need to stick to the settings in the rastral size dropdown list. You can enter a precise number in the space size box.

You were right. I went to size 5, which worked perfectly. I can still experiment. The difference between a rastral size is 0.02. Many thanks. You made my day!

I like it when people experiment!

1 Like


“Courage is the price that life exacts for granting peace.”
—Amelia Earhart

I hope that is sufficient for our friends in Ukraine.

Me too!

1 Like

Just for your information Edna, that sounds like you were looking at the First Steps guide, which isn’t a manual so much as a long-form tutorial. It uses a specific example of music, so any exact instructions given are in that context.

For other projects, with different music and players, other values are likely to be better!

And the “Inter-system gap” is in the “Ideal Gaps” on the Vertical Spacing page in Layout Options, just a bit further up.


Thank you!

That sounds like exactly what I need. The systems aren’t colliding any more, but there is a large inter-system gap on each page.

If you want to share your project, I’d be happy to take a look and offer some pointers if needed.

I attached a zip file to the original post. Will that be sufficient or do you need another. I haven’t changed anything since then.

“Courage is the price that life exacts for granting peace.”
—Amelia Earhart

I am very grateful that you are willing to help.

“Courage is the price that life exacts for granting peace.”
—Amelia Earhart

You’re very welcome Edna! You’re right, you had already attached the project, and I’d missed it.

Here’s your project back with some adjustments from me – see what you think, of course you can disagree with some of my engraving preferences as a lot of that sort of work is subjective!

Some things I changed were in Engraving Options, which you don’t have access to on the iPad, but which will probably reduce the amount you need to move things around manually – I decreased the minimum distances between the staff and dynamics, lyrics, text, and tempo marks, to let them sit a bit closer by default and therefore relieve some vertical spacing pressure. Likewise, I decreased the minimum gaps between lyrics, letting them be positioned a bit closer together and therefore not push their notes as far apart.

For vertical spacing, you can look in Layout Options to see what I changed – crucially for you, I increased the 2nd value for vertical justification. That’s the one that sets how full a page needs to be vertically for Dorico to only justify systems, and not the staves within them (which was why you had 2 systems at the top and bottom of each page, but a very large gap between them). You can see a comparison of a page of music using and not using this justification at the bottom of this page in the manual:

A couple of your “Legato” text items had an extra line break in, that’s why they were originally positioned so far from the staff. I edited those and removed the line break.

Where you had changed the length of some lines (for gradual tempo changes or gradual dynamics) in Engrave mode, I’ve gone back to Write mode and changed their rhythmic duration there (so they span “in time” the amount you want). You can do that on the iPad by dragging the circular handles at the start/end of items that have duration.

I also changed some positions and alignment of lyrics, to make sure they were attached to the right notes.

:violin: Working-Viola—I’m Comin’ Home 2_LH.dorico|attachment (1.2 MB)

1 Like

Wow! Thank you many times over!

I will study this and learn as much as I can from all of your hard work.

You are a highly creative and caring person.

1 Like

It’s honestly a pleasure to get to look at people’s work when they put as much care into it as you obviously have, Edna :slight_smile:

1 Like

Blush …
I’m grateful to be able to do this. The song is a journey song of my own life. It’s taken most of a year to write, because I was learning Dorico simultaneously. The software is stupendous. I feel like I haven’t even begun to learn its capabilities.

My family wanted me to sing it myself so it would truly be my story. For that, I had to write the viola part because my voice has changed from a big bold soprano to a sound little more than a whisper with a 5-note range.

I sing only the three occasions that begin, “I have faith in my creator…” The rest is spoken.

Writing music is the most enjoyable part of my day. In other words—love Dorico :notes:


Good for you! I love that you’re carrying on making your music, whatever the challenges. It’s great to hear how Dorico is helping you do that.

:+1: Dorico is awesome, and the kindness of the developers and forum members make it fun.

1 Like