Some problems formatting an XML import

I wanted to see how Dorico would do with an XML import of a Finale piano/vocal score. I knew I would not be able to put a bracket on the choral parts, but I ran into some other problems I thought you should know about.

  1. On page 1 there is a break for dialogue. I had two problems with this. One was getting the text size to stick at 10pts. I would change a line to 10 pts, but it would switch back even when I tried to change the default property. The second problem was getting the staff spacing to make room. The ability to change the staff spacing by number is great; but it too kept changing back. Compare the PDF to the PNG of page 1 which I opened after creating the PDF and closing (and Saving) the program. (1010 KB)
    I realize one option I did not try was changing the frames on page 1 to create a text frame for the dialogue. Perhaps that would be a more elegant solution, but the staff spacing should still hold, right? (415 KB)
    I also had a question about how Dorico casts off systems. The systems on p. 3 are tight with a gap below. Those on p. 9 are stretched out to fill the space (not very attractive, but perhaps that will get better), but then those on p. 10, which might benefit from a little more space between staves, remain tight.

I’m not sure what happened to the lyrics in measure 50; the overwritten syllable was (thankfully) not in version from which I made the XML. Maybe I did something without realizing it.

At any rate, I enjoyed this as a learning experience; Dorico does some really nice things on its own. I’m still learning (and trying to remember after I do) where exactly to look for things. (“Was that in Engraving? No it was a Layout option.” etc.)

Whoops, originally did not include the PDF (that needed to be zipped). Now corrected.

Sorry to take so long to come back to you on this thread.

This was a bug that we fixed in 1.0.20.

We found a bug in the staff spacing code, discussed here, that might explain this. It’ll be fixed in 1.0.30.

I think this is simply that you’re very close to the threshold for whether or not the page should be justified; you can will find this thresholds on the Vertical Spacing page of Layout Options. Try reducing the lower value (60% by default) to a lower value still, so that Dorico will justify the page even when it is less than 60% full.