Soothe2 VST3 not recognized by Cubase 9

Hello guys.
I’m having the same problem in my Cubase pro 9 in my mac with the osx 10.12.6.
I bought Soothe2 last week and Cubase just doesn’t recognize the VST3 of Soothe2.

Even after deleting the vst3 xmls to force a hard scan.
Already uninstalled and reinstalled cubase too.
I left only soothe2 in the vst folder, and even like that it doesn’t appear in the cubase, not even blacklisted.

Anyone know a workaround for this?
I’m becoming desperate already.

Hi and welcome to the forum,

MacOS has standardized plug-in folders. So there cannot be an issue of the folder missing in the scanned paths (as it could be on Windows).

Are you sure, you have the latest plug-in update installed? Is the plug-in compatible with this older macOS version?

VST3 plug-ins have the *.vst3 extension. I don’t know, what do you mean by this.

Have you tried to rename or delete the blacklist.xml file?

Thank you for the welcoming
I installed the last (1.3) and the 1.2.2, that is the one that is supposed to work with my os. To try
When i say the vst3 xmls is exactly that
blacklist.xml that you are talking about.

Already tried to add the vst3 folder too and nothing…
And the others vst3 that are on the same folser appear there, only the Soothe2 doesn’t.