Sound won't come through my headphones!

I just upgraded to Dorico 3. I have my headphones plugged into my monitor. The sound is coming out of my speakers instead of my headphones. I tried plugging my headphones into my computer, rather than my monitor, but that caused all sound to stop.

You should go into Edit > Device Setup and make sure you have appropriate settings in there. Dorico 3 won’t pick those settings up from Dorico 2, so you should quit Dorico 3, run Dorico 2 again, open a project, then open Edit > Device Setup and make a note of what settings you have in there, then go back to Dorico 3 and replicate those settings in the new version.

This may or not be a related issue, but I can’t get Dorico to play through my bluetooth headphones, even when other apps and browsers are.

Try this: https://www.steinberg.net/forums/viewtopic.php?f=246&t=161749&p=866290&hilit=aggregate#p866290

The device setup settings are exactly the same in both Dorico 2 and Dorico 3.

Have you closed Dorico (or at least the project) since updating Device Setup? At least in Dorico 2, this change required closing the project and reopening.

The settings were already the same; I didn’t need to change anything.

I suggest you try changing something, and then changing it back again, namely the sample rate. Change it to e.g. 480000 if it’s currently 441000, then wait a moment, and change it back again.

48000 is the only sample rate in the drop-down list.

Try switching off the option at the top of the dialog that forces exclusive control of the audio device.

It’s already off.

Then try switching it on again.

That didn’t work.

Well, fun as this is, I’m afraid I don’t think I can offer any further assistance at this stage, I’m afraid. You might try installing ASIO4ALL and then choose that instead of the Generic Lower-latency ASIO Driver in Device Setup. If that doesn’t help, then create a new project with a single instrument in it, type a few notes into it, then save it and zip it up and attach it here. Also do Help > Create Diagnostic Report and attach the zip file from your desktop to a reply here as well. Ulf is better placed to diagnose these problems than I am, but it’s nearly 1am on Sunday morning and I’m afraid he’s not here right now to look at it.

Untitled Project 1.zip (421 KB)
Dorico Diagnostics.zip (191 KB)

Worked! Thank you!

Hi ThatViolaGuy, do I understand that correctly, you do get sound out of Dorico 3 but only through the speakers? Just when plugging in the headphones sound is gone?
How about other applications (e.g. youtube via browser or media player, does sound output then also stop)?
Because your port settings tells me sound goes to “Speakers/Headphones (Realtek)”, so this is a combined device and it will automatically switch depending whether the headphones are plugged in or not. So Dorico has no control over the sound coming out of speakers or phones in this case.

Dorico’s internal device mapping and mixer state look fine. What if you open the NotePerformer GUI and start play back, does it show any kind of metering?
If that is the case, then the audio engine produces audio data and delivers it to the audio device (Realtek).

I saw you have NotePerformer 3.2. You know that you have to take additional steps to make it work properly in Dorico 3? If not, there is a recent thread in this forum about it.

The problem only occurs when I plug my laptop into my monitor; when using it without the monitor, it works fine. This problem does not occur with other programs. What do you mean by “metering?” I took the steps in the thread about NotePerformer, but that did not change anything.

By “metering” I assume Ulf wants to know whether there are any green lights that appear in the meters of the faders in the NotePerformer editor (the window that is opened by pressing the e round in Play mode), when you hit play or enter notes with a midi or computer keyboard.

That would mean that NotePerformer is producing signal, and that the problem comes from somewhere else.