Staccato Playback of tied notes (with staccato dot on first note)

Hi, is there a way (or planned a possibility) in Dorico to tell it to play back all the following notes as staccato (i’m using VSL btw) without using Force Duration. Since Dorico handles tied notes in quite all manners as a singe entity, it should it do here, too. Especially with the dot on the first note.
I found this topic (DORICO 4, its MIXER and PLAY mode - #111 by witold) but got lost in all the arguing, so a simple “yes/no/maybe with the next release” is more then enough :wink:

whether notes like this play back staccato depends partly on the tempo. For instance if you set crochet =120, then the passage will play staccato but if 72, then it won’t, assuming default settings of 1/4 note maximum duration for staccato playback in your Playback Options. If you change this setting to 1/2 note or even longer, then you should find that staccatos are played as required.

1 Like

Hmm… at least with my setup (VSL) it seems there is no difference which tempo i write or which value i enter as note duration for staccato notes. As long as i don’t write a crochet with “Force duration”, the highlighted notes don’t play back as staccato.

Dorico does not treat staccato ties the same as normal notes, See…


Oh, didn’t see that thread. That was the info i was searching for. Good to see the team is thinking on this. Thanks Janus for the pointer

although the existence of a tie-chain can change whether a note is interpreted as staccato or not, in your particular example, that’s not the determining feature as far as I can see. I used the VSL solo violin (although this issue is library independent as far as I can remember) and set tempi 120 and 72. At 120 all the notes are staccato and at 72 none of them are with default settings. The difference is the ability to change the maximum duration for staccato playback (which was introduced after the thread referred to). If you’re getting different results, then it would be interesting to see your project. It also makes no difference on which note in a tie the dot is – thought I’d check that to make sure.

1 Like

Ok, i think i had a mess in some Playback options. As i wrote before, i tried several values and tempos, but there was no change. That’s what i got with 10%, 50% or 70% staccato duration:

After i applied the “Reset to Factory” settings, i got this, which looks pretty good. Can’t tell which actually caused this problem, but now it seems it works as you described.

Thank you for your help!

glad you’re getting to the bottom of this – by the way, I didn’t try changing the actual staccato lengths as you did but rather the “maximum duration for staccato playback” setting lower down

It’s this setting when changed to 1/2 or even whole note which can bring back the staccato.

Ah, i see! :+1: