Staccato playback persists due to grace notes... and metronome marking

In this little fragment, the staccato playback continues to the end of bar 2 despite the fact that that note hasn’t an articulation. This seems to be due to the presence of grace notes - specifically the ones attached to the last beat - but playback is correct, even when those grace notes are present, if I shorten the B to a crotchet. I’ve tried, but to no avail, changing the voice of the B with and without its preceding grace notes.
I’m using NP, and am attaching the fragment as well as the screenshot.
staccato problem.dorico (715.0 KB)


[Later] I’ve now discovered that the staccato markings have nothing to do with it. AFAIKMO, it’s all about a pair of grace notes preceding a dotted crotchet or any longer duration. Flummoxing in the extreme.
[Even later] Oh, this is getting more flummoxworthy hour by hour. I now discover that, if I change the metronome marking from q=80 to q=88, playback is correct!

I tried to recreate your example from the description in this topic, but I couldn’t get the problem to occur until I downloaded your Dorico file. It seems that NotePerformer doesn’t like the tempo change from q=90 to q=80 at the start of measure 2. If I move the second tempo mark even one 32nd to the left, then the last note in measure 2 plays back correctly. The position of this tempo mark can be moved in Engrave mode if needed.

PS: I did a Google search on the word flummoxworthy (without a hyphen) and this topic was the only result!

Thanks again. An intriuging issue. Also - I’m proud to have introduced a new word into the language!

1 Like

I may be getting obsessed over this, but I still can’t understand what exactly is happening. I intended to upload a file consisting of nothing but this pesky phrase, but with three versions: the original (not, by the way, cut and pasted from the full piece), one without grace notes on the final note, and one with grace notes which are on a pitch different to that of the main note. I tried all sorts of metronome marking in various positions in this file, but was unable to get the note in question in example 1 to play for its full duration.
Now, I then remembered that the main note will play back if it’s less in a duration than a dotted crotchet, so I added a fourth example to show this behaviour. This time I did cut and paste, and from example 1. Before I changed the main note’s duration to a crotchet, I (for some reason) played example 4 back with the dotted minim still in place… and, blow me down if it didn’t play back correctly. So example 4 is identical to ex. 1, but plays back differently. Is there anything under the bonnet/hood to show what’s going on?
staccatos again.dorico (528.4 KB)

I don’t quite understand why, but you can fix it by changing the length of the graces in Playback Options. Increase it to 0.19 and it plays back correctly.

Wow - that’s inspired! Thanks!

I have found the culprit by examining the MIDI file exported from your example. Every time there are two grace notes followed by a normal note, the note off event for the second grace note happens at the same time as the note on event for the normal note. When these events happen at the same time, a race condition occurs. Sometimes the note on event for the normal note will be processed before the note off event for the second grace note. If these notes have different pitches, this won’t cause a problem. But if they have the same pitch, the normal note will sometimes be clipped so short as to be practically inaudible.

1 Like

I’m so grateful to you for discovering the root cause - I couldn’t for the life of me figure out what was going on! Many thanks.