Steinberg Download Assistant not working on my Mac

on mac 12.2.1 STEINBERG DOWNLOAD ASSISTANT 1.32. 0 is not working. is not shown at all only seeing spinning wheel.
as on macBookPro Intel the same happens also on mac mini M1

3 Likes

I have the same issue with Mac M1. I just bought Cubase 12 Pro but I cannot even open the Steinberg Download Assistant

2 Likes

any solution here?? assistant doesn´t start at all. hangs up.

2 Likes

Same problem here. Just installed a terabyte and a half of applications and plugins on a new Mac and the only thing that doesn’t work is the Steinberg Download Assistant. I’d give anything for direct download link to Cubase 12… but I have 14 days for a refund… So I’ll give Steinberg 13 to fix this before I move on. Been a customer since SX3 but their ancient licensing and constant PITA store vs. website and cookies prompts might just end here now. It becomes less and less worth it each upgrade. I had Ableton Live Suite and dozens of add-ons working in less time than it took to find a link to purchase from Steinberg again… and I didn’t need a dongle or 3rd party application to do it.

3 Likes

Here’s a link to the direct installer. Hopefully this saves someone more time than the dysfunctional download “assistant”

1 Like

STEINBERG DOWNLOAD ASSISTANT 1.32. 1, newest version is also NOT WORKING!! shame.

2 Likes

Hi, is my Idea or Steinberg is going down ??? :confused: I hope I am wrong, but customer services and the way how they are punching away users, that not good…

2 Likes

i am in contact with steinberg support. they think that i am the only one who has problems with the download assistant. that is not my opinion. unfortunately, they cannot read any errors from my sent log files. i think i will wait for the next update, as i can also install manually, but this makes things a bit tedious.

2 Likes

I was so happy thet with my new Mac Studio M1 I could finally install the latest cubase, But I had the same experience you are talking about.
Steinberg Download Assistant does not run.
The older versions are not available.
I downloaded Cubase 12, Steinberg Activation Manager, Steinberg Library Manager manually, but if I try to run Cubase it seems like it does not find a licence (that I have), maybe because I need SDA to enter the download access code. Could anybody fix this before me?

P.S. I could redeem the access code by logging in, but still it does not find the licence and closes cubase

2 Likes

Hi, Did you fix your problem?

1 Like

Any Solution ?? this is crazy what happens with Steinberg ??

1 Like

Has anybody come up with a workable solutiom yet ??? I have been trying to upgrade Cubase from v11.5 to v12.0 on a Mac Mini with OSX 12.6 for several months. SDA worked fine on earlier version of OSX. I have all the latest versions of eLicenser etc installed but the workaround suggested by Steinberg website article does not work either. Have contacted “support” several times and sent them error logs etc but they have never bothered to reply. They have my money so I assume that’s all they are interested in !!!

2 Likes

same problems with macbook pro m1

1 Like

Same here. Mac mini M1 2020. macOS Monterey 12.6

2 Likes

Found out what’s going on. The App is Java / JavaFX based, Java version 8 or 1.8 (it’s the same). If you run it from the command line like this:

./Steinberg\ Download\ Assistant

in the app directory

“/Applications/Steinberg Download Assistant/Steinberg Download Assistant.app/Contents/MacOS”

you see the output of JAVA. It crashes in a function called “MacFontFinder.java” in Line 89.

I researched the error and it was fixed in 2017 (see bugs dot openjdk dot org slash browse slash JDK-8089900 ). So it seems that Steinberg is using a very outdated JAVA runtime. They should be able to fix it by porting their Java software to a newer Java version.

Output:

21:59:03.135 [main] DEBUG net.steinberg.elicenser.download.singleinstance.SingleInstanceLock - Lock file is: /Users/XXX/Library/Application Support/Steinberg/Download Assistant/net-steinberg-sda.4EA4CA71-30AB-4E8A-A087-757CA9B5E747.lock

21:59:03.149 [main] DEBUG net.steinberg.elicenser.download.singleinstance.SingleInstanceLock - Message file is: /Users/XXX/Library/Application Support/Steinberg/Download Assistant/net-steinberg-sda.4EA4CA71-30AB-4E8A-A087-757CA9B5E747.message

Sep 29, 2022 9:59:04 PM tornadofx.Stylesheet$Companion detectAndInstallUrlHandler

INFORMATION: Installing CSS url handler, since it was not picked up automatically

Exception in Preloader start method
Exception in thread “main” java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:49)
at org.springframework.boot.loader.Launcher.launch(Launcher.java:108)
at org.springframework.boot.loader.Launcher.launch(Launcher.java:58)
at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:65)
Caused by: java.lang.RuntimeException: Exception in Preloader start method
at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:899)
at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$1(LauncherImpl.java:182)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.ExceptionInInitializerError
at javafx.scene.control.ProgressIndicator.createDefaultSkin(ProgressIndicator.java:199)
at javafx.scene.control.Control.impl_processCSS(Control.java:872)
at javafx.scene.Parent.impl_processCSS(Parent.java:1280)
at javafx.scene.Parent.impl_processCSS(Parent.java:1280)
at javafx.scene.Parent.impl_processCSS(Parent.java:1280)
at javafx.scene.Node.processCSS(Node.java:9069)
at javafx.scene.Scene.doCSSPass(Scene.java:545)
at javafx.scene.Scene.preferredSize(Scene.java:1646)
at javafx.scene.Scene.impl_preferredSize(Scene.java:1723)
at javafx.stage.Window$9.invalidated(Window.java:864)
at javafx.beans.property.BooleanPropertyBase.markInvalid(BooleanPropertyBase.java:109)
at javafx.beans.property.BooleanPropertyBase.set(BooleanPropertyBase.java:144)
at javafx.stage.Window.setShowing(Window.java:940)
at javafx.stage.Window.show(Window.java:955)
at javafx.stage.Stage.show(Stage.java:259)
at net.steinberg.elicenser.download.gui.preloader.StartingScreen.start(StartingScreen.kt:50)
at om.sun.javafx.application.LauncherImpl.lambda$launchApplication1$6(LauncherImpl.java:785)
at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$7(PlatformImpl.java:326)
at com.sun.javafx.application.PlatformImpl.lambda$null$5(PlatformImpl.java:295)
at java.security.AccessController.doPrivileged(Native Method)
at com.sun.javafx.application.PlatformImpl.lambda$runLater$6(PlatformImpl.java:294)
at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
Caused by: java.lang.NullPointerException
at com.sun.javafx.font.MacFontFinder.populateFontFileNameMap(MacFontFinder.java:89)
at com.sun.javafx.font.PrismFontFactory.getFullNameToFileMap(PrismFontFactory.java:1705)
at com.sun.javafx.font.PrismFontFactory.getFontResource(PrismFontFactory.java:438)
at com.sun.javafx.font.LogicalFont.getSlot0Resource(LogicalFont.java:194)
at com.sun.javafx.font.LogicalFont.getDefaultAAMode(LogicalFont.java:409)
at com.sun.javafx.font.LogicalFont.getStrike(LogicalFont.java:413)
at com.sun.javafx.font.PrismFont.getStrike(PrismFont.java:73)
at com.sun.javafx.text.PrismTextLayout.setContent(PrismTextLayout.java:138)
at javafx.scene.text.Text.getTextLayout(Text.java:229)
at javafx.scene.text.Text.needsFullTextLayout(Text.java:184)
at javafx.scene.text.Text.access$200(Text.java:95)
at javafx.scene.text.Text$2.invalidated(Text.java:389)
at javafx.beans.property.StringPropertyBase.markInvalid(StringPropertyBase.java:109)
at javafx.beans.property.StringPropertyBase.set(StringPropertyBase.java:144)
at javafx.beans.property.StringPropertyBase.set(StringPropertyBase.java:49)
at javafx.scene.text.Text.setText(Text.java:370)
at javafx.scene.text.Text.(Text.java:129)
at com.sun.javafx.scene.control.skin.ProgressIndicatorSkin.ProgressIndicatorSkin.java:169)
… 22 more

2 Likes

Hi @Nanduhirion , thanks for your post and excuse the delay.
I forwarded your analysis to development and here’s what I got:

"This is no issue in the SDA code but in the JavaFX derivate we use.
Usually, it is caused by a font with an invalid name that is installed on the system.

Something that could help or at least help to find out if there is an invalid font would be:

  • Open Font book
  • Go to /System/Library/Fonts
  • Compress the whole Font directory
  • Click on “File” (don’t know what it is in English :wink:) and choose “restore standard fonts”.

As a result, the font book should only contain valid system standard fonts.
If the error does no longer occur afterwards, there was an invalid font.
The challenge might be finding out which font exactly causes the issue…"

Any feedback on this would be very helpful.

2 Likes

Thank you So much Ed, it is working :slight_smile:

The FONT RESET it fixes the issue with the “Download Assistant”

Why by email is so hard to get a proper answer like this from “Steinberg Customer Service” ?? :frowning:

Thank you again! :slight_smile:
My Best
Cristian Troncoso

BTW may I ask you how I can " Force" Nuendo 12 & Cubase 12 to Run Natively M1 Silicon on OSX Monterey?

Both run all the time on “Rossetta” mode doesn’t matter what I do, I already tried “Menu” from the App, and the option “Open Using Rosetta” isn’t ACTIVE

Thank you so much for your time !!

That’s “slightly” off-topic but have you had a look at this?
Cubase 12 / Nuendo 12: Using the native Apple silicon version – Steinberg Support

AFAIK, we will show the mode Cubase/Nuendo run in on the start screen which should make things easier.

1 Like

Thank you so much

It works!

:slight_smile:

1 Like