Steinberg Download Assistant will not Authorize

I have downloaded the latest version of the Download Assistant and installed it. When I first run it a webpage opens and you must login in order to authorize it. I log in successfully, I don’t get any errors. However, the download assistant doesn’t run - the sign-in window pops up again. I’m stuck in an infinite loop - Is the authorization server not working? I have followed all the steps carefully and gave the download assistant administrative control. Anyone else out there experience this behavior? I haven’t had any issue with the download assistant previously.

Yes - same here sent a ticket to Steinberg today, hopefully, they can help :slight_smile:

Cheers Martin

I am having the same issue.

I too am having this issue - I really hope this gets sorted soon…

I just wanted to pitch in here as I am having the same problem as you guys.

I am on Windows 10. Everything is up to date here. No nonsene.

Steinberg has the slogan “creativity first”, but I must say there has been nothing about creativity in my recent experience with Steinberg. I just wanted to review Cubase Pro vs. Digital Perform as I have grown out of Ableton Live for film music purposes. But I have had problems just getting started with Cubase Pro. First off they didn|t tell me that I need an eLicenser to even open the Pro version of the software, so I went today and bought one. I have installed Java script only for Steinberg puroses, and the malfunctioning Steinberg Download Assistant and of course the eLicenser software which I first thought could would do the job for the eLicenser. Too little information, too many flaws here to even start. If this is how the experience is going to be using Steinberg software I am pretty sure I don’t wnat to continue. Then the smooth experience of Digital Performer is much more intriguing.

Please help! I have obviously heard some good rumours about Cubase Pro. There is still some hope.

Definitely let us know. I’m having the same issue.

Had he same issue. Skowered the web, and apparently your computer clock need to be within a minute or “real time”. Anyway, I had turned off Windows updating the clock. When I turned that back on in Settings, the Download Assistant worked.

I’m having the same issue too. My clock is 55ms off UTC+1 and all the other software is up to date. So much for using Cubase 11 tonight.

Scottfafalconberry, thank you, thank you, thank you!!! That worked. I actually did turn on the auto clock thing, but I did do a sync now.

The Windows system clock was the issue. Thank you Scottfafalconberry! As soon as I sync’d the win10 clock it worked immediately. What was odd on my machine though is that sync was on yet the clock was out by about 3 minutes. In the change and date and time settings in Win10 there is a “sync now” button that I will be reminding myself to hit every once and while.

Same issue…

Thanks, it worked. :smiley:
Wasted ten minutes in the loop to get started but lucky I quickly found your research to solve this issue. :smiley:
My feeling is that Steinberg should have provided the info and a link to the “sync now” button.
They make such great products but just to get started I had to search for the why and how. :frowning:

Glad it worked!

Keyboard shortcuts don’t load presets

I am having the same issue. However i am getting a Time sync Failed error when i try to Sync the Win10 Clock.

FIX Authorize Steinberg Download Assistant when getting “Time sync Failed error” :

How can I fix the synchronization error?

1 Check if Windows Time service is running.
2 Use a different server.
3 Restart Windows Time service.
4 Use Command Prompt.
5 Disable your third-party firewall.
6 Change the default update interval.
7 Add more servers to the registry.
8 Change registry values.

Windows Time sync do did NOT fix issue here- still in infinite loop.
Why do legit users have to suffer, while cracked software users are already making music?

1 Like

Thanks, it works. My issue is that the windows time service did not work.

I start CMD with the administrator and run the command ‘net start w32time’. Then sign in successfully.

Same problem - Download Assistant will not Authorize. Anyone know the solution…?

I tried so many things to solve this problem, here is my solution that worked for me :

It was because my default web browser was not Chrome.