Steinberg UR44C DspMixFx - No Device Found

Hello, folks! I’m new to the forum and own a Steinberg UR44C (NOTE: there is no “cc switch” in the back of this device, only a switch which allows me to use either USB or 12v power - please don’t roll your eyes if this is the same thing, lol). I use this with Cubase Pro 11 on a newly built Windows 10 Desktop with 32g of RAM (AMD). With all that being said:

I have opened dspMixFx and have consistently run across a blank interface along with the error message “no device found”. After researching the topic to absolute frustration, I decided to ask for some help. So um…HALP!?

Thanks ahead of time for your help!

Did you update the firmware?

I think the latest tools require also latest firmware. If you open the steinberg yamaha usb driver control panel can you see the interface recognised there?

1 Like

I’m having the same issue and I’ve found 0 help on this topic. I found a forum thread from 2016 talking about it but nobody had a solution. I’m just gonna go to support. the forum hasn’t helped.

Having the same issue on a MacBook Air M1 (silicon) - no information available so far…

Hello, misohoza! The Yamaha Control Panel recognizes it, yes! Also, thanks for taking the time to try to help!

Also having the same issue, help please!

UPDATE: I have fixed the problem! I’ll tell you what I ended up doing and you can see if it works for you!

Issue: (provided that you own a Steinberg UR-C series device)

You open dspMixfx UR-C and simply get a blank interface along with the note “no device found”

Solution:

  1. First go to the “UR-C Updates and Downloads” page

  2. You will download two things - 1) - The latest firmware for your device (in my case it was UR44c) and 2) the latest “Tools for UR-C”

  3. Update the firmware for your device

  4. Install “Tools for UR-C”

  5. Boom - you have a brand new, working dspMixFx!

NOTE: If you have a shortcut to the old dspMixFx, delete it (it will never work)- there is a new dspMixFx on your system that has nothing to do with the old install. Find the new install and make a shortcut to that instead!

Thanks, misohoza, for the solid direction!

@LibraClassic1 thanks for sharing the instructions but still n to working for me. Doesn’t actually allow me to update the firmware. Comes up with an error message saying ‘UR is not detected please reboot and check connection’ it is connected and working fine on my Mac! (other than the fact that I cannot get the DSP FX to work)

Really frustrating there are so many issues with this hardware and software integration. Doesn’t work well at all