Stuck at "scanning VST3 plug-ins"

Hi
I just purchased upgrade from Cubase Artist 10 to Pro version.
Activated the code in Elicenser Control Center.
Launching the Cubase program shows that it is now the Pro version.

But the splash screen is completely stuck at “scanning VST3 plug-ins”.
I tried renaming the VST3 folder to VST3_old and try again. No change.
Same with reinstalling Cubase.

What to do?

Hi,

Make sure, your plug-ins are up-to-date, please. And be patient whle scanning. :slight_smile:

I’m pretty sure I don’t use any VST3 plugins. But maybe some native Cubase plugins use it.

How do I update the cubase vst3 plugins?
When I used the upgrade installer it said nothing needed changes.

Ok I will try letting the splash screen “scan” for longer.
I just almost know it’s frozen

Hi,

All Cubase built-in Cubase plug-ins are VST3.

I was thinking to update 3rd party plug-ins, if you use any.

Hi

I now tried waiting for many minutes without luck. SSD activity looks to be zero.
So I’m pretty sure it’s just stuck for some reason.

None of my (3) plugins can be updated.
But I tried removing their vst folders so Cubase can’t see them at all. Still stuck on VST3 scan on splash screen.
I also tried reinstalling the Elicense Control Center and running it as admin including maintenance. Still stuck on VST3 initialize splash screen.
And I tried renaming the appdata/roaming/cubase folder so it would re-initialize it all. It did, but still stuck on VST3 initialize splash screen.

Maybe I need to uninstall everything and start from scratch? :confused:

Hi,

Could you try in Cubase Safe Start Mode or trash Cubase preferences?

I just tried it.
First I tried “disable preferences”. Didn’t help, so I tried “delete preferences”.
No change, still stuck at VST3 scan :unamused:

Do you think I can completely uninstall and reinstall Cubase, and then restore the 3rd party plugins by simply moving them back to the folders they were in before? (from backup)
I mean the plugins are installed independently in the system, so it should be just a matter of restoring the vst dll’s/folder that cubase scans or points to.

EDIT: I couldn’t wait, so I just uninstalled all Steinberg.
Let’s see how it goes installing it

After uninstalling everything Steinberg via Windows app-uninstall, and reinstalling it all with latest Cubase installer:
No change. Still stuck at initializing/scanning VST3 plugins at Cubase splash. hmmm

Just created a support ticket.
But feel free to come with some ideas I can try :wink:

Hi,

Did you install it as administrator?

No. That hasn’t been necessary before.
Trying it right now.

After installing as admin, and trying starting it both as admin and without it’s still stuck at scanning VST3

Hi,

You said you removed all your 3rd party plug-ins from all folders, right? Are you sure they were really all folders?

Could you try to move the plug-in set component out of the Components folder (inside the folder, where Cubase 10.exe is), please?

Martin that helped locate/workaround the problem :stuck_out_tongue:
Thanks

The problem seems to be the file vstscanner.exe
Now I have removed that from the components folder (only that file).
And Cubase now starts up nicely. I can make music.

So I put back my own 3rd party VST(2) plugins, and went to the vst plugin manager and add my plugins folders.
When I press rescan in the bottom, Cubase complaints about “vstscanner for vst3 plug-ins not found! VST3 plug-ins are disabled. Check your installation!”
BUT it does scan and add my vst2 plugins and they are now all working without problems.

I don’t know if any native Cubase VST3’s are not working because of this, or if I’m missing out on anything (?)
Just tried a few, and they seem to load fine.

Hi,

I have to say I wasn’t aware about this component. But it looks Cubase cannot scan the plug-ins properly now and cannot check, if any plug-in is faulty and could cause a crash.

So I hope it will work for you like this. :wink:

So far I can work with this OK.
But I wish to solve it, so I will be talking to Steinberg support about it later.
Thanks

DOH! :smiley:
I just found an old leftover VST3 component from a plugin I thought was gone.
It was in Program Files\Common Files\Steinberg, where I didn’t know to look also.
Deleting that file made the VST3 scanner work as normal again.

I think it also had something to do with the latest big Windows update though…
I had to adjust some Windows apps/settings a few places, and some permissions were changed, maybe including the license for that old “deleted” plugin.

Oh well, all is good now

Hi,

I’m glad it works as it should now.

Cubase 10 didn’t recognize my Waves plugins and was hanging. Here’s the fix that worked for me if you have that issue.

https://www.youtube.com/watch?v=6mmaxH2TyLI

hello, do you resolved this issue ?
how can i get around the obstacle? I can’t open cubase.
Can you give me any suggestions?

Hi. I posted my solution here.
But if your problem is not identical then it won’t help you.
Start a new post about your problem