Sudden eLicenser problems, Win 10 update?

Did some recent/semi-recent Windows 10 update break something? I haven’t launched Cubase 8 at home in a few weeks but it was fine last time I did. But now when I do, it flashes my dongle a few times, and then pops up a “No valid license found. The program will quit now” – even though eLicenser sees the dongle and shows my licenses just fine. And yes I downloaded and installed the newest eLicenser to no avail.

If I try 2 or 3 times in a row, eventually it will launch correctly (although once it did so as Cubase Artist instead of Pro!) However, about 5 seconds after the hub window finally appears, I get an error dialog:
elic-error.jpg
If I dismiss it, the app continues to run just fine, but what the heck is going on? Didn’t used to be like this.

Cubase 8.0.40, Windows 10 Pro x64, build 1511 (not running Anniversary update) with eLicenser 6.10.4.1203.

Anyone else getting this? Did some Win10 update break something, or is my dongle dying?

Try to run elicense control as admin and perform maintenance.

i frequently get eLicenser errors after win10 updates, but not of this kind. It seems there’s an new eLicenser update after each win10 update. I notice that your version of eLicenser is even newer than mine, and I’m running Cubase 8.5. I wonder if your eLicenser is too new, but I bet an old version wouldn’t work with new win10.

My typical error message is that a required license (that I have) could not be found - it’s a Cubase message. Your error seems to be a timeout - it’s an eLicenser Control message. I don’t remember ever seeing anything like it. Perhaps the new version has a bug, or your eLicenser download was corrupted.

In another thread, it was indicated that the eLicenser doesn’t work well in a USB3 port, one should use USB2. I wonder if the USB port you are using has gone bad, or if the dongle has come loose.

While the app may seem to run fine, maybe it isn’t. I suppose it’s moot (at least for now) if Cubase and its add-ons are allowed to run normally.

It seems like Maintenance succeeds whether I Run As Administrator or not (and I am an Administrator normally anyway.)

Well like I said, I do get “license not found” sometimes. I just run it again until it finally works. But once it does work and Cubase gets up and running, that’s when I get the weird “USBDeviceOS_Finish expected but received” error a few seconds later.

Well I’ve pulled it out a couple of times so I don’t think it’s loose or dirty or not making good contact, I don’t get any random disconnect/connect device sounds even if I wiggle it. As for USB3 my motherboard only has 2 USB2 ports (there’s some more leads on it but I don’t have them wired anywhere) and the rest are USB3. But I put it on the USB2 bus and still have problems - It just launched as Cubase Artist again, second try was No Valid License, third try worked (as Pro)

I’ll have to try taking this dongle to my Windows 7 machine at work and seeing if it works OK, just to rule out the dongle failing. But it really seems like software, since it’s been working just fine since I build this machine in February and only recently has started misbehaving like this.

You are not alone in this. Recent elicenser problems is a known issue to Steinberg although the only official reply by support is trashing preferences, which doesn’t fix it.

I have had problems on 3 machines. Interestingly one of the machines is my Vienna Ensemble Pro Slave machine which doesn’t have Cubase installed but does use eLicenser software for licence protection. What confuses me is where the buck stops with eLicenser in terms of fixing the problem as Vienna and Steinberg separate entities.

The main issue for me at the moment is that I must start Cubase before Vienna ensemble software or I get licence dongle error. Often too the elicneser locks up and will not allow either program to start. Instead instances blindly sit in memory taking about 8mb and do nothing. The only way to then resolve this is a restart of the system which presumably resets the elicenser service.

This is what we get for using legitamite software! Seriously though a slicker solution to the issue needs to be found moving ahead. Particuarly now that hardware vendors are phasing out standard USB slots on computers.

Did you see my replies to your thread?
https://www.steinberg.net/forums/viewtopic.php?f=226&t=105757

@ManChicken: yep, we had a few issues with every major Win 10 update and updates followed, like Colin noted.
Issues vary from corrupt Soft-eLicenser, which generate rather harmless warnings, to corrupt eLC drivers.
Usually Maintenance solve the issue, otherwise installing and running Maintenance does.
I had a couple strange, more difficult cases.

Please, check the dongle on that Win 7 machine - if you still get “USBDeviceOS_Finish expected but received”, please get in touch with support.

Hi Fabio

I hadn’t picked up those replys to the thread no sorry. The advice I was referring to was a reply from someone else on an official Steinberg support ticket. The gist of the reply was to trash preferences. Other than that blame Vienna and contact their support instead. I’m confused as to who elicencer belongs to or where the buck stops, maybe you can enlighten me?

Regarding your other findings and USB 3 do you know of an elicencer version that has rectified the issue? I think I have latest installed but I have to make sure Cubase is started before Vienna ensemble pro 5 or it will not start until I shut down VEP 5

Yes, not everyone is aware of that problem. I received a very detailed report from another user and passed it over directly to QA without discussing it too much at Support, I should have. From a support perspective, his reply actually made sense, as we had a few reports exclusively from Vienna users, but surely he didn’t know it was reproduced already, sorry for the confusion.

Unfortunately, I just know that older dongles are more prone to this issue than the newer (shorter) ones, I didn’t test this personally, but I’m told it’s ‘progressively worse’ (Steinberg Keys and older ‘blue’ eLicensers being probably more affected). I’m not currently aware of an eLCC version which does not show the issue and is fully compatible with Win 10. But they’re looking into it - if the issue is with the eLCC, it won’t take too long before a new version is released. For the time being, to start Cubase before Vienna is the only work-around, I’m afraid. At least better than adding a USB2 bracket just for that (I can’t even be 100% sure that this would work on every system, as the problem was reproduced on one single system over here AFAIK).

Just had a few elicencer issues here. What I did not realise was that ‘performing maintenance task’ does not actually update the elicencer to the latest version’ this has to be done separately. It helped here to update to the latest version seperately.

I"m on latest versions of everything. Still having issues.