Suspend VST 3 plug-in processing cannot be disabled


There is an issue where the “Suspend VST 3 plug-in processing when no audio signals are received” option in Preferences cannot be disabled.
Even when the option is disabled, it still takes effect.

This can be tested with any plugin that is compatible, for example RoomWorks.
Just insert the plugin on a track.
As long as playback is Stopped, the ASIO Guard meter is low.
Now press Play and notice that the ASIO Guard meter increases.
Press Stop, and after a few seconds the ASIO Guard meter will drop again, just like when we bypass the plugin. This simple experiment is enough to prove the existence of the problem.

The expected behavior is that the enabled/disabled state should follow what we set in Preferences.

Note for Steinberg : If your plan is to leave this feature enabled permanently, just remove the option so it won’t confuse anyone anymore…

Thanks @TakashiWatanabe for pointing out the issue in some of your posts :wink:

Yes, that is true.
Although the cpu usage drop in the reverb plug-in can be from individual algorithm, we can see that the option seems to be broken and always enabled from behavior of other plug-ins, too.

This is serous because this is related to lots of dynamics plugins that misbehave. It used to work properly.

1 Like

I think you should test it with 3rd party plugins.
For example, send a short impulse into a reverb set it to 20 seconds, make sure Suspend VST 3 is ON, and no other audio besides the reverb.
You will see that the reverb will be cut :v:t6:

No that’s not how to test it, because it monitors the output, and not the input. If you put the reverb time to 20 seconds it will wait for the reverb to end before going into sleep mode.
The same applies for analog modeled plugins that generate noise. If you leave the noise on, the plugin will never go to sleep.

I told you by experience, you welcome to try with any of 3rd party reverbs :v:t6:

Do you know any 3rd party plugin that supports vst3 suspend function?

Besides, this was all working fine in C/N11 (v11 updates after the release of v12 are also affected.).

Plugin Alliance do support VST Suspend.

Which PA? ones by Brainworks?

Yes Brainworx, didn’t try with others (non-Brainworx) so I’m gonna do it.

The problem is I currently have no working version on my systems. I know N11.0.0.x was a properly working version. But N11.0.40.x perhaps updated after N12, is not. I have to install a working version to investigate further.
(because e.g. above RoomWorks case, that CPU saving may be written exclusively to the plugin. The CPU usage difference for this particular plugin won’t tell us if it’s the broken preference option or not. You need an older, properly working host for comparison.)

I could have taken any plugin as an example and you would still respond that this particular plugin has a specific CPU saving feature… RoomWorks doesn’t have such “exclusive” feature, I just took it because it has a notable impact on CPU compared to other lighter plugins and makes the test easier… Just try it with Chorus, Distortion, or Compressor, the behavior will be the same, as soon as there’s no signal on output the ASIO Guard meter will go down, same as with Brainworx and Elysia plugins, except the timer on those is longer, seems to be up to 15 seconds.
Example with RoomWorks :

VST Suspend

However I have noticed another problem with those plugins (BX and Elysia, but maybe other plugins are also concerned), is that they prevent subsequent plugins in the inserts rack (from any brand) from going into sleep mode, even if that plugin is bypassed. Although this specific issue is only related to these third-party plugins, you still have to take this into consideration when doing the tests.

PA suspend bug

You can’t be sure without looking at source code or, test the same in earlier version.

Earlier versions or not, these are facts, VST3 Suspend currently cannot be disabled, and the feature behaves the same with every Steinberg plugins that are compatible.

Also I have tried with third-party reverbs as @Idan_Bigel suggested, and as I expected, the VST Suspend feature seeks for the signal at the plugin output. If I set the reverb to 30 s, it will wait for the reverb to end once I press Stop. It does not cut the audio like that… Still I’m very curious about what plugin you used.

Yes, this is the bug I’ve found. But the reverb test alone does not tell you that unless you know the reverb code or check earlier versions for comparison. That’s all I’m saying.
If you uncheck the option in one of the earlier versions and if that changes the reverb’s behaviour, then you can confirm it.

I tested with Valhalla and Waves plugins (V13 and V12) maybe also fab-filter.
I made a short white noise send it to fix channel and exported the reverb only :v:t6:

@Louis_R I’ll dig into it in Cubase 12 as well, last time I checked it was on Cubase 11