Synthmaster 2 Problem in Cubase Pro 12.0.70

This follows on from posts in this thread where the issue is described.

Cubase 12.0.70 maintenance update.

Running Win11, Cubase Pro 12.0.70, i8700 cpu, asus 370-a mobo, nvme drives, 32gb ram. Asio-guard, cubase power scheme all checked. Steinberg UR44 audio interface. Using multi-processing. Running 96,000 x 64 bit. Latency 1024 samples. No real problems until I started using Synthmaster2. The audio meter flies randomly off the scale and Cubase becomes unusable because of dropouts. Changing a voice leads to a spike in audio performance, many of these going into the red. Changing sample rates, latency and so on have no real effect. It happens with the VST2 and 3 versions of this synth.
As suggested in another thread about all this I have tried disabling unused inputs. The only thing that seems to help is to turn off multi-processing. My mobo doesn’t seem to allow me to turn off hyper-threading. This seems to be specific to Synthmaster 2.

KVR pointed me towards another Cubase thread about windows power schemes. Whether I use the Steinberg power scheme or set my windows power scheme to high performance and disable hard drive and usb suspend power states. There is a sample project link below for anyone interested.

Synthmaster Two-03.cpr (269.1 KB)

1 Like

Just downloaded your project, no problem here. However it’s an almost empty project with just one instrument track, right?

Works fine here too, Win 11 Ryzen machine.

Can change presets and such like fine, no glitches and I left it on the high sample rate of the project, too and whatever my default buffer is (usually 256). And it’s showing 1-2% CPU usage.

Is synthmaster up to date, and are you running the VST3 version? I’m on v2.9.16.

I think I’ve been able to replicate the problem on my system

  • Ryzen 9 7900X,
  • builtin GPU,
  • 64GB DDR5 6000,
  • Cubase 12.0.70,
  • ASIO at 48kHz, 256 Samples
  • Synthmaster 2.9 x64 VST3

There are clearly visible ASIO performance meter spikes in the attached video screen capture (wait a while for the first). While they don’t always go into the red (the danger zone for audio artifacts), sometimes they do - even on my relatively new and well spec’d system – except for using the builtin modest GPU). Note: I disabled Synthmaster animations, just to ensure that wasn’t the culprit.

Animation

Didn’t catch a going into the red during the screen recording, but it happened a little later.


UPDATE (a few hours later): I tried quite a few potential workarounds that did not appear to make a difference on my system:

  • VST2 rather than VST3
  • use an instrument track with each of the following plugin chainers, and embed Synthmaster into the chainer.
    • PluginGuru Unify
    • Plogue Bidule
    • Native Instruments Komplete Kontrol

UPDATE 2 (even later):
The only (complicated, fiddly and not very satisfying) workaround I could get to work so far, was to use the standalone version of Synthmaster and let Cubase treat it like an external hardware synth. And then use loopMIDI and the audio loopback via my RME audio interface to send and receive audio and MIDI respectively.

1 Like

Didn’t think about checking the performance meter, I can replicate this also, it doesn’t hit the red for me unless I start flicking through presets. The peak meter just sits there and dances and hits 50% every second or so, I don’t get any glitches occur though.

Does this only occur in 12.0.70, then? Just tried Reaper and there’s no such spikes but it doesn’t have a peak meter like Cubase, only a real-time, and that doesn’t jump.

I can see how this can be aggrevated in a loaded up project running at 96k.

1 Like

Many thanks everyone for taking the time to check on this. It seems Nico and skijumptoes have replicated this problem. My system is older, an i8700. But it copes admirably with everything I throw at it - except this.

“However it’s an almost empty project with just one instrument track, right?”

Yes.

“Is synthmaster up to date, and are you running the VST3 version? I’m on v2.9.16.”

Yes and yes. Same and same.

" UPDATE 2 (even later):
The only (complicated, fiddly and not very satisfying) workaround I could get to work so far, was to use the standalone version of Synthmaster and let Cubase treat it like an external hardware synth. And then use loopMIDI and the audio loopback via my RME audio interface to send and receive audio and MIDI respectively."

Really didn’t think of that because Synthmaster2 works fine for me as a standalone too. But you’re right - it is fiddly.

"Does this only occur in 12.0.70, then? Just tried Reaper and there’s no such spikes but it doesn’t have a peak meter like Cubase, only a real-time, and that doesn’t jump.

I can see how this can be aggrevated in a loaded up project running at 96k."

I did try this in Cubase 11 and it seemed to be the same. It’s fine in Cakewalk too but I’m not sure about Cakewalk’s monitoring. And even with a 48 x 24 project it does the same.

I’ll report all this back to kvr and see what they make of it.

Thanks again guys.

Hello, I also had a problem on my system with the Synthmaster 2 plug-in in the Burak Yeter version. The plug-in worked horribly even when changing any sound or moving the plug-in window. The Peak indicator in Cubase was literally going crazy and lit up red all the time. It was the same as far as I remember with Synthmaster Player. When I went back to previous versions all problems disappeared. I currently use only Synthmaster One from KV331 and it works flawlessly.

1 Like

Hey Tony, exactly what I’ve been trying to describe. Synthmaster One is not a problem. It’s all to do with 2. I’m awaiting a reply from KVR.

In the meantime, having seen the amount of junk - unused plugins and the like - which have accumulated on my system I am in the middle of a complete clean windows 11 install. I suspect the Synthmaster 2 problem will be exactly the same but I’m going to go through all the usual checks as Cubase and Synthmaster are reinstalled. Updates to follow.

Okay, clean install done, all windows tweaks done, all Cubase tweaks done. Synthmaster 2 installed. Same old same old. Massive peaks hitting the red. Disable multi-processing does the trick. But still not very satisfactory.

1 Like

I guess, if desperate enough for actually using Synthmaster, one could try to go back to Version 2.9.14 (although that likely brings back some older bugs) - apparently the problem was introduced in 2.9.15 and not yet fixed in 2.9.16 - the developer posted download links to 2.9.14 at their official KVR support forum:

2 Likes

Thanks Nico, didn’t know that. I’ll roll back as the bugs then didn’t bother me.

Well, rolling back to 2.9.14 fixes that. Multiprocessing enabled and asioguard. No wild peaks and fluctuating performance meter. Everything stable. Once again thanks to everyone for their help and Nico you’re a star :sunglasses:

2 Likes

Hi Peter,
Do you receive a reply from KVR about this issue?
Kinds regards.
Hervé

No! However I did log it with them.

Interestingly after a couple of months of audio problems, not just with Synthmaster, everything seemed to improve after a couple of windows updates. I believe Steinberg posted about this a while back. And now the latest version of Synthmaster is not a problem. In fact I’m back to loading up to 20 soft synths, midi channels, audio, fx and the like without a problem on my intel i8700 (with nvme drives), nvidia 3060 gpu, 32mb ram.

It seems to have been beyond my control but just pleased everything is back to normal. It even got me looking at Reaper :smile:

Hi guys, this is Bulent, the developer himself. A couple of years ago, we received an email from Intel about a performance issue on Windows, which might be related to this issue:

“” Hi there, for a while Cubase has had an E-Core problem, for example Cubase tries to access the E-Cores before P-Cores creating massive spikes. We discovered with Steinberg by disabling the Steinberg Power Scheme and leaving Windows on high power setting the problem went away by 90%. However I discovered after the latest update of Synthmaster that it is also trying to access the E-Cores first and is causing the worst CPU spikes I have seen, the original solution does not work, I had to use Bitsum Lasso in Ultimate mode to get the CPU back to normality. Not sure if it is just a Cubase thing but all developers need to understand going forward all CPU’s will have E-Cores as well as P-Cores. Steinberg already contacted Intel on the issue last year and were told they will need a new API going forward etc. Anyway… thought I would pass this on before u get swamped with support requests from Alderlake owners,"

2 Likes

Hmm, not sure I fully understand but it’s interesting info. Synthmaster 2 had indeed reverted to creating large spikes. However following the latest Windows update while still a bit hungry on the performance meter it is now entirely usable again. Incidentally this is on a humble Core i7-8700. It’s even now rendering to audio without crashing Cubase.