Temporary "snap off" behaviour with Command key while selecting range, like Pro Tools does

Temporary “snap off” behaviour with Command key like Pro Tools does!
(it should be similar like if your just push Snap Off key) - if so you can have fine range selection in one click - cool feature!

Holding the Ctrl/Cmd key isn’t working for you ?

it works. But not the way you expect it. Because the first mouse click (with cmd/ctrl key) is still in grid and only second click is Snap off. It’s better to have the first click already snapped off

Drag the event. As soon as you press Ctrl/Cmd the snap will be disabled. If you release Cmd/Ctrl while still holding the left mouse button the snap will be switched back on.

I am sure you just have get used to the details of the workflow. The feature is already there.

1 Like

Got you. But what I’m saying is about selecting range, not about dragging events. Dragging events with cmd/ctrl is OK

I understand what you mean, the first mouse click will always snap to the grid, it seems there is no way to start freely without having to disable Snap. And even at high zoom levels it’s not possible. (although when moving the Cursor via the Ruler past a certain zoom level, snap is automatically disabled.)

It works the same as when dragging Events, but nevertheless this can look buggy, if you start holding Cmd/Ctrl before clicking, it will start selecting from where the last selection previously was.

Update : Actually it is possible to start freely when holding Shift/Maj + Ctrl/Cmd, but doing so will select all the tracks.

1 Like

Yes! You’re right. That’s why all I ask from Steinberg in this topic is to start freely when holding ctrl/cmd) there are no bugs with this, just a feature request

Hm. Here all seems to work. Is this what you’re after? Note that the config of your modifier keys in Preferences can potentially interfere.

Press, hold, release ctrl while dragging

Press and hold ctrl before dragging is not snapped

How you did that on a second video? I only have a first video scenario…

Simply pressed ctrl and held before pressing mouse button, as shown in the video.


This does not work for us, we cannot start a new selection like you do.
When holding Ctrl before clicking it will just extend the current selection :
(all default controls here)

range selection snap issue

@AlexanderPozdnyakoff what is your OS platform and version?

Mac Os, Big Sur. And what modifier keys in Preferences you talking about? I can’t find any similar to this

I didn’t have a specific one in mind, I mentioned it because it’s something I have seen.

Neither of you state the exact Cubase version. Please do. I’m on 12.0.51

@AlexanderPozdnyakoff You’re on Mac, so maybe there’s a Mac vs PC difference? (there shouldn’t be though)

Cubase 12.0.40 Pro

Hm. I can’t test in that version. I presume you can’t update to 12.0.51?


I can’t update right now. But… there is hope that the solution is so close to us. Because your second video shows just what I’m looking for

There is one possibly salient thing I observed - this desired behavior only happens when the mouse is over a area with tracks populated.

And the behavior in 12.0.40 is the same as in 12.0.51. (I remembered how to have multiple versions installed on Windows. )

I have a feeling this accounts for the difference we are seeing.

Well… still no luck. Don’t know why

I think I got it, The tool modifier that is conflicting is the Range Tool>Exclude Row.

Mine are in the image below. When I tried ctrl for Exclude row I could exactly reproduce what you guys are saying.

I probably changed it long ago when I first noticed…