Temporary "snap off" behaviour with Command key while selecting range, like Pro Tools does

Hallelujah! You’re the best, Steve! Thank you. It finally worked! Now it works as expected! I couldn’t presume that Exclude Row is about that

1 Like

Yes it was it !
Although there’s another problem if you change it to Ctrl+Alt (as shown on your screenshot), since this latter modifier is also tied for Slip Event Content by default, so we must change this one too.

Actually I think there’s some issues with how the modifiers work with the different tools.
Why do modifiers that are specific to a tool also works/interferes with tools that don’t use this modifier ?

That’s the issue, modifiers from Select Tool interfere with Range Tool, and I think they should not, that’s the reason why they all have their own modifiers list to start with.

@AlexanderPozdnyakoff No, it doesn’t make sense! Probably Exclude Row depends on some other thing to be active (behind the scenes). Modifiers have been an obscure thing in Cubase for a while – hopefully we will see some evolution in this area soon.

@Louis_R Not really, because that’s done with the Select tool, and this is the Range tool. Also, I checked this before posting, as I generally do, so as not to steer anyone wrong… Yes. Change one of them.

Please. I beg you. Post a simple repro sequence so that can be confirmed. in a separate topic.

Also, note that they allow conflicting modifiers to exist to give users maximum flexibility in config. It’s a trade-off. Not a bug.

Because of this :


But when Combine Selection Tools is not active it should not interfere.
Whatever, the Combined mode only splits the tracks in two horizontal rows, when you move the pointer over the top half part it is the Range tool, and the bottom part is the Selection Tool, so it should not interfere either.
As far as I know the Alt modifier doesn’t interfere with the various Tools, although many of them actually use the Alt key. This would cause quite a mess.

I’ll do this.

Slip event content is a great option. So if I got you right, guys, the idea is “slip event content” with cmd-opt , “temporary snap off” with cmd/ctrl pressed like on second Steve’s video, and also “exclude row option” with cmd/ctrl pressed while excluding rows from selection - all without interfere, right?

To verify it works for you, the best thing to do is test it on your machine. This avoids any error on the part of the remote tester.

Yeah that’s it.
I’ve created another topic to describe the conflict a bit clearer because I was asked to do so :