The dreaded startup crash

I just noticed that everytime WL crashes it doesn write to the event log, so maybe this will be usefull for Steinberg…

Everytime I start up WL 7.01 (this didn’t happen with the prior version) on win7 64 bit and I open a new wav file this WL crashes. When I open it again and then open the same file it works. I think this has to do with the *.mrk file creation
If I open a file that already has the *.mrk there’s no problem.
I have to kill the process in task manager and then restart.

here is the entry in the even log:

Faulting application name: WaveLab 7.exe, version: 7.0.1.522, time stamp: 0x4ce9a3f2
Faulting module name: QtGui4.dll, version: 4.7.1.0, time stamp: 0x4cdfb985
Exception code: 0xc0000005
Fault offset: 0x002c8c42
Faulting process id: 0xfb0
Faulting application start time: 0x01cbfbf70dfd1e39
Faulting application path: C:\Program Files (x86)\Steinberg\WaveLab 7\WaveLab 7.exe
Faulting module path: C:\Program Files (x86)\Steinberg\WaveLab 7\QtGui4.dll
Report Id: 74828ebf-67ea-11e0-809d-0018f358167f

just a bump for this - is this still happening ? did you find a fix ?

sorry haven’t been on here in a while

It still happens, I was hoping this would be fixed with the latest version 7.11 ( I think) but no dice.

I kinda started living with this…open wavelab, open wav file…wavlab crashes, kill wavelab in task manager, restart, re-open file…all works…

Please fix this

If only I could reproduce…

mrtomcat: I don’t understand the reference to the .mrk file creation. I thought the .mrk file was only created when you create a Mark, but it doesn’t sound like that’s what you’re doing.

I’m fairly sure it’s related to my problem:

http://www.steinberg.net/forum/viewtopic.php?f=47&t=7748

PG was very helpful and said he was fairly sure there was a bug somewhere - but he needed me to run some debug code on the PC which I wasn’t in a position to do. Recent WL updates haven’t fixed it but I’m still pretty much running v6 so not to concerned. Hoping the eventual move to 64bit will fix it.

Have you tried different locations for the peak file creation? Like c:\temp or make a new folder called gpks, something like that? (Options/AudioFileEditingPreferences/Create In Independent Folder - on or off). Unless I missed it, I don’t see any mention of that in the previous posts.

Yes. Same problem. Went through a few things with PG but couldn’t pin it down.

It does create the file before it crashes, that’s why it doesn’t crash the next time around because the file is already there.
it’s definetely related to the .mrk file that gets created first time a new wav file is being opened

NOTE once again this was NOT an issue with the initial WL7 release it started with the first patch.

I just played around with different folder locations, same results.
Here is the event viewer dump on the latest wavelab build:

Faulting application name: WaveLab 7.exe, version: 7.1.1.550, time stamp: 0x4df8df87
Faulting module name: QtGui4.dll, version: 4.7.2.0, time stamp: 0x4de66e8f
Exception code: 0xc0000005
Fault offset: 0x0016f45c
Faulting process id: 0x11f8
Faulting application start time: 0x01cc526ba9b07ef4
Faulting application path: C:\Program Files (x86)\Steinberg\WaveLab 7\WaveLab 7.exe
Faulting module path: C:\Program Files (x86)\Steinberg\WaveLab 7\QtGui4.dll
Report Id: 1f36f1e8-be5f-11e0-ab3b-0018f358167f

Do you mean .mrk or .gpk ?

*.mrk

If I open a wav without the *.mrk ,wavelab crashes but creates the file.

Next time I open the wav file in wavelab all works fine

If I delete the mrk file and try to open the wav file again, wavelab crashes after creating the mrk again…

then it works again…it’s a twisted cycle :slight_smile:

Hmm, WaveLab (may) create .gpk files (peak file) when opening files, but never .mrk files (marker files).

What is the audio file extension?

these are standard broadcast wav files coming out of Nuendo.

And the moment I open a wav file in wavlab it creates a .mrk file

Is there maybe a setting that would disable that? I see a Markers tab in my workspace

ok, now ever since I started trying to change the location of the temp files it is no longer creating a mrk file (I reset everything the way I had it before…or so I thought…) and now wavelab crashes everytime I open a wav file without a marker and since it’s no longer creating one every new wav file is unuseble. SHOOT!

Back to wavlab 6 again. PLEASE help me figure this out, I finally got used to wavelab 7

I can’t see a situation where WaveLab creates a .mrk file when opening a file.
If you are sure and have such a file, please send it to me…

What I want to know is - what exactly is this file. A quicktime GUI or what?

VP

Nothing to do with QuickTime. Google is your friend here !

Yeah…okay…here’s one of the first things found - on Google…

“The file QtGui4.dll is a legitimate component of Adobe Photoshop Elements. The file size is 5246976 with the MD5 signature of 5F46BBD36877300007A8CA46F9DEA3B3. Adobe Photoshop Elements is the consumer version of the Adobe Photoshop raster image editing product. It includes most of the features of the professional version. But it has fewer options. Besides they are simpler. The program enables users to create, edit, arrange and share images,…”

And a further investigation on the Adobe forms - does in fact point to this as a Quicktime component…

http://forums.adobe.com/thread/766273

What exactly does this file have to do with Wavelab 7?

VP

Bruce, with the greatest of respect, you are barking up the wrong tree

http://qt.nokia.com/

It’s fairly irrelevant to us, as end users, what the exact dll is doing as we don’t have access to the source - do you have this a problem with gpk/mrk file creation causing a crash ? or is this just a curious enquiry ?

I did some more experimenting last night…

For whatever reasons the mrk files are no longer being created when I first open a file, it’s down to the .gpk files

Things are behaving a bit different now ever since I did some settings changes even though I reverted back …

Anyway, here’s what’s happening now (maybe that was the problem all along and the mrk was just a side effect):

I open a wav file freshly exported out of Nuendo, Wavelab opens the file and on the top view of the wav file there is an error stating: “Cannot create Peak File”. If I now click anywhere within wavelab it crashes.
I have to kill the process, restart and open the file again and all works fine.
–before I restarted the process I checked in the directory and the peak file was created even though there was an error message–

I changed the path of the peak file creation with the same results.

Good news is that I can use wl7 again but I still would like to see a fix for the nasty crash