The New MIDI Remote is

Letting the messages through even though they are converted into parameter changes is very counter intuitive. You easily get in conflict between written parameter automation and recorded CC lanes.

1 Like

…yes, I only debug in this way.

1 Like

When I send a sysed-id request with F0 7E 7F 06 01 F7 this is the reply I have:
F0 7E 7F 06 02 00 20 6B 02 00 05 58 3E 0A 01 01 F7
So the correct value is 05 58 instead of 05 48 for the model
I changed the script with .expectSysexIdentityResponse(‘00206B’, ‘0200’, ‘0558’) and now it works.
Thanks again.


^This really is critical, and agree. There needs to be the “selected track” options as before, or provide us with the options to page through the layers of quick controls and we can define the mappings using the remote editor.


Lordy, just a typo. Thanks for finding!
Will be part of the next maintenance update then.


Will there be any chance of being able to map to quick control layer changes? I did raise a post about this here:-

1 Like

I’ve been assigning my controllers with this section - but there are still a lot of missing parameters. No per-channel control over Channel Strip processors or Inserts, for instance. I’m going to have to revert to Generic Remote for now. I love the way Midi Remote works - so I hope more parameters will be included soon.


Yup, that did the trick. I removed the controls from the gui and the MIDI is passed directly through from the controller now! THX!!

I’m new to Cubase and pretty impressed with 12 so far. Is there a place where people can upload or link the custom scripts they’ve created and people like me who are useless with scripting can lurk until a script for our hardware has been shared by somebody else? I’m using a PreSonus Faderport Single, and not all of the buttons are recognized by the Midi Remote editor. I’ll reach out to PreSonus, but I won’t hold my breath.

How to access QC controls on Massive X or Omnisphere/Trillian? There’s no QC button (and some other buttons are missing).
Here’s Padshop
and Trillian

BTW, is there a keyboard shortcut to open the QC controls on a VST?

1 Like

I’ve also been poking around with this new tool. It is amazing! It’s done right and it makes sense right from the , and with a minimum of effort we’re up and running, it’s intuitive and easy to navigate … but what good would that be if it isn’t very powerful. It’s not very powerful. It’s EXTREMELY powerful and the best of all, it’s MIDI Remote 1.0.0 …
This looks sooo good now and for the future!
s l o w c l a p !!!

Yeah, a lot of the NI plugins do not show the QC button etc. I think it’s their slightly odd non-conformist way of programming their VST plugs. Not sure if anyone at Steinberg can suggest a workaround?! The QC controls are actually doing something, just that we cannot reassign them to our own taste…


Maybe this is not a Steinberg issue, but in the Spectrasonic plugins these buttons are “hidden” :wink:
This is introduced in C11. Kontakt 6 btw., shows the buttons.
Will be nice if Steinberg can invest here and give us a result, if Steinberg or the vendors must fix this.

1 Like

What I’d really like to know is whether or not the javascript API could let me do something as deep as what the SSL UC1 does - where it can detect ALL instances of the SSL Native v2 channel strip and bus compressor.

What I always struggle with is with different projects having different FX channels and different plugins on different inserts, the Generic Remote has always struggled to allow a nice way of controlling a specific plugin a specifc way reliably - with GR you are either forced due to track offsets to have a template with the same plugs on the same inserts (non-starter) or (as most folks do) be forced to use “Selected Track”. Which is better, but then you need to ensure you have the selected track etc.

Maybe what I’m hoping for - at some point - is way too ambitious, but my hope was the API would allow me to map a certain page of my Faderfox EC4 to for example Valhalla Delay - and then cycle through all instances of Valhalla Delay - or Vintage Verb or whatever.

So far it doesn’t look like this is remotely feasible with the API as it currently stands - which is a shame, as the SSL UC1 impl is AWESOME, and wI’d really like to use my EC4 in a similar fashion, but as it stands that’s going to be a long way off.

I think there is probably something at the core of how Cubase deals with inserts / tracks that make this difficult - but the SSL UC1 proves that it IS possible. I was just hoping that opening up the API to Javascript would have allowed coders like myself to do cool stuff like it.

NB - I ooked through the API documentation and it was unclear to me how inserts can be automated - or even bound, but I appreciated it’s early days yet

In another thread it was pointed out that TQCs can be assigned to CCs as well as other messages:

1 Like

I would like to know too

will mackie be once also integreated there? And will there be an option to divide incomming midi from the midi cubase is sending back, for example i use relative 14 bit mode to send it to cubase but the controller needs absolut data to set leds or faders or whatever according to the real value set in cubase.


P.S. and the faders or knobs are jumpy if i use my maschine or whatever as midi controller, this is also a problem of the midi sended back to the midi controller i guess, but this is not new, the only controller i know where it worked really good with some knowlege was the bcr200 and bcf 2000 but this was because of the capabillities of this controller with BCEdit

I’m not going to bother with this for my Oxygen Pro 49.

There is a mode button that changes the function of the buttons under the faders (Record, Select, Mute, Solo or MIDI (Device Function)). Even if I were able to map this all, it would be a royal PITA to set it up. It’s actually far easier to map this for Cubase using Mackie Control and the M-Audio Preset Editor.

I did test with a script for the Faders and Knobs and Inconsistent Pick-up behavior in Cubase 12 still renders them unusable, even though they pick-up properly in Studio One 5 - so, it’s definitely a Cubase issue, not a FW/Hardware issue.

I’ve never been able to get pick-up mode to function consistently in Cubase (10.5, 11 or 12), and I think I’ve given up :stuck_out_tongue:

I want to replace this controller with a Keystation MK3 of GX49 to recover a bit of space.

EDIT: Also, since the Cubase 12 update, I can no longer Bank </> with my controller, so the faders and knobs are officially dead.

Does Steinberg plan to support KeyLab MKII? They’ve already got KeyLab Essentials and MiniLab presets, but nothing for KeyLab proper.

Maschine in MIDI mode? Should work. I don’t see why not. I use it as a MIDI controller sometimes, usually with Ableton though, but as long as it’s set up properly as a MIDI input device it should work.