The New MIDI Remote is

Family issues haha

Why a decoupling layer at all?

Lua would have been preferable if performance is the concern, but if you look at Logic, which also uses JavaScript, where is the decoupling layer there?

Something doesn’t make sense here. We are not working with all of the information. It isn’t clear what Steinberg is trying to do when they seem to intentionally set limitations. It can’t possibly be a lack of skill. It isn’t a lack of understanding what they are competing with. So there has to be some reason. I just want to understand what that is.

It is, I converted my generic remote with transport controls. The only issue is that it is a key command, so without writing a script and just using the UI, the result will be that there is no feedback to the device for lighting the button.

But then there wasn’t in the Generic Remote either.

Also be aware that the Track Controls such as monitor, mute, solo, record, write, read. Any of the buttons on a channel strip for the selected track will NOT work for MIDI tracks. For those you will also have to use the “edit” key commands, and therefore also have no feedback to the button on the device.

Was that intended to have more than one page?
When I move the JSON from one computer to another it doesn’t seem to bring along more than the UI setup and the bindings for the default page.

… but in the Generic Remote I could make a different output mapping from the input mapping, so I could get the LED to behave properly.

Very cool. I tried that and it didn’t work no mater which way I configured the device or the GR. So, until they fix this, use the GR the same way, only just for the output? Or write a JavaScript .

Interestingly enough @Jochen_Trappe implied in another thread, that it should be possible to make a StartStop, …

EDIT / Correction: And YES it works!!

p.s. This was the old way in the Generic Remote:

In the Generic Remote, I’ve done the following workaround, and it seems to work great:

Of course the first thing I did was to map Transport/Start to see if it worked. It did not!

sigh All of this shouldn’t be this difficult with so many workarounds to do what would be super simple otherwise. I mean, is the audio engine full of this sort of thing?

I was so thrilled with this release at first, but the scripting is a bit of a let down. This should be easy. The Audio part should be hard. But if the easy part is sort of phoned in…

1 Like

Ahh. Sorry. It wasn’t well structured. I made an extra page but removed the bindings on it.

Sloppy of me. I’d like to make a more generally useful script with several pages for different purposes an upload it here. Maybe tonight.

Thank you :wink:
I’ve reported this to Spectrasonics.

The reason I am asking is that I took the JSON from my laptop and put it on the studio computer and only got the first page.

Then I went to

C:\Users\<user>\Documents\Steinberg\Cubase\MIDI Remote\User Settings

And there was one there with a GUID in it’s name and not formatted. When I moved this one over it worked, as it was not missing the other pages.

I just got it to work!

My options are “Momentary”, “Toggle”, and “Trigger” on the device I am using. (Launchpad Mini mk3).
Momentary would be the one I would expect to work.

Ill try it again and see if its. EBKAC

1 Like

Please use the provided Export/Import-Script functionality in the MIDI Remote Manager. Only that way your mappings will be included.


Hmm, i need to watch this when i get home as my NI. M32 didnt work at all. Only notes were recognised.

I couldn’t try it again because when I went back to try it, none of my already created scripts would connect.

See: Midi Remote Problems Can't Load UI Created Script

I’m not having a positive experience at this point. So Sorry for the cheeky attitude.

Edit: I got the same MRs to work on the laptop by plugging the devices in to the exact same port, and rebooting. They still will not transfer. However, I was able to try Toggle mode with the Transport Start button, and that does not work. You have to use the Start/Stop key Command, and Momentary.

you have to set the midi mode “shift” + “plug-in”

has anyone managed to use the Quick Controls (selected Track) with standard MIDI tracks? It works with Audio and Instrument channels for me but not for MIDI tracks. Don’t know why.

It doesn’t work for me no, I can assign knobs to things, but when I turn them, the only change the value of whatever I have assigned it to by a maximum of 1%

1 Like

do you mean at the quick control panel at the inspector of a midi channel? I confirm, it doesn’t work for me neither. I can’t e.g. change the volume with QC1.

1 Like