The New MIDI Remote is

yes, is fairly straight forward, watch the video, it took me a few goes to get it, persevere you’ll get there. The issue is there are only parameters for 8 channels in the mixer. I have 32 channels i want to assign, anyone have any clues how to assign more than 8 volumes, pan etc…

I’ve got the Arturia Keylab Essential 88 and Cubase does not detect it
I’ve found this error message in the Script Console.
Any idea ?

Good tip, thx! I’ll give that a try. I did draw the controls on the gui so I could have a visual reference, but your approach makes sense. Thx, again!

1 Like

Does anybody here already managed to get a custom JavaScript midi remote script loaded?

I used the existing script for the Arturia Essential 88 as a building base for an Arturia Keylab mkII 88 script. But the MIDI remote console simply does not load the custom JS file. All existing files in the “Public” folder are loaded, but the custom one in the “Local” folder (the manual says that you should always use the “Local” folder for development) simply is not loaded.

The MIDI remote developer console shows no error so there is no hint why the script is not available.

I also create a really simple JS script based on one of the example scripts provided - with the same result. The script is not loaded.

Is there anybody here who was successful in creating a custom JS script? (not the JSON-ones from the visual MIDI control builder)?


Not had a go yet, but I think it’s important that you match the MIDI ports up so it gets detected.

There doesn’t seem a great deal of flexibility in being able to pick ports for different scripts right now - so you need that detection to work or it won’t load the script I imagine.

I think that in my case it has nothing to do with the ports as all existing scripts (i.e. Korg etc.) are loaded according to the developer console - even if no hardware is connected.

I have created some little control over my beatstep, what is important are the names of the midi ports.

I want to try using control to Fabfilter pro Q but there are only 8 quick controls. How can I assign buttons to more than 8 controls?


Are there plans to add CMC series factory scripts?


i got my nano kontrol working fine… cubase has script for it… just need to dig a little to find it

You probably have to copy the “keylab_essential_common.js” file from “Public/arturia” to “Local/arturia”. I believe it’s just missing. You unfortunately picked one of the scripts that are NOT the simplest here :wink:

1 Like

Is the MIDI Remote capable of outputting data on its own, by mouse clicking buttons/controls?

For example, could I assign a bunch of buttons to trigger different PLE scripts by mouse clicking the buttons?

btw, fantastic work.

Look forward to checking this feature out but am fairly new to this whole part of DAW work. Would be good if cubase did a deep dive tutorial in an “explain it like I’m 5” way for newbies to get up to speed.

Also bodes well for an updated CC121 at some point in future that can display paramter names on LED screens beneath each control knob and update as you change channels…


Not exactly. You would have to use something like TouchOSC together with MIDI Remote for your mouse-click approach.

SB need to put a layer control on those quick controls. You can do it with VSTi’s already by opening the VSTi remote racks on the right and change page, I made a request here:-

If they put that in, I don’t know if it would work for inserts too, but it’s certainly something that we need to have as the quick controls are picked up from the first page of each default remote map. And within those remote maps are multiple pages.

Did you need to look for it? I have a MacBook Pro that saw the NanoKontrol2 immediately automatically, but my MacPro doesn’t see it. The folder with .js files is present in the MIDI Remote folder inside the app, but I cannot open the script (if that is what the .js file is) as it’s greyed out. In fact it’s not possible to navigate to the app folder so I copied out to the desktop top try manually loading but still it’s greyed out when I navigate to that folder from the “import script” page.
As the MacBook sees the Korg immediately there must be something odd going on with the MacPro, I’ve tried re-installing C12 but still no go. Anyone have any ideas? Don’t want to flood support at this time as I’m sure there are far more important bugs they’re dealing with!

I guess this feature is still a growing baby and I expect more to come in following patches.
The whole variety of settings possible (like f.e. TouchOSC) will come for sure.
Give the developers time!
For now it’s already a good step in the right direction

1 Like

Is the youth not capable of reading manuals anymore?


And you have been reading manuals back then? :wink:


Any ideas on how to split a knob range for use with key commands in the new MIDI Remote? (except for using the legacy Generic Remote?)