Time Warp and Track Toggle Bug

Hi all,

I tried posting this to ‘issues’ but the post didn’t show up. I’ll try here.

I often write free-hand to picture without click (I hate playing to click and do it poorly). Then I generally use the timewarp tool in the project window and line up beats so that I get a sense of the tempo. Usually, when I select a bar and move it over, the midi/audio tracks switch from Musical to Linear time base and when I let go of the bar they switch back to musical. After I’ve made my rough adjustments this way, I open the tempo track and even it out taking out the most egregious tempo shifts so that I have a relatively stable tempo for my cue.

However, often times I find that the tracks did not switch back from Linear to Musical and thus, after I edit my tempo map, all my midi is completely not at the right beats. What’s frustrating is that I’m not sure what causes the bug. Whether it happens if I edit tempo track or whether its a bug in the time warp feature.

Further making this completely frustrating is the fact that, if I do the time warp in the project window and the tracks don’t toggle back to Musical EVERY SINGLE TRACK IS THEN IN LINEAR MODE. Cubase doesn’t have a ‘toggle time mode’ that affects multiple channels at once, so I’m forced to toggle each track individually (150-200 tracks)…Its very frustrating.

If there are any ways around this bug I’d really appreciate it.

Thanks
F

My workflow is exactly like you describe yours as in the first paragraph, that is a bummer to read.

As far as multiple tracks toggling back and forth between Musical Timebase and Linear Timebase, maybe 19:10 in this video will help: https://www.youtube.com/watch?v=baH-A2bxAvA

I’m probably installing 8.5.10 next weekend, assuming I can do the trial (I’m not sure if the trial is just for 8.0, or 8.10), I’ll check it out.

Calling this a bug does the word ‘bug’ a disservice.

FYI, This was already added a while ago. (I also replied in a different post of feeserface’s. )

I’m not sure of your meaning here, S.I.C. … can you clarify please? Are you confirming that this is a bug as he describes?




Similarly here :frowning: . I thought maybe you meant it was added to the bug list but I couldn’t find it now when I just looked. Is there another place bugs are added, or did I just miss it?

Thanks!


PS To OP, feeserface - if you do your Timewarp in the editor, then check back in the project page - have the tracks been switched back to musical mode like they should be, or are they all in linear mode (like the way you describe when it is done from the project page)?

Steve,

The bug is that tracks sometimes don’t toggle back to musical mode after warp editing.

The lack of multi track linear vs musical toggles (at least in 8.0.35) is an annoyance that makes the bug unbearable.

All the best
Feeser

Also, to be honest, the name of the problem concerns me much less than the solution to it. If its somehow user error on my part, I’m more interested in solving the issue than I am in what it’s called. I outlined exactly what I do. From use to use I don’t change this procedure and yet intermittently the tracks don’t go back to musical mode as they should.

Most times they do toggle back. But most times they toggle back in the project window too.

However, when I open an editor with multiple midi tracks and the same does are its even more maddening than in the project window, as the only tracks that stay in linear are the ones I just edited while the others are in musical. I then have to find all the linear tracks and toggle them back to musical.

Like I said, if it’s somehow user error I’ll be glad to admit it. However, I use this process almost daily and the ‘bug’ seems to happen at random. Which makes work flow very touch and go.

Alexis, it seems you and I have discussed this issue before and I’ve still not found a solution. For a while, I just work around it, but in a crunch it really is frustrating.

Here is our old discussion:
https://www.steinberg.net/forums/viewtopic.php?f=146&t=25326

The thing is, I’m pretty sure that it’s not user error and here’s why:

As of now my version of Cubase has no easy way to toggle the time base of multiple tracks. They toggle to linear mode when using the warp editor and toggle back to musical when the mouse is led up from a warp edit.

However sometimes after editing with the warp tool those same multiple tracks do not toggle back to musical mode.

F

Okay, now I finally understand the problem, :blush: and I actually could reproduce it after a few minutes of using the Warp tool, but only once- looks to be intermittent…

I was able to undo back to the point where the the tracks got stuck in linear time. The tracks went back to musical timebase.

Another thing you can do for when this happens is create a Project Logical Editor preset:

Media Type is <MIDI>
Track Operation <Time Domain> <Musical>

Here’s the repro for anyone who would like to try.

Create several midi tracks
Open them in the Key Editor (set up the windows so you can see the project window track list, and watch the Musical Timebase icons.)
Put some notes in each track
Switch to Warp tool (regular, not ‘musical events follow’)
Move the grid with the warp tool
after a bunch of moves the tracks got stuck in Time Linear Timebase
(I continued moving the grid for a few more moves, then I hit undo a few times and was able to get back to the step before the time domain got stuck)

I imagine others have seen this, so if you have, and are reading this, if you can find a repro that works every time it would be helpful.

Reported: https://www.steinberg.net/forums/viewtopic.php?f=230&t=92960

Steve,

Was the PLE “time domain” setting only added for 8.5?

Yes. That’s what I meant when I said “it was added…” Sorry- I was not paying close enough attention when I first read your post.

I will make sure this gets into the official ‘bugbase’, and I’ll update these threads when I have confirmation they received it.

I’ll update to 8.5 for the PLE but hope that bug gets taken care of. Warp is invaluable to me and having insecurity as to whether the midi will stay on beats makes working just that much more difficult.

Thanks.

F

Hopefully the PLE preset will make this less of an issue for you.

Hi,
I couldnt repro.
Could anybody send a moving gif or a project that shows the problem?

Gr,
JHP

Here you go.
warp tool time domain issue undo.zip (15.6 KB)
warp-time domain prob-undoing resets state.gif
warp tool tim domain issue.gif

Hi Steve,
Your gifs and the project is alot of help.
Thanks!

Strangely enough I still cant repro but I will continue to investigate.

If anybody finds a working repro please let us know.

Gr,
JHP

Thanks Jan.

It is weird, in the three times I tried this morning, once I could not repro, once it happened on the second warp tool move, third it took a couple solid minutes of warp tool moves. It does appear midi (note) data is needed on the tracks to get a reproduction…

I had it happen twice yesterday during extensive time editing. Had to undo all the way back a bunch of steps. I think it may have something to do with editing the tempo track while warping. Because most of the times it happens to me I’m doing just that. The cursor changes to the arrow in the tempo track but the warp seems to be still open in either the project or edit window.

[edit] just watched the motion gift that Steve sent and I’m dead wrong. Must be the warp editor.

Maybe, but here only the project and midi editor was open.

Just happened again. This time I used the history to undo to the point at which it stopped catching the toggle. Once at that point I remade my edits and the warp worked correctly. So that’s kinda a work around. Because the problem is intermittent, chances are it wont happen on the same edit twice. This is only a workaround if you notice the issue before making too many edits.