Timing sync between MIDI notes and synth audio

Hi,

I’m getting a really weird sync problem between notes recorded in a part and the audible playback of the notes from the synth (in this case Retrologue, but I tried with other VSTi and its the same). If I adjust the offset for the part about -100ms its seems to sync up better, but that shifts the notes so some get truncated and others dont start on time.

I turn the metronome on and it obviously is in time with the recorded notes and the underlying grid (visually that is). But the notes sound far off the beat of the metronome.

I checked my latency which is at 22ms with a 512 buffer, and 6.6ms with a 64 buffer. ASIO guard latency 26ms. Changing these settings made no difference either way to the sync problem. In anycase I thought latency was only an issue with live playing and not necessarily recorded notes?

This is the first time I have encountered this problem and its got me stumped. Really hard to record guitar along to this.

Thanks

Heres a screen grab of the midi editor window showing the midi notes ‘off’ the grid by about a 16th note. I had to offset these notes using the midi track delay to get them to sound in time with the beat

Why?

Have you tried recording your midi tracks with “Constrain Delay Compensation” enabled?

No I have not Nico. What would that do? Not sure how that would affect my situation.

I generally input my notes by hand, I rarely record live. I’m a guitarist by nature, so when it comes to producing I’m more of a composer than a keyboardist.

thanks

just trying to clarify what you are saying (cos I’m a bit dim !)

putting a note in manually exactly on beat 1 plays out of time with the metronome ?

a few questions.

Is it just this project ?
Any plugins or midi processing on the track ?
is it just this synth ?

So if I understand it right, your screen capture shows where the Retrologue notes have to start to line up with the Cubase metronome click?

Maybe try the following:

Create a totally empty Cubase project. Then add just 1 instrument track with Retrologue as the plugin instrument. Load a nice snappy percussive sound into Retrologue (maybe something like Short Cross Perc). Then draw some midi notes starting right on the beat and maybe quarter notes.
Then activate the Cubase metronome click (with the default sound).

Now, when you play that track back with the metronome click does it seem in sync or not?
If it sounds in sync in this experiment, then it would seem to be something specific to your project setup (or all of the midi tracks in the project).

If it sounds out of sync on this experiment, then I’m guessing it’s likely something in your general setup or overall Cubase preferences.