Touch automation issue with Mackie Control MCU pro

Hi everyone, I use Cubase 9.5.30 with a Mackie control MCU pro and 2 XT pro extenders (latest firmware 4.0.3)
I have a problem with touch automation mode : when I touch a fader, it starts writing automation correctly because the fader are touch sensitive. But if I stop moving the fader for a second or two, the automation stops writing even if I keep my finger on the fader and the parameter goes back to the previous value. When I move the fader, it starts writing again. Normally, it should write as long as I keep my finger on the fader even if I don’t move.
As a result, if I want to overwrite preexisting automation data in touch mode, I have to keep making little finger moves all the time so it keeps on writing. If I stop moving my finger, it stops writing after a second or two and the value changes to the previous one.
Is it a known issue with mackie protocol in 9.5?
Is it a hardware MCU problem?
If someone also has a MCU pro, can you test touch mode and see if you have the sale problem with yours?
Thank you very much.

Hi and welcome,

Make sure your finger is put to the fader really from the top, and you really send the “touch” event (you can test, if the proper MIDI message has been sent, there is a dedicated MIDI message for the touch/release fader). Do you use Global Automation Mode: Touch?

So you lose your touch?
I have a old mcu pro, but havent used it in 7 years. So my memory might be a bit of a blure.
But I think I never run in to issues with loosing touch, while resting my finger on the fader.

Now I use generic remote with my hw console, wich works fine.

Try and put one finger on a screw on the mcu chassis, while you use the fader. This will improve the static, so if it is a issue with the touch sensitivity, you will quickly get that confirmed.

Luckly there are 3 modes of automation in cubase pro. So while troubleshooting the issue, you can hit F6 or you can find a menu on the project window toolbar, by default it is set to touch. If you cant see it, you can open toolbar setup and ad automation mode.

Now you can select between 3 modes,
-touch, wich you probly are using.
-Auto latch, by your discription this is the one you want to use.
-Cross over, for touch ups.

You can read about the modes and all in the manual. I swap between them depending on the task.

Thank you.
I think I touch the faders correctly.
How can I see if the touch/release MIDI message has been sent?
Because after a few tests, I think the MCU has a “touch-sensitive” problem.
At first, I thought it worked because when I was touching a fader, the channel was selected but then I realized that even when I touch it slightly, the value of the parameter (volume) changes a bit so the channel is selected, but not because of the touch.
So if I can see wether touch/release MIDI messages are sent, I will have the diagnosis.
How do I do that? In the automation lane? In another program?
Thank you.


Just check incoming MIDI messages. Use MIDI Monitor in Cubase or any other MIDI Monitor application. Fader moves are Pitch Bend messages in different MIDI Channels (1-9). Touch/Release faders are MIDI Notes, if I remember right.

OK. So I chose my MCU as the MIDI input and I recorded a MIDI track.
When I touch the faders, I write a MIDI Note (G#6 for the first fader, A6 for the second and so forth) with a velocity data of 127.
When I move the fader, I write pitchbend data.
Is this normal behaviour?
Thank you.

OK so the touch sensitive function seem to work correctly so I still don’t understand why in touch mode, when I keep my finger on the fader, it stops writing automation data if I don’t move…

Yes, the behavior is correct. There should be another MIDI message when release the Fader. Probably G#6 Velocity 0.

What Automation nice do you use? Touch or Latch?

The problem is only with touch automation.
When I use latch, I have no issue because it keeps on writing until I hit stop.
With touch mode, it should be keeping on writing until I release the fader…
But it stops automatically writing if I don’t move the fader after around 1.5 second so the value on the screen goes back to the previously recorded one although I still have my finger on the fader.

The automation track will light up red, as long as it is reciving data. So you can see on the automation track when the mcu stops transmitting.

Might be a setting on the mcu that is stopping the transmitting if movement is idle for a period.

Just use the auto latch mode. It will give you the result you are looking for. But I do understand that it is a bit frustrating.

Only thing to know about Touch sensitive faders is that they work by using a electromagnetic field. Your touch brakes the field, so the fader starts transmitting. If the field is to weak. You will get issues with respons.

Wich leaves 2 options. Increas the field by running something electrical like a powercord near the faders, so it will increas the field.
Or you can improve your ground by using one hand on the chassis (screws, metal) and the other on the fader.

It is a classic issue if you work in a striped clean environment or the design of the unit dosent generate enough.
But I dont think it is the case here. When the field is to weak, it is a real pita to use.

Thank you for your help!
Yes, I will use auto-latch but touch mode is sometimes practical for little touches here and there. With auto-latch, I will have to hit stop rapidly before it overwrites the parts that I want to keep…
By writing my midi file to check the Midi messages, I now know that the MCU doesn’t stop sending the midi note. The note continues as long as I keep my finger on the fader. So it’s really mysterious why the automation writing stops if the MCU is still sending the note…

It is strange that it stops writing. Normaly the only thing that will stop the writing, even if the note transmit. Is the puch out. So working with loop can be abit of a challenge.

You can try and open the automation panel.
Open the setup (icon on the bottom left).
Select continue writing. And see if that will overrule the thing that is stopping the writing. This will ignore the punsh out.
So you can write automation more smothly in a loop.

Hi. So according to Mackie, my problem with touch automation in Cubase 9.5.30 is due to how cubase read the Mackie control protocol…
It would be awesome if someone in this forum also uses MCU pro with cubase 9.5.30 and could try to reproduce the same behavior.
I would be sure that my MCU is not broken…
Thank you.


Do you have some more specific information? What specifically is not in Cubase, as the Mackie Control Protocol defines? Is it new in Cubase 9.5.30 (according to Mackie)?

So I took my old MCU pro out off storage to see. My MCU pro has the P+G faders.

I got these results.

Using one fader in touch ruler, was no issue. Only issue was if my touch was sloppy. Then I got same result as you.

Using multible faders in touch mode was just a nighmare. Same result as you.

Changing ruler to auto latch, was smooth operation.

Cross over ruler was also a mess using multible channels.

Seams to me that the MCU pro faders are a bit “Touchy”. And it is starting to dim on me why my MCU pro has collected dust for years.

Think the best way of using the MCU pro is to use auto latch ruler.
To prevent disaster while doing automation edits, you can use Punch in and out.
In the preference setup you can go to Record and enable Stop after automatic punch out.

Now you just need to activate punch in/out, set a short punch in/out at the end of where you want to rewrite automation. Transport will stop at punch out. Punch in, is just to trigger the punch out setting.

You can custom map key commands for the punch in/out. So it is a quick task to enable/disable and set location.


Is it new in Cubase 9.5.30? Or can you reproduce it with older Cubase version(s) too, please?


Now I can also reproduce it. Reported to Steinberg (CAN-18617).

Btw, it works as expected with EuCon.

Thank you very much. That’s a huge thing for me to know that it’s a bug and not a hardware problem.
I have my MCU and extensions for just a couple of weeks so I’ve never tried on previous versions of Cubase. Only in 9.5.30.
Thank you and have a nice day.

I tested it on some older versions of cubase. This behavour is present in c4 and c6 on my older MCU pro.

Single fader use is no problem. But as soon as 2 or more faders are in use. The whole thing is just a mess. My guess is that it is a issue with the tick message (select track) on the Mackie Control protocol and how cubase handles that information.