Tracks volume not working properly when assigned to VCAs

I’d like to check here if there’s maybe something I’m doing wrong. I’ve been a Nuendo user sporadically, currently own v11 which I haven’t used for over a year maybe two years and I just downloaded v13 trial to get on board again. I immediately noticed a problem with VCAs that maybe you can tell me if it’s something I’m doing wrong or it’s a bug.

Steps to reproduce:

  1. On an empty session please add a new audio track and a VCA track
  2. Assign the audio track to the VCA track
  3. Lower the volume of the audio track to any given value by typing in the value field, let’s say -5dBs
  4. Lower the VCA track volume to -5dBs by typing in the value field

At this point the audio track should be at -10dBs as expected

  1. Now in the audio track type in -15dBs to lower its volume by -5dBs more

Now the audio track is at -20dBs which is not correct because it should be at -15dBs as we typed in -15dBs. At this point you can type in any value in the volume field of the audio track and the result won’t be correct. If you move the audio track out of the VCA assignment it behaves correctly again.

This is a screen capture where you can see it in action:

Please right-click on the GIF so you can open it in a new tab and it will be bigger.

I think is exactly how it is supposed to work, because VCA is prioritised or counter first over the track.

If VCA is A and Audio Track is B, then A+B=C
C is new Audio Track value.

So to get -15dB you should remove the -5dB decrease in the VCA at this point.

I would expect that. Also: vca are mostly uses for fader passes/rides not for typing in new values. So perhaps this is why it seems weird but it is not.

I’ve used VCAs all my career for global adjustments or automation passes on a bunch of tracks but those individual tracks that are assigned to the VCA tracks should not behave differently because they’re part of a VCA group. I mean, the volume in the individual track should obey the VCA group WHEN I move the fader in the VCA track otherwise I should be able to type in whatever value I want in it.

I must admit i’ve never tried to work the way you are testing, i only use vca for fader rides generally. So never experienced this and am currently behind Pro Tools without vca’s in the template.
So maybe you are right but how else would a VCA work technically then my simplified math above? How should nuendo know to ignore the vca? And why is it there in the first place if you want lower it on the audiotrack (by typing). To me it seems clear cut but perhaps I’m wrong.

Since you’re there on ProTools please try it. Follow my steps in ProTools and you’ll see what I mean. ProTools works correctly in this area.

Yeah, I think I understand what you’re talking about. The workflow I’ve always used in both Nuendo and Pro Tools is that I typically just write automation on VCAs on a controller. So I don’t think I’ve ever run into the situation you have.

There seems to be a fundamental difference and in Nuendo the level itself changes, so using the previous poster’s formula Nuendo is entirely logical.

Here’s what the manual says:

I’m not sure what the technical implications are for your workflow and how it is affected negatively now that you understand that this is functioning correctly - by design.

Thanks for participating, Mattias. Appreciated.

I think you don’t understand the issue so let me throw another example here:

Let’s say I have several Object tracks with different volumes in my Atmos mix that I want to control with a single VCA. I just add a VCA track and assign them to it, correct? Great, so far so good. Now I type -5dBs in the VCA track and all those Object tracks go down by -5dBs relatively to their previous volume values. Great, so far so good, smooth sailing until you try to type in a value in one of those Object tracks. Just try it by yourself, type in -2dBs in one of those Object tracks and you’ll notice that it won’t go down by -2dBs. It will go to whatever value it wants to. That’s the problem here because if I grab the volume fader of that Object track and lower it by -2dBs it will go down by -2dBs, why can’t it do the same when I type the value in?

I tried what you suggested earlier in both PT and Nuendo.

What you’re now describing is different. Now you seem to be saying that there’s a difference between using numerical entry and moving the fader. So now I tried that instead and indeed there seems to be something strange going on. But first things first:

1 - I entered “-5” into VCA
2 - I entered “-2” into A1 audio track:
image
(-5) + (-2) = -7

Seems correct given how the manual says it’s supposed to work.

3 - I entered “-7” into A1
(-5) + (-7) = -12

Again, seems correct. That’s what I see.

You’re right though that using the fader seems to give us a different result.

4 - I moved the fader to exactly -10

Number field then reads “-10”

It seems that:

  • Changing fader position sets total gain change.
  • Changing numerical value adds track gain to VCA gain.

Doing the latter therefore results in the fader moving to a different position than the value entered since the two are summed.


However, if I click into the number field of A1 and then click outside of that field without entering a new value it seems as if Nuendo applies the offset of the VCA to A1. So;

I clicked the number field
I clicked on the meter:

image

So, previous value I had in A1 was -12, and once I clicked on the meter the VCA’s -5 was applied and I now see -17. This is easy to test by going through these steps and changing the VCA to something arbitrary, like -3.5, which I did next, and then again click into A1 number field and clicking anywhere else in the app without entering a value:

image

(-15.5) + (-3.5) = -19

That seems to be a bug.


However - however…; Preexisting automation:

In my opinion ‘best practice’ in Nuendo is using automation points by default on audio and VCA tracks. All my templates have this so I’ve never run into this discrepancy between numerical entry and moving the fader, or the bug.

I’ve never bothered much with typing in automation because I just don’t do that, and now that I’ve tested it I realize I’m too tired to continue looking at this… Because I see a slightly different behavior when automation is present… Maybe tomorrow or after coffee or something I’ll look at it again…

Wel, if there is already existing automation, or the new automation of the VCA written into that individual track, it, of course, will not go down a further 2dB. It will read whatever the last automation was. Especially if you manually enter a numerical value into the little box.

Fader Automation is not a “static” system, where you can enter numbers in a box, and have the entire automation for the entire track change. It is an “active” system, where you are playing back, and it will either play or record automation moves, but, ONLY when you are playing back.

To change an individual track’s level, apart from the VCA, you have to select that tracks ENTIRE automation points, and then use the mouse to bring them up or down by the amount you wanted.

Cheers.

Thanks again for taking the time to give it a look, Mattias. We’re always very busy and spending a few minutes to check this is truly appreciated.

Maybe I didn’t explain it properly the first time but what I said above in my first reply to you is exactly what I meant and I’m glad we’re now understanding each other.

It seems that:

  • Changing fader position sets total gain change.
  • Changing numerical value adds track gain to VCA gain.

Yes, exactly. I would expect both behaviors to be the same.

The other behavior you mentioned about the VCA offset being applied every time we click the number field is also a bug to me. Thanks for mentioning that, I noticed it as well. In fact, I noticed a few other strange behaviors with VCAs that I will probably investigate further at some point.

Hi there!

Yes, I understand all that. I’ve been using automation with controllers and several other systems for many years. What you are describing is not related to the problem I’m exposing here because I’m not including automation anywhere in my description of the problem. I understand that most of us think about automation when someone says “VCA” but that’s not the case here.

hi. thanks for chiming in everyone. I think I don’t really understand the issue very well. To me it seems like you are using vca’s wrong (because you do not use as @noeqplease describes it, thanks for that).

I think is that there is a better way to do what you do, by using a trim function or using another parameter to set the gain of an object (the clip gain or event volume for example).

My reasoning: If you want a specific object in an atmos mix to be -5dB why not just select that object and change the event volume? isn’t that a much easier way to adjust it’s level AND leave the VCA and volume automation intact?

To be clear: I’m not saying you shouldn’t use VCA the way you do, especially since. it seems like you can in PT this way, I just think it is wrong tool for the job.

What’s the best way to report this to Steinberg? I looked around and apparently you have to report this to a local distributor. Is this the only way or there’s an official contact form we can fill in to report bugs?

Reporting in a clear manner in a topic on this forum is one way, but you are unlikely to get any direct response. The following from the Cubase forum might help: How to format a bug report

1 Like

Thank you. Hope it’s clear enough for Steinberg devs to understand the bug.

If you were to reiterate the ‘bug’ in a simplified step-by-step form at the end of this topic it might draw more attention. But TBH, your first post in this topic seems to do a good job of describing the issue in step-by-step form anyway.

Hello

This look like the same bug as in Cubase:

1 Like

It’s a different bug.

1 Like